Bug 275176 - Kwin crash clicking on menu button
Summary: Kwin crash clicking on menu button
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-08 04:21 UTC by Calvin Arndt
Modified: 2011-06-08 11:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Calvin Arndt 2011-06-08 04:21:29 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
Attempting to open the K menu

- Unusual behavior I noticed:

Just prior I open firefox download dialog but when it appeared it did not have a window border?
I moved the dialog via alt + left mouse button and the dialogs border appeared. I closed the dialog
and then closed firefox. Next I clicked the K menu button. Kwin segfaulted...

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f05de2f67a0 (LWP 1538))]

Thread 3 (Thread 0x7f05bec77700 (LWP 1556)):
#0  0x00007f05ddb3e143 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f05d9f1c32c in qt_safe_select (nfds=17, fdread=0x39c90e0, fdwrite=0x39c9378, fdexcept=0x39c9610, orig_timeout=<value optimized out>) at kernel/qcore_unix.cpp:82
#2  0x00007f05d9f213d0 in QEventDispatcherUNIXPrivate::doSelect (this=0x39c8f20, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#3  0x00007f05d9f2204a in QEventDispatcherUNIX::processEvents (this=0x38d79e0, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#4  0x00007f05d9ef3882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f05d9ef3abc in QEventLoop::exec (this=0x7f05bec76db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f05d9e0a924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f05d9ed5c2f in QInotifyFileSystemWatcherEngine::run (this=0x3a90340) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f05d9e0d175 in QThreadPrivate::start (arg=0x3a90340) at thread/qthread_unix.cpp:320
#9  0x00007f05d4500d8c in start_thread (arg=0x7f05bec77700) at pthread_create.c:304
#10 0x00007f05ddb4604d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f05be476700 (LWP 1557)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f05dc9a52a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f05dccbe180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f05dc9a52d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f05dcccc254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f05d4500d8c in start_thread (arg=0x7f05be476700) at pthread_create.c:304
#4  0x00007f05ddb4604d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f05de2f67a0 (LWP 1538)):
[KCrash Handler]
#6  intel_region_buffer (intel=0x26402f0, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007f05c59e86c2 in intelClearWithBlit (ctx=0x26402f0, mask=2) at intel_blit.c:262
#8  0x00007f05c59ead2a in intelClear (ctx=0x26402f0, mask=2) at intel_clear.c:177
#9  0x00007f05ddebcce7 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#10 0x00007f05ddeb488f in KWin::Scene::paintGenericScreen (this=0x263af00, orig_mask=544) at ../../kwin/scene.cpp:188
#11 0x00007f05ddeb1c7a in KWin::Scene::finalPaintScreen (this=0x263af00, mask=544, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:178
#12 0x00007f05ddecff19 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=544, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#13 0x00007f05c4a9a5a6 in KWin::StartupFeedbackEffect::paintScreen (this=0x38b6870, mask=544, region=<value optimized out>, data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=544, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#15 0x00007f05dbf8fa18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=544, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=544, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#17 0x00007f05c4a4144d in KWin::LogoutEffect::paintScreen (this=0x3c3fe80, mask=544, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#18 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=544, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#19 0x00007f05c4a5c57b in KWin::ShadowEffect::paintScreen (this=0x3b54a60, mask=544, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#20 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=544, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#21 0x00007f05c4a6ee68 in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=544, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#22 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=512, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#23 0x00007f05c4a45fbd in KWin::PresentWindowsEffect::paintScreen (this=0x37e61c0, mask=512, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=512, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#25 0x00007f05dbf8fa18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=512, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=512, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#27 0x00007f05dbf8fa18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=512, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=512, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#29 0x00007f05dbf8fa18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=512, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=512, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#31 0x00007f05dbf8fa18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=512, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=512, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#33 0x00007f05c4a2d365 in KWin::DesktopGridEffect::paintScreen (this=0x37ddc20, mask=512, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#34 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=512, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#35 0x00007f05c4a62b8f in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=512, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#36 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=512, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#37 0x00007f05c4a26bad in KWin::BoxSwitchEffect::paintScreen (this=0x38c0b90, mask=512, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#38 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=512, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#39 0x00007f05c4a7d256 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=512, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#40 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=512, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#41 0x00007f05dbf8fa18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=512, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=512, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#43 0x00007f05dbf8fa18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=512, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=512, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#45 0x00007f05dbf8fa18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=512, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=512, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#47 0x00007f05c4a75d86 in KWin::CoverSwitchEffect::paintScreen (this=0x3997750, mask=512, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#48 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=512, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#49 0x00007f05dbf8fa18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=512, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#50 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=512, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#51 0x00007f05dbf8fa18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=512, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=512, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#53 0x00007f05c4a6c39b in KWin::ZoomEffect::paintScreen (this=0x3a6b510, mask=512, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#54 0x00007f05ddecffa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x376bb70, mask=512, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#55 0x00007f05ddeb40af in KWin::Scene::paintScreen (this=0x263af00, mask=0x7fff68e4c60c, region=0x7fff68e4c6d0) at ../../kwin/scene.cpp:137
#56 0x00007f05ddec7ef3 in KWin::SceneOpenGL::paint (this=0x263af00, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#57 0x00007f05ddeaf396 in KWin::Workspace::performCompositing (this=0x7f05c0353fe0) at ../../kwin/composite.cpp:448
#58 0x00007f05d9f081c9 in QObject::event (this=0x7f05c0353fe0, e=<value optimized out>) at kernel/qobject.cpp:1190
#59 0x00007f05d92b59e4 in QApplicationPrivate::notify_helper (this=0x25413e0, receiver=0x7f05c0353fe0, e=0x7fff68e4ce60) at kernel/qapplication.cpp:4462
#60 0x00007f05d92ba3aa in QApplication::notify (this=<value optimized out>, receiver=0x7f05c0353fe0, e=0x7fff68e4ce60) at kernel/qapplication.cpp:4341
#61 0x00007f05dd641866 in KApplication::notify (this=0x7fff68e4d260, receiver=0x7f05c0353fe0, event=0x7fff68e4ce60) at ../../kdeui/kernel/kapplication.cpp:311
#62 0x00007f05d9ef449c in QCoreApplication::notifyInternal (this=0x7fff68e4d260, receiver=0x7f05c0353fe0, event=0x7fff68e4ce60) at kernel/qcoreapplication.cpp:731
#63 0x00007f05d9f21f12 in sendEvent (this=0x2543270) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#64 QTimerInfoList::activateTimers (this=0x2543270) at kernel/qeventdispatcher_unix.cpp:604
#65 0x00007f05d9f2205b in QEventDispatcherUNIX::processEvents (this=0x24e6340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#66 0x00007f05d935dc0c in QEventDispatcherX11::processEvents (this=0x24e6340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#67 0x00007f05d9ef3882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#68 0x00007f05d9ef3abc in QEventLoop::exec (this=0x7fff68e4d1a0, flags=...) at kernel/qeventloop.cpp:201
#69 0x00007f05d9ef7ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#70 0x00007f05dde4d1ec in kdemain (argc=<value optimized out>, argv=0x7fff68e4d8f8) at ../../kwin/main.cpp:542
#71 0x00007f05dda7eeff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fff68e4d8f8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff68e4d8e8) at libc-start.c:226
#72 0x0000000000400669 in _start ()

Possible duplicates by query: bug 274967, bug 273989, bug 273601, bug 273553, bug 273495.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-06-08 11:03:55 UTC
driver bug, likely related to closing flash.

*** This bug has been marked as a duplicate of bug 252817 ***