Bug 273495 - Kwin Crashing when coming out of MythTV Frontend
Summary: Kwin Crashing when coming out of MythTV Frontend
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-17 17:21 UTC by Steve Murray
Modified: 2011-05-17 17:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Murray 2011-05-17 17:21:59 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed: Exiting MythTV - Usually (but not everytime) when I exit MythTV Frontend (which is running in fullscreen mode and using OpenGL) Kwin Crashes.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f41a997f7a0 (LWP 2092))]

Thread 3 (Thread 0x7f418a5ed700 (LWP 2097)):
#0  0x00007f41a91d1143 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f41a55af32c in qt_safe_select (nfds=17, fdread=0x3aab2f0, fdwrite=0x3aab588, fdexcept=0x3aab820, orig_timeout=<value optimized out>) at kernel/qcore_unix.cpp:82
#2  0x00007f41a55b43d0 in QEventDispatcherUNIXPrivate::doSelect (this=0x3aab130, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#3  0x00007f41a55b504a in QEventDispatcherUNIX::processEvents (this=0x3a84df0, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#4  0x00007f41a5586882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f41a5586abc in QEventLoop::exec (this=0x7f418a5ecdb0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f41a549d924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f41a5568c2f in QInotifyFileSystemWatcherEngine::run (this=0x3aa9fb0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f41a54a0175 in QThreadPrivate::start (arg=0x3aa9fb0) at thread/qthread_unix.cpp:320
#9  0x00007f419fb93d8c in start_thread (arg=0x7f418a5ed700) at pthread_create.c:304
#10 0x00007f41a91d904d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f4189dec700 (LWP 2098)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f41a80382a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f41a8351180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f41a80382d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f41a835f254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f419fb93d8c in start_thread (arg=0x7f4189dec700) at pthread_create.c:304
#4  0x00007f41a91d904d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f41a997f7a0 (LWP 2092)):
[KCrash Handler]
#6  intel_region_buffer (intel=0x24e4a70, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007f41911e06c2 in intelClearWithBlit (ctx=0x24e4a70, mask=2) at intel_blit.c:262
#8  0x00007f41911e2d2a in intelClear (ctx=0x24e4a70, mask=2) at intel_clear.c:177
#9  0x00007f41a954fce7 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#10 0x00007f41a954788f in KWin::Scene::paintGenericScreen (this=0x24d80d0, orig_mask=552) at ../../kwin/scene.cpp:188
#11 0x00007f41a9544c7a in KWin::Scene::finalPaintScreen (this=0x24d80d0, mask=552, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:178
#12 0x00007f41a9562f19 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=552, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#13 0x00007f41902655a6 in KWin::StartupFeedbackEffect::paintScreen (this=0x3ade160, mask=552, region=<value optimized out>, data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=552, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#15 0x00007f41a7622a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=552, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=552, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#17 0x00007f419020c44d in KWin::LogoutEffect::paintScreen (this=0x3991ce0, mask=552, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#18 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=552, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#19 0x00007f419022757b in KWin::ShadowEffect::paintScreen (this=0x39a82d0, mask=552, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#20 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=552, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#21 0x00007f4190239e68 in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=552, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#22 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#23 0x00007f4190210fbd in KWin::PresentWindowsEffect::paintScreen (this=0x37af900, mask=520, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#25 0x00007f41a7622a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#27 0x00007f41a7622a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#29 0x00007f41a7622a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#31 0x00007f41a7622a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#33 0x00007f4190257c05 in KWin::FlipSwitchEffect::paintScreen (this=0x3690860, mask=520, region=..., data=...) at ../../../kwin/effects/flipswitch/flipswitch.cpp:148
#34 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#35 0x00007f41901f8365 in KWin::DesktopGridEffect::paintScreen (this=0x385b270, mask=520, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#36 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#37 0x00007f419022db8f in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=520, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#38 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#39 0x00007f41901f1bad in KWin::BoxSwitchEffect::paintScreen (this=0x3ac77b0, mask=520, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#40 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#41 0x00007f4190248256 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=520, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#42 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#43 0x00007f41a7622a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#45 0x00007f41a7622a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#47 0x00007f41a7622a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#48 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#49 0x00007f4190240d86 in KWin::CoverSwitchEffect::paintScreen (this=0x399f9d0, mask=520, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#50 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#51 0x00007f41a7622a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#53 0x00007f41a7622a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#54 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#55 0x00007f419023739b in KWin::ZoomEffect::paintScreen (this=0x38aa450, mask=520, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#56 0x00007f41a9562fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x360eb40, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#57 0x00007f41a95470af in KWin::Scene::paintScreen (this=0x24d80d0, mask=0x7fff9181554c, region=0x7fff91815610) at ../../kwin/scene.cpp:137
#58 0x00007f41a955aef3 in KWin::SceneOpenGL::paint (this=0x24d80d0, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#59 0x00007f41a9542396 in KWin::Workspace::performCompositing (this=0x28097f0) at ../../kwin/composite.cpp:448
#60 0x00007f41a559b1c9 in QObject::event (this=0x28097f0, e=<value optimized out>) at kernel/qobject.cpp:1190
#61 0x00007f41a49489e4 in QApplicationPrivate::notify_helper (this=0x23f5cd0, receiver=0x28097f0, e=0x7fff91815da0) at kernel/qapplication.cpp:4462
#62 0x00007f41a494d3aa in QApplication::notify (this=<value optimized out>, receiver=0x28097f0, e=0x7fff91815da0) at kernel/qapplication.cpp:4341
#63 0x00007f41a8cd4866 in KApplication::notify (this=0x7fff918161a0, receiver=0x28097f0, event=0x7fff91815da0) at ../../kdeui/kernel/kapplication.cpp:311
#64 0x00007f41a558749c in QCoreApplication::notifyInternal (this=0x7fff918161a0, receiver=0x28097f0, event=0x7fff91815da0) at kernel/qcoreapplication.cpp:731
#65 0x00007f41a55b4f12 in sendEvent (this=0x23f77c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#66 QTimerInfoList::activateTimers (this=0x23f77c0) at kernel/qeventdispatcher_unix.cpp:604
#67 0x00007f41a55b505b in QEventDispatcherUNIX::processEvents (this=0x239a340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#68 0x00007f41a49f0c0c in QEventDispatcherX11::processEvents (this=0x239a340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#69 0x00007f41a5586882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#70 0x00007f41a5586abc in QEventLoop::exec (this=0x7fff918160e0, flags=...) at kernel/qeventloop.cpp:201
#71 0x00007f41a558aecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#72 0x00007f41a94e01ec in kdemain (argc=<value optimized out>, argv=0x7fff91816838) at ../../kwin/main.cpp:542
#73 0x00007f41a9111eff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fff91816838, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff91816828) at libc-start.c:226
#74 0x0000000000400669 in _start ()

Possible duplicates by query: bug 273464, bug 273271, bug 273246, bug 273242, bug 273078.

Reported using DrKonqi
Comment 1 Martin Flöser 2011-05-17 17:37:41 UTC
driver bug

*** This bug has been marked as a duplicate of bug 252817 ***