Bug 273989 - Kwin crash closing the game 0Ad
Summary: Kwin crash closing the game 0Ad
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-23 21:49 UTC by jordeath.gedeon
Modified: 2011-05-23 22:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jordeath.gedeon 2011-05-23 21:49:33 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic-pae i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
closing 0AD (game) Kwin has had an accident.
after clicking the exit button has fallen Kwin

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb2863720 (LWP 1581))]

Thread 3 (Thread 0xad1b4b70 (LWP 1728)):
#0  0xb37acd41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb643cdd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb65094f2 in updateCurrentTime (this=0x95176c8, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x95176c8, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb650b3a3 in QEventDispatcherUNIX::processEvents (this=0x92c4430, flags=...) at kernel/qeventdispatcher_unix.cpp:906
#6  0xb64da289 in QEventLoop::processEvents (this=0xad1b4280, flags=...) at kernel/qeventloop.cpp:149
#7  0xb64da522 in QEventLoop::exec (this=0xad1b4280, flags=...) at kernel/qeventloop.cpp:201
#8  0xb63e42a0 in QThread::exec (this=0x92d1058) at thread/qthread.cpp:492
#9  0xb64bbfdb in QInotifyFileSystemWatcherEngine::run (this=0x92d1058) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb63e6da2 in QThreadPrivate::start (arg=0x92d1058) at thread/qthread_unix.cpp:320
#11 0xb387ae99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb754573e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xac9b3b70 (LWP 1729)):
#0  0xb7702424 in __kernel_vsyscall ()
#1  0xb387f48c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb75533fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb6cd1817 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb6de51c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0xb6cd1851 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb6de51c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0xb387ae99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb754573e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb2863720 (LWP 1581)):
[KCrash Handler]
#7  intel_region_buffer (intel=0x8f0f380, region=0x0, flag=2) at intel_regions.c:514
#8  0xaf86fce2 in intelClearWithBlit (ctx=0x8f0f380, mask=2) at intel_blit.c:262
#9  0xaf8724c0 in intelClear (ctx=0x8f0f380, mask=2) at intel_clear.c:177
#10 0xaf69c512 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:241
#11 0xb76b584b in KWin::SceneOpenGL::paintBackground (this=0x8f4a9e0, region=...) at ../../kwin/scene_opengl.cpp:921
#12 0xb76ac562 in KWin::Scene::paintGenericScreen (this=0x8f4a9e0, orig_mask=40) at ../../kwin/scene.cpp:188
#13 0xb76b5a31 in KWin::SceneOpenGL::paintGenericScreen (this=0x8f4a9e0, mask=40, data=...) at ../../kwin/scene_opengl.cpp:909
#14 0xb76a97c0 in KWin::Scene::finalPaintScreen (this=0x8f4a9e0, mask=40, region=..., data=...) at ../../kwin/scene.cpp:178
#15 0xb76cb0fc in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=40, region=..., data=...) at ../../kwin/effects.cpp:173
#16 0xae4209d5 in KWin::SnowEffect::paintScreen (this=0x93589f0, mask=40, region=..., data=...) at ../../../kwin/effects/snow/snow.cpp:120
#17 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#18 0xae4210e9 in KWin::StartupFeedbackEffect::paintScreen (this=0x93aa590, mask=40, region=..., data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#19 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#20 0xb6ad1256 in KWin::Effect::paintScreen (this=0x93be780, mask=40, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#21 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#22 0xae3c307f in KWin::LogoutEffect::paintScreen (this=0x93e0be8, mask=40, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#23 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#24 0xae3deb10 in KWin::ShadowEffect::paintScreen (this=0x946eae0, mask=40, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#25 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#26 0xae3f3013 in KWin::BlurEffect::paintScreen (this=0x928f858, mask=40, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#27 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#28 0xae3c7e6f in KWin::PresentWindowsEffect::paintScreen (this=0x92a6708, mask=8, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#29 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#30 0xb6ad1256 in KWin::Effect::paintScreen (this=0x9318058, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#32 0xb6ad1256 in KWin::Effect::paintScreen (this=0x9317fe8, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#33 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#34 0xb6ad1256 in KWin::Effect::paintScreen (this=0x9319138, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#35 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#36 0xb6ad1256 in KWin::Effect::paintScreen (this=0x92913e8, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#37 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#38 0xae3ae7e9 in KWin::DesktopGridEffect::paintScreen (this=0x9482660, mask=8, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#39 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#40 0xae3a7799 in KWin::BoxSwitchEffect::paintScreen (this=0x948a628, mask=8, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#41 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#42 0xae401bcc in KWin::CubeEffect::paintScreen (this=0x94463a8, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#43 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#44 0xb6ad1256 in KWin::Effect::paintScreen (this=0x94460a8, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#45 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#46 0xae40adf0 in KWin::CubeSlideEffect::paintScreen (this=0x9371490, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cubeslide.cpp:111
#47 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#48 0xb6ad1256 in KWin::Effect::paintScreen (this=0x93688d0, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#49 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#50 0xb6ad1256 in KWin::Effect::paintScreen (this=0x932b420, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#51 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#52 0xae3faa0c in KWin::CoverSwitchEffect::paintScreen (this=0x9317b18, mask=8, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#53 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#54 0xb6ad1256 in KWin::Effect::paintScreen (this=0x9382e98, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#55 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#56 0xb6ad1256 in KWin::Effect::paintScreen (this=0x9280f78, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#57 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#58 0xb6ad1256 in KWin::Effect::paintScreen (this=0x94d77a8, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#59 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#60 0xae3f00c1 in KWin::ZoomEffect::paintScreen (this=0x93dfb28, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#61 0xb76cb172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9233cc8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#62 0xb76aa98c in KWin::Scene::paintScreen (this=0x8f4a9e0, mask=0xbfe2b5b8, region=0xbfe2b640) at ../../kwin/scene.cpp:137
#63 0xb76c1962 in KWin::SceneOpenGL::paint (this=0x8f4a9e0, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:772
#64 0xb76a6886 in KWin::Workspace::performCompositing (this=0x8f45f60) at ../../kwin/composite.cpp:448
#65 0xb64f0214 in QObject::event (this=0x8f45f60, e=0xbfe2bb6c) at kernel/qobject.cpp:1190
#66 0xb5a34d24 in QApplicationPrivate::notify_helper (this=0x8e89f78, receiver=0x8f45f60, e=0xbfe2bb6c) at kernel/qapplication.cpp:4462
#67 0xb5a398ce in QApplication::notify (this=0xbfe2be84, receiver=0x8f45f60, e=0xbfe2bb6c) at kernel/qapplication.cpp:3862
#68 0xb72ab3ca in KApplication::notify (this=0xbfe2be84, receiver=0x8f45f60, event=0xbfe2bb6c) at ../../kdeui/kernel/kapplication.cpp:311
#69 0xb7635abf in KWin::Application::notify (this=0xbfe2be84, o=0x8f45f60, e=0xbfe2bb6c) at ../../kwin/main.cpp:376
#70 0xb64db0bb in QCoreApplication::notifyInternal (this=0xbfe2be84, receiver=0x8f45f60, event=0xbfe2bb6c) at kernel/qcoreapplication.cpp:731
#71 0xb650b1e4 in sendEvent (this=0x8e89768) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#72 QTimerInfoList::activateTimers (this=0x8e89768) at kernel/qeventdispatcher_unix.cpp:604
#73 0xb650b338 in QEventDispatcherUNIX::processEvents (this=0x8e47ac0, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#74 0xb5ae97ea in QEventDispatcherX11::processEvents (this=0x8e47ac0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#75 0xb64da289 in QEventLoop::processEvents (this=0xbfe2bdc4, flags=...) at kernel/qeventloop.cpp:149
#76 0xb64da522 in QEventLoop::exec (this=0xbfe2bdc4, flags=...) at kernel/qeventloop.cpp:201
#77 0xb64deecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#78 0xb5a328e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#79 0xb76385b2 in kdemain (argc=3, argv=0xbfe2c104) at ../../kwin/main.cpp:542
#80 0x080485bb in main (argc=3, argv=0xbfe2c104) at kwin_dummy.cpp:3

Possible duplicates by query: bug 273601, bug 273553, bug 273495, bug 273464, bug 273271.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-05-23 22:21:17 UTC
driver bug, see comment #84 in bug #252817 for a workaround.

*** This bug has been marked as a duplicate of bug 252817 ***
Comment 2 jordeath.gedeon 2011-05-23 22:29:08 UTC
thank you very much ... do a great job!



2011/5/23 Thomas Lübking <thomas.luebking@gmail.com>

> https://bugs.kde.org/show_bug.cgi?id=273989
>
>
> Thomas Lübking <thomas.luebking@gmail.com> changed:
>
>           What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>             Status|UNCONFIRMED                 |RESOLVED
>         Resolution|                            |DUPLICATE
>
>
>
>
> --- Comment #1 from Thomas Lübking <thomas luebking gmail com>  2011-05-23
> 22:21:17 ---
> driver bug, see comment #84 in bug #252817 for a workaround.
>
> *** This bug has been marked as a duplicate of bug 252817 ***
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.