Bug 273601 - Guild Wars Wine 1.3.16
Summary: Guild Wars Wine 1.3.16
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-19 00:54 UTC by Daniel O'Keefe
Modified: 2011-08-27 03:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (11.21 KB, text/plain)
2011-08-27 03:33 UTC, Alexis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel O'Keefe 2011-05-19 00:54:17 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-9-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:Playing Guild Wars then shutting the game down creates the crash

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb786b720 (LWP 3567))]

Thread 3 (Thread 0xb2f12b70 (LWP 3573)):
#0  0x0525fd41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x02b06dd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x02bd4525 in updateCurrentTime (this=0xb2600498, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:339
#4  QEventDispatcherUNIXPrivate::doSelect (this=0xb2600498, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:182
#5  0x02bd5326 in QEventDispatcherUNIX::processEvents (this=0xb2600488, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#6  0x02ba4289 in QEventLoop::processEvents (this=0xb2f12280, flags=...) at kernel/qeventloop.cpp:149
#7  0x02ba4522 in QEventLoop::exec (this=0xb2f12280, flags=...) at kernel/qeventloop.cpp:201
#8  0x02aae2a0 in QThread::exec (this=0x9e0dff0) at thread/qthread.cpp:492
#9  0x02b85fdb in QInotifyFileSystemWatcherEngine::run (this=0x9e0dff0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x02ab0da2 in QThreadPrivate::start (arg=0x9e0dff0) at thread/qthread_unix.cpp:320
#11 0x087c5e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x0095e73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb25ffb70 (LWP 3574)):
#0  0x007ab416 in __kernel_vsyscall ()
#1  0x087ca48c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x0096c3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x00e14817 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xf281c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x00e14851 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xf281c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x087c5e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x0095e73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb786b720 (LWP 3567)):
[KCrash Handler]
#7  intel_region_buffer (intel=0x982b7c8, region=0x0, flag=2) at intel_regions.c:514
#8  0x023d5ce2 in intelClearWithBlit (ctx=0x982b7c8, mask=2) at intel_blit.c:262
#9  0x023d84c0 in intelClear (ctx=0x982b7c8, mask=2) at intel_clear.c:177
#10 0x069c3512 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:241
#11 0x001d984b in KWin::SceneOpenGL::paintBackground (this=0x9853590, region=...) at ../../kwin/scene_opengl.cpp:921
#12 0x001d0562 in KWin::Scene::paintGenericScreen (this=0x9853590, orig_mask=32) at ../../kwin/scene.cpp:188
#13 0x001d9a31 in KWin::SceneOpenGL::paintGenericScreen (this=0x9853590, mask=32, data=...) at ../../kwin/scene_opengl.cpp:909
#14 0x001cd7c0 in KWin::Scene::finalPaintScreen (this=0x9853590, mask=32, region=..., data=...) at ../../kwin/scene.cpp:178
#15 0x001ef0fc in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=32, region=..., data=...) at ../../kwin/effects.cpp:173
#16 0x024f70e9 in KWin::StartupFeedbackEffect::paintScreen (this=0x9d12570, mask=32, region=..., data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#18 0x00657256 in KWin::Effect::paintScreen (this=0x9da2658, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#19 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#20 0x0249907f in KWin::LogoutEffect::paintScreen (this=0x9c01dc0, mask=32, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#21 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#22 0x024b4b10 in KWin::ShadowEffect::paintScreen (this=0x9d8d190, mask=32, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#23 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#24 0x024c9013 in KWin::BlurEffect::paintScreen (this=0x9bbbd08, mask=32, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#25 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#26 0x0249de6f in KWin::PresentWindowsEffect::paintScreen (this=0x9bb52d8, mask=0, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#27 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#28 0x00657256 in KWin::Effect::paintScreen (this=0x9d75870, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#29 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#30 0x00657256 in KWin::Effect::paintScreen (this=0x9cdc490, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#32 0x00657256 in KWin::Effect::paintScreen (this=0x9df9dc8, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#33 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#34 0x00657256 in KWin::Effect::paintScreen (this=0x9c1ae08, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#35 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#36 0x024847e9 in KWin::DesktopGridEffect::paintScreen (this=0x9c8a538, mask=0, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#37 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#38 0x024bbce2 in KWin::SlideEffect::paintScreen (this=0x9c33cc0, mask=0, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#39 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#40 0x0247d799 in KWin::BoxSwitchEffect::paintScreen (this=0x9bb69f8, mask=0, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#41 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#42 0x024d7bcc in KWin::CubeEffect::paintScreen (this=0x9deaab0, mask=0, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#43 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#44 0x00657256 in KWin::Effect::paintScreen (this=0x9c95310, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#45 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#46 0x00657256 in KWin::Effect::paintScreen (this=0x9cd91f8, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#47 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#48 0x00657256 in KWin::Effect::paintScreen (this=0x9bb60c0, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#49 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#50 0x024d0a0c in KWin::CoverSwitchEffect::paintScreen (this=0x9cbe990, mask=0, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#51 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#52 0x00657256 in KWin::Effect::paintScreen (this=0x9bbbe68, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#53 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#54 0x00657256 in KWin::Effect::paintScreen (this=0x9da1330, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#55 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#56 0x024c60c1 in KWin::ZoomEffect::paintScreen (this=0x9bc0b98, mask=0, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#57 0x001ef172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9b4e870, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#58 0x001ce98c in KWin::Scene::paintScreen (this=0x9853590, mask=0xbfa61788, region=0xbfa61810) at ../../kwin/scene.cpp:137
#59 0x001e5962 in KWin::SceneOpenGL::paint (this=0x9853590, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:772
#60 0x001ca886 in KWin::Workspace::performCompositing (this=0x9860040) at ../../kwin/composite.cpp:448
#61 0x02bba214 in QObject::event (this=0x9860040, e=0xbfa61d3c) at kernel/qobject.cpp:1190
#62 0x053dcd24 in QApplicationPrivate::notify_helper (this=0x976bbf0, receiver=0x9860040, e=0xbfa61d3c) at kernel/qapplication.cpp:4462
#63 0x053e18ce in QApplication::notify (this=0xbfa62054, receiver=0x9860040, e=0xbfa61d3c) at kernel/qapplication.cpp:3862
#64 0x004053ca in KApplication::notify (this=0xbfa62054, receiver=0x9860040, event=0xbfa61d3c) at ../../kdeui/kernel/kapplication.cpp:311
#65 0x00159abf in KWin::Application::notify (this=0xbfa62054, o=0x9860040, e=0xbfa61d3c) at ../../kwin/main.cpp:376
#66 0x02ba50bb in QCoreApplication::notifyInternal (this=0xbfa62054, receiver=0x9860040, event=0xbfa61d3c) at kernel/qcoreapplication.cpp:731
#67 0x02bd51e4 in sendEvent (this=0x97709a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#68 QTimerInfoList::activateTimers (this=0x97709a0) at kernel/qeventdispatcher_unix.cpp:604
#69 0x02bd5338 in QEventDispatcherUNIX::processEvents (this=0x972aaa8, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#70 0x054917ea in QEventDispatcherX11::processEvents (this=0x972aaa8, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#71 0x02ba4289 in QEventLoop::processEvents (this=0xbfa61f94, flags=...) at kernel/qeventloop.cpp:149
#72 0x02ba4522 in QEventLoop::exec (this=0xbfa61f94, flags=...) at kernel/qeventloop.cpp:201
#73 0x02ba8ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#74 0x053da8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#75 0x0015c5b2 in kdemain (argc=3, argv=0xbfa622d4) at ../../kwin/main.cpp:542
#76 0x080485bb in main (argc=3, argv=0xbfa622d4) at kwin_dummy.cpp:3

Possible duplicates by query: bug 273553, bug 273495, bug 273464, bug 273271, bug 273246.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-05-19 01:11:27 UTC
driver bug, see comment #84 in bug #252817 for a workaround.

*** This bug has been marked as a duplicate of bug 252817 ***
Comment 2 Alexis 2011-08-27 03:33:03 UTC
Created attachment 63167 [details]
New crash information added by DrKonqi

kwin (4.7.00 (4.7.0)) on KDE Platform 4.7.00 (4.7.0) using Qt 4.7.2

- What I was doing when the application crashed:

I was playing with the Epsxe in wine, later epsxe out fullscreen and kwin crashes

- Custom settings of the application:

Epsxe in fullscreen(wine)

-- Backtrace (Reduced):
#7  intel_region_buffer (intel=0x964dfe0, region=0x0, flag=2) at intel_regions.c:514
#8  0x02d37742 in intelClearWithBlit (ctx=0x964dfe0, mask=2) at intel_blit.c:262
#9  0x02d30670 in intelClear (ctx=0x964dfe0, mask=2) at intel_clear.c:177
#10 0x0358e512 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:241
#11 0x00a4630f in KWin::SceneOpenGL::paintBackground (this=0x950e0d8, region=...) at ../../kwin/scene_opengl.cpp:182