Bug 273553 - absturz bbei screensaver
Summary: absturz bbei screensaver
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-18 12:14 UTC by patrickscholz
Modified: 2011-05-18 17:28 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description patrickscholz 2011-05-18 12:14:40 UTC
Application: kwin (4.6.00 (4.6.0) "release 6")
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.6-0.5-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
Screensaver GL... stürtzt ab nach ~10 min

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f3a573f2760 (LWP 10360))]

Thread 2 (Thread 0x7f3a3dc13700 (LWP 10385)):
#0  0x00007f3a52ccb38c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f3a55ac7044 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f3a55de0180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f3a55ac7079 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f3a55dee254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f3a52cc6a3f in start_thread () from /lib64/libpthread.so.0
#4  0x00007f3a56c5967d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3a573f2760 (LWP 10360)):
[KCrash Handler]
#6  intel_region_buffer (intel=0x797c10, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007f3a3ee782d4 in intelClearWithBlit (ctx=0x797c10, mask=2) at intel_blit.c:262
#8  0x00007f3a3ee7a7da in intelClear (ctx=0x797c10, mask=2) at intel_clear.c:177
#9  0x00007f3a56fbe625 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:921
#10 0x00007f3a56fb5d96 in KWin::Scene::paintGenericScreen (this=0x792bd0, orig_mask=32) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:188
#11 0x00007f3a56fb2eea in KWin::Scene::finalPaintScreen (this=0x792bd0, mask=32, region=<value optimized out>, data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:178
#12 0x00007f3a56fd038f in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:173
#13 0x00007f3a3e375d7b in KWin::StartupFeedbackEffect::paintScreen (this=0x1e0a580, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#15 0x00007f3a550b5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#16 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#17 0x00007f3a3e31cf3f in KWin::LogoutEffect::paintScreen (this=0x1b8bc30, mask=32, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/logout/logout.cpp:207
#18 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#19 0x00007f3a3e337b72 in KWin::ShadowEffect::paintScreen (this=0x1c6e700, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/shadow/shadow.cpp:189
#20 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#21 0x00007f3a3e34a4fe in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/blur/blur.cpp:230
#22 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#23 0x00007f3a3e3219c2 in KWin::PresentWindowsEffect::paintScreen (this=0x1ebfb10, mask=0, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#25 0x00007f3a550b5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#26 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#27 0x00007f3a550b5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#28 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#29 0x00007f3a550b5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#30 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#31 0x00007f3a550b5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#32 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#33 0x00007f3a3e3082a3 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/desktopgrid/desktopgrid.cpp:155
#34 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#35 0x00007f3a3e33e34d in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/slide/slide.cpp:86
#36 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#37 0x00007f3a3e300e42 in KWin::BoxSwitchEffect::paintScreen (this=0x1dfb170, mask=0, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/boxswitch/boxswitch.cpp:143
#38 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#39 0x00007f3a550b5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#40 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#41 0x00007f3a550b5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#42 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#43 0x00007f3a550b5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#44 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#45 0x00007f3a550b5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#46 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#47 0x00007f3a550b5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#48 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#49 0x00007f3a3e347b7f in KWin::ZoomEffect::paintScreen (this=0x1b44b00, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/zoom/zoom.cpp:341
#50 0x00007f3a56fd041c in KWin::EffectsHandlerImpl::paintScreen (this=0xaabec0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#51 0x00007f3a56fb3fa5 in KWin::Scene::paintScreen (this=0x792bd0, mask=0x7fff23697d9c, region=0x7fff23697e90) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:137
#52 0x00007f3a56fc84e9 in KWin::SceneOpenGL::paint (this=0x792bd0, damage=..., toplevels=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:772
#53 0x00007f3a56fb06c7 in KWin::Workspace::performCompositing (this=0xab9500) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/composite.cpp:448
#54 0x00007f3a53052799 in QObject::event (this=0xab9500, e=<value optimized out>) at kernel/qobject.cpp:1175
#55 0x00007f3a521edd14 in QApplicationPrivate::notify_helper (this=0x635680, receiver=0xab9500, e=0x7fff236986d0) at kernel/qapplication.cpp:4445
#56 0x00007f3a521f622a in QApplication::notify (this=<value optimized out>, receiver=0xab9500, e=0x7fff236986d0) at kernel/qapplication.cpp:4324
#57 0x00007f3a566d19e6 in KApplication::notify (this=0x7fff23698bb0, receiver=0xab9500, event=0x7fff236986d0) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#58 0x00007f3a5303ebfc in QCoreApplication::notifyInternal (this=0x7fff23698bb0, receiver=0xab9500, event=0x7fff236986d0) at kernel/qcoreapplication.cpp:732
#59 0x00007f3a5306c4d8 in sendEvent (this=0x636090) at kernel/qcoreapplication.h:215
#60 QTimerInfoList::activateTimers (this=0x636090) at kernel/qeventdispatcher_unix.cpp:618
#61 0x00007f3a5306cbe0 in QEventDispatcherUNIX::processEvents (this=0x612380, flags=...) at kernel/qeventdispatcher_unix.cpp:937
#62 0x00007f3a52293bac in QEventDispatcherX11::processEvents (this=0x612380, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#63 0x00007f3a5303e052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#64 0x00007f3a5303e265 in QEventLoop::exec (this=0x7fff23698aa0, flags=...) at kernel/qeventloop.cpp:201
#65 0x00007f3a530426ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#66 0x00007f3a56f4ec8a in kdemain (argc=<value optimized out>, argv=0x7fff23698c10) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/main.cpp:542
#67 0x00007f3a56ba4bfd in __libc_start_main () from /lib64/libc.so.6
#68 0x0000000000400699 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 273495, bug 273464, bug 273271, bug 273246, bug 273242.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-05-18 17:26:12 UTC
driver bug.
In general please file bugs in English - if possible.

*** This bug has been marked as a duplicate of bug 252817 ***
Comment 2 Thomas Lübking 2011-05-18 17:28:23 UTC
Kommentar #84 in Bug #25817 beschreibt einen Workaround.