Bug 274967 - Crash when exiting fullscreen application boxee
Summary: Crash when exiting fullscreen application boxee
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-05 09:39 UTC by Jesper R. Plauborg
Modified: 2011-06-05 09:42 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesper R. Plauborg 2011-06-05 09:39:57 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
Crach when exiting fullescreen application boxee. Single monitor

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fcd0fe917a0 (LWP 1356))]

Thread 3 (Thread 0x7fccf46ea700 (LWP 1378)):
#0  0x00007fcd0f6da143 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fcd0bab832c in qt_safe_select (nfds=17, fdread=0x27f9760, fdwrite=0x27f99f8, fdexcept=0x27f9c90, orig_timeout=<value optimized out>) at kernel/qcore_unix.cpp:82
#2  0x00007fcd0babd3d0 in QEventDispatcherUNIXPrivate::doSelect (this=0x27f95a0, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#3  0x00007fcd0babe04a in QEventDispatcherUNIX::processEvents (this=0x27185b0, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#4  0x00007fcd0ba8f882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fcd0ba8fabc in QEventLoop::exec (this=0x7fccf46e9db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fcd0b9a6924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fcd0ba71c2f in QInotifyFileSystemWatcherEngine::run (this=0x27f8520) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fcd0b9a9175 in QThreadPrivate::start (arg=0x27f8520) at thread/qthread_unix.cpp:320
#9  0x00007fcd0609cd8c in start_thread (arg=0x7fccf46ea700) at pthread_create.c:304
#10 0x00007fcd0f6e204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fccf3ee9700 (LWP 1379)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fcd0e5412a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fcd0e85a180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fcd0e5412d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fcd0e868254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fcd0609cd8c in start_thread (arg=0x7fccf3ee9700) at pthread_create.c:304
#4  0x00007fcd0f6e204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fcd0fe917a0 (LWP 1356)):
[KCrash Handler]
#6  intel_region_buffer (intel=0x1478b60, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007fccf74296c2 in intelClearWithBlit (ctx=0x1478b60, mask=2) at intel_blit.c:262
#8  0x00007fccf742bd2a in intelClear (ctx=0x1478b60, mask=2) at intel_clear.c:177
#9  0x00007fcd0fa58ce7 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#10 0x00007fcd0fa5088f in KWin::Scene::paintGenericScreen (this=0x146c6b0, orig_mask=40) at ../../kwin/scene.cpp:188
#11 0x00007fcd0fa4dc7a in KWin::Scene::finalPaintScreen (this=0x146c6b0, mask=40, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:178
#12 0x00007fcd0fa6bf19 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#13 0x00007fccf64c35a6 in KWin::StartupFeedbackEffect::paintScreen (this=0x26eaca0, mask=40, region=<value optimized out>, data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#15 0x00007fcd0db2ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=40, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#17 0x00007fccf646a44d in KWin::LogoutEffect::paintScreen (this=0x28a7e80, mask=40, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#18 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#19 0x00007fccf648557b in KWin::ShadowEffect::paintScreen (this=0x28c3120, mask=40, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#20 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#21 0x00007fccf6497e68 in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=40, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#22 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#23 0x00007fccf646efbd in KWin::PresentWindowsEffect::paintScreen (this=0x29cc880, mask=8, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#25 0x00007fcd0db2ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#27 0x00007fcd0db2ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#29 0x00007fcd0db2ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#31 0x00007fcd0db2ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#33 0x00007fccf6456365 in KWin::DesktopGridEffect::paintScreen (this=0x25e7520, mask=8, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#34 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#35 0x00007fccf648bb8f in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#36 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#37 0x00007fccf644fbad in KWin::BoxSwitchEffect::paintScreen (this=0x283a560, mask=8, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#38 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#39 0x00007fccf64a6256 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#40 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#41 0x00007fcd0db2ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#43 0x00007fcd0db2ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#45 0x00007fcd0db2ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#47 0x00007fccf649ed86 in KWin::CoverSwitchEffect::paintScreen (this=0x28a80f0, mask=8, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#48 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#49 0x00007fcd0db2ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#50 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#51 0x00007fcd0db2ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#53 0x00007fccf649539b in KWin::ZoomEffect::paintScreen (this=0x2a5cd30, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#54 0x00007fcd0fa6bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x25a8870, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#55 0x00007fcd0fa500af in KWin::Scene::paintScreen (this=0x146c6b0, mask=0x7fffada436dc, region=0x7fffada437a0) at ../../kwin/scene.cpp:137
#56 0x00007fcd0fa63ef3 in KWin::SceneOpenGL::paint (this=0x146c6b0, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#57 0x00007fcd0fa4b396 in KWin::Workspace::performCompositing (this=0x179ea70) at ../../kwin/composite.cpp:448
#58 0x00007fcd0baa41c9 in QObject::event (this=0x179ea70, e=<value optimized out>) at kernel/qobject.cpp:1190
#59 0x00007fcd0ae519e4 in QApplicationPrivate::notify_helper (this=0x1393910, receiver=0x179ea70, e=0x7fffada43f30) at kernel/qapplication.cpp:4462
#60 0x00007fcd0ae563aa in QApplication::notify (this=<value optimized out>, receiver=0x179ea70, e=0x7fffada43f30) at kernel/qapplication.cpp:4341
#61 0x00007fcd0f1dd866 in KApplication::notify (this=0x7fffada44330, receiver=0x179ea70, event=0x7fffada43f30) at ../../kdeui/kernel/kapplication.cpp:311
#62 0x00007fcd0ba9049c in QCoreApplication::notifyInternal (this=0x7fffada44330, receiver=0x179ea70, event=0x7fffada43f30) at kernel/qcoreapplication.cpp:731
#63 0x00007fcd0babdf12 in sendEvent (this=0x1395320) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#64 QTimerInfoList::activateTimers (this=0x1395320) at kernel/qeventdispatcher_unix.cpp:604
#65 0x00007fcd0babe05b in QEventDispatcherUNIX::processEvents (this=0x1338340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#66 0x00007fcd0aef9c0c in QEventDispatcherX11::processEvents (this=0x1338340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#67 0x00007fcd0ba8f882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#68 0x00007fcd0ba8fabc in QEventLoop::exec (this=0x7fffada44270, flags=...) at kernel/qeventloop.cpp:201
#69 0x00007fcd0ba93ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#70 0x00007fcd0f9e91ec in kdemain (argc=<value optimized out>, argv=0x7fffada449c8) at ../../kwin/main.cpp:542
#71 0x00007fcd0f61aeff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fffada449c8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffada449b8) at libc-start.c:226
#72 0x0000000000400669 in _start ()

Possible duplicates by query: bug 273989, bug 273601, bug 273553, bug 273495, bug 273464.

Reported using DrKonqi
Comment 1 Martin Flöser 2011-06-05 09:42:00 UTC
see duplicate for workaround

*** This bug has been marked as a duplicate of bug 252817 ***