Bug 273464 - Kwin crashes in fullscreen modes
Summary: Kwin crashes in fullscreen modes
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-17 07:28 UTC by paul playe
Modified: 2011-07-08 04:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (11.17 KB, text/plain)
2011-07-08 04:27 UTC, Ezau
Details

Note You need to log in before you can comment on or make changes to this bug.
Description paul playe 2011-05-17 07:28:27 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

I was trying to fix a config problem in the mars-shoter game. Everytime the game went full screen Kwin crashes (And I equally got this problem when I launch full screen flash videos, but in this case Kwin didn't crash at each attempt to go fullscreen).

I cannot remember if I got this problem before I migrate to Natty but I don't think this could be the cause of the crashes.

I'm on a fujitsu Lifebook A530, under Kubuntu.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fd97661c7a0 (LWP 1767))]

Thread 3 (Thread 0x7fd955dbb700 (LWP 1781)):
#0  0x00007fd975e68143 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fd97224632c in qt_safe_select (nfds=17, fdread=0x34724b0, fdwrite=0x3472748, fdexcept=0x34729e0, orig_timeout=<value optimized out>) at kernel/qcore_unix.cpp:82
#2  0x00007fd97224b3d0 in QEventDispatcherUNIXPrivate::doSelect (this=0x34722f0, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#3  0x00007fd97224c04a in QEventDispatcherUNIX::processEvents (this=0x346bb30, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#4  0x00007fd97221d882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fd97221dabc in QEventLoop::exec (this=0x7fd955dbadb0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fd972134924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fd9721ffc2f in QInotifyFileSystemWatcherEngine::run (this=0x23545b0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fd972137175 in QThreadPrivate::start (arg=0x23545b0) at thread/qthread_unix.cpp:320
#9  0x00007fd96c82ad8c in start_thread (arg=0x7fd955dbb700) at pthread_create.c:304
#10 0x00007fd975e7004d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fd9555ba700 (LWP 1782)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fd974ccf2a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fd974fe8180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fd974ccf2d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fd974ff6254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fd96c82ad8c in start_thread (arg=0x7fd9555ba700) at pthread_create.c:304
#4  0x00007fd975e7004d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd97661c7a0 (LWP 1767)):
[KCrash Handler]
#6  intel_region_buffer (intel=0xd936c0, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007fd95de436c2 in intelClearWithBlit (ctx=0xd936c0, mask=2) at intel_blit.c:262
#8  0x00007fd95de45d2a in intelClear (ctx=0xd936c0, mask=2) at intel_clear.c:177
#9  0x00007fd9761e6ce7 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#10 0x00007fd9761de88f in KWin::Scene::paintGenericScreen (this=0xd7bd10, orig_mask=40) at ../../kwin/scene.cpp:188
#11 0x00007fd9761dbc7a in KWin::Scene::finalPaintScreen (this=0xd7bd10, mask=40, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:178
#12 0x00007fd9761f9f19 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#13 0x00007fd95cedd5a6 in KWin::StartupFeedbackEffect::paintScreen (this=0x21587d0, mask=40, region=<value optimized out>, data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#15 0x00007fd9742b9a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=40, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#17 0x00007fd95ce8444d in KWin::LogoutEffect::paintScreen (this=0x20fcf90, mask=40, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#18 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#19 0x00007fd95ce9f57b in KWin::ShadowEffect::paintScreen (this=0x2102790, mask=40, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#20 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#21 0x00007fd95ceb1e68 in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=40, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#22 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#23 0x00007fd95ce88fbd in KWin::PresentWindowsEffect::paintScreen (this=0x219f3b0, mask=8, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#25 0x00007fd9742b9a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#27 0x00007fd9742b9a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#29 0x00007fd9742b9a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#31 0x00007fd9742b9a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#33 0x00007fd95cecfc05 in KWin::FlipSwitchEffect::paintScreen (this=0x2087460, mask=8, region=..., data=...) at ../../../kwin/effects/flipswitch/flipswitch.cpp:148
#34 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#35 0x00007fd95ce70365 in KWin::DesktopGridEffect::paintScreen (this=0x225b4b0, mask=8, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#36 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#37 0x00007fd95cec0256 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#38 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#39 0x00007fd9742b9a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#40 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#41 0x00007fd95cec9fa4 in KWin::CubeSlideEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cubeslide.cpp:111
#42 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#43 0x00007fd9742b9a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#45 0x00007fd9742b9a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#47 0x00007fd9742b9a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#48 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#49 0x00007fd9742b9a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#50 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#51 0x00007fd9742b9a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#53 0x00007fd9742b9a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#54 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#55 0x00007fd95ceaf39b in KWin::ZoomEffect::paintScreen (this=0x20d2500, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#56 0x00007fd9761f9fa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x1eb2940, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#57 0x00007fd9761de0af in KWin::Scene::paintScreen (this=0xd7bd10, mask=0x7fffafe77e2c, region=0x7fffafe77ef0) at ../../kwin/scene.cpp:137
#58 0x00007fd9761f1ef3 in KWin::SceneOpenGL::paint (this=0xd7bd10, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#59 0x00007fd9761d9396 in KWin::Workspace::performCompositing (this=0x7fd958353f10) at ../../kwin/composite.cpp:448
#60 0x00007fd9722321c9 in QObject::event (this=0x7fd958353f10, e=<value optimized out>) at kernel/qobject.cpp:1190
#61 0x00007fd9715df9e4 in QApplicationPrivate::notify_helper (this=0xc55280, receiver=0x7fd958353f10, e=0x7fffafe78680) at kernel/qapplication.cpp:4462
#62 0x00007fd9715e43aa in QApplication::notify (this=<value optimized out>, receiver=0x7fd958353f10, e=0x7fffafe78680) at kernel/qapplication.cpp:4341
#63 0x00007fd97596b866 in KApplication::notify (this=0x7fffafe78a80, receiver=0x7fd958353f10, event=0x7fffafe78680) at ../../kdeui/kernel/kapplication.cpp:311
#64 0x00007fd97221e49c in QCoreApplication::notifyInternal (this=0x7fffafe78a80, receiver=0x7fd958353f10, event=0x7fffafe78680) at kernel/qcoreapplication.cpp:731
#65 0x00007fd97224bf12 in sendEvent (this=0xc55e40) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#66 QTimerInfoList::activateTimers (this=0xc55e40) at kernel/qeventdispatcher_unix.cpp:604
#67 0x00007fd97224c05b in QEventDispatcherUNIX::processEvents (this=0xbf9340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#68 0x00007fd971687c0c in QEventDispatcherX11::processEvents (this=0xbf9340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#69 0x00007fd97221d882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#70 0x00007fd97221dabc in QEventLoop::exec (this=0x7fffafe789c0, flags=...) at kernel/qeventloop.cpp:201
#71 0x00007fd972221ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#72 0x00007fd9761771ec in kdemain (argc=<value optimized out>, argv=0x7fffafe79118) at ../../kwin/main.cpp:542
#73 0x00007fd975da8eff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fffafe79118, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffafe79108) at libc-start.c:226
#74 0x0000000000400669 in _start ()

Possible duplicates by query: bug 273271, bug 273246, bug 273242, bug 273078, bug 273067.

Reported using DrKonqi
Comment 1 paul playe 2011-05-17 07:36:54 UTC
Well, the full screen mode didn't crash Kwin when the graphical advanced options of the game are not checked.

Each time Kwin crashes, I was at that moment trying to shut down some of the graphical options with the ingame interface.

So I think that the crashes should be the result of a problem with some OpenGL features or Vsync/shaders-like enhanced graphical options.

I forgot to mention the laptop had an Intel graphical card.
Comment 2 Thomas Lübking 2011-05-17 13:20:54 UTC
driver bug, uncheck "suspend compositing for fullscreen windows" in the advanced tab of "kcmshell4 kwincompositing"

*** This bug has been marked as a duplicate of bug 252817 ***
Comment 3 Ezau 2011-07-08 04:27:20 UTC
Created attachment 61697 [details]
New crash information added by DrKonqi

kwin (4.6.2 (4.6.2)) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:
crashes in fullscreen mode 
- Unusual behavior I noticed:
black screen when crash and i can't do nothing just black screen and pointer mouse

-- Backtrace (Reduced):
#7  intel_region_buffer (intel=0x9c21b78, region=0x0, flag=2) at intel_regions.c:514
#8  0x061adce2 in intelClearWithBlit (ctx=0x9c21b78, mask=2) at intel_blit.c:262
#9  0x061b04c0 in intelClear (ctx=0x9c21b78, mask=2) at intel_clear.c:177
#10 0x090c2512 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:241
#11 0x001d984b in KWin::SceneOpenGL::paintBackground (this=0x9f50220, region=...) at ../../kwin/scene_opengl.cpp:921