Bug 274568 - Boot chrash
Summary: Boot chrash
Status: RESOLVED DUPLICATE of bug 195034
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: 0.4
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-31 06:51 UTC by dkfedorabugs
Modified: 2011-05-31 11:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dkfedorabugs 2011-05-31 06:51:35 UTC
Application: ksmserver (0.4)
KDE Platform Version: 4.6.3 (4.6.3)
Qt Version: 4.7.2
Operating System: Linux 2.6.38.6-27.fc15.x86_64 x86_64

-- Information about the crash:
- What I was doing when the application crashed: Starting up the computer and I was waiting for the dwsktop to start up.

-- Backtrace:
Application: The KDE Session Manager (ksmserver), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  _IceTransGetConnectionNumber (ciptr=0x0) at /usr/include/X11/Xtrans/Xtrans.c:1002
#7  0x0000003be8e14289 in KSMServer::newConnection (this=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.3/ksmserver/server.cpp:838
#8  0x0000003be8e175c4 in KSMServer::qt_metacall (this=0x1820da0, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fff19a77980) at /usr/src/debug/kdebase-workspace-4.6.3/x86_64-redhat-linux-gnu/ksmserver/server.moc:137
#9  0x0000003be716ceca in QMetaObject::activate (sender=0x1824c30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff19a77980) at kernel/qobject.cpp:3278
#10 0x0000003be71b5e5e in QSocketNotifier::activated (this=<optimized out>, _t1=9) at .moc/release-shared/moc_qsocketnotifier.cpp:89
#11 0x0000003be7174c1b in QSocketNotifier::event (this=0x1824c30, e=0x7fff19a77ff0) at kernel/qsocketnotifier.cpp:317
#12 0x0000003be9db73d4 in notify_helper (e=0x7fff19a77ff0, receiver=0x1824c30, this=0x1750100) at kernel/qapplication.cpp:4462
#13 QApplicationPrivate::notify_helper (this=0x1750100, receiver=0x1824c30, e=0x7fff19a77ff0) at kernel/qapplication.cpp:4434
#14 0x0000003be9dbc261 in QApplication::notify (this=0x173c4e0, receiver=0x1824c30, e=0x7fff19a77ff0) at kernel/qapplication.cpp:4341
#15 0x0000003beb041806 in KApplication::notify (this=0x173c4e0, receiver=0x1824c30, event=0x7fff19a77ff0) at /usr/src/debug/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#16 0x0000003be715a1bc in QCoreApplication::notifyInternal (this=0x173c4e0, receiver=0x1824c30, event=0x7fff19a77ff0) at kernel/qcoreapplication.cpp:731
#17 0x0000003be7184437 in sendEvent (event=0x7fff19a77ff0, receiver=<optimized out>) at kernel/qcoreapplication.h:215
#18 socketNotifierSourceDispatch (source=0x17536e0) at kernel/qeventdispatcher_glib.cpp:110
#19 0x0000003478442b6d in g_main_dispatch (context=0x17528e0) at gmain.c:2440
#20 g_main_context_dispatch (context=0x17528e0) at gmain.c:3013
#21 0x0000003478443348 in g_main_context_iterate (context=0x17528e0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3091
#22 0x00000034784435dc in g_main_context_iteration (context=0x17528e0, may_block=1) at gmain.c:3154
#23 0x0000003be7184d1f in QEventDispatcherGlib::processEvents (this=0x1718cb0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#24 0x0000003be9e59f2e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#25 0x0000003be71596d2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x0000003be71598cf in QEventLoop::exec (this=0x7fff19a78230, flags=...) at kernel/qeventloop.cpp:201
#27 0x0000003be715da17 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#28 0x0000003be8e12a2a in kdemain (argc=1, argv=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.3/ksmserver/main.cpp:311
#29 0x000000347882143d in __libc_start_main (main=0x4007a0 <main(int, char**)>, argc=1, ubp_av=0x7fff19a787c8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff19a787b8) at libc-start.c:226
#30 0x00000000004007d1 in _start ()

Possible duplicates by query: bug 274565, bug 263789, bug 257688, bug 254523, bug 250351.

Reported using DrKonqi
Comment 1 Lubos Lunak 2011-05-31 11:56:31 UTC

*** This bug has been marked as a duplicate of bug 195034 ***