Bug 257688 - ksmserver crashes on kde start after hard kill of italc session
Summary: ksmserver crashes on kde start after hard kill of italc session
Status: RESOLVED DUPLICATE of bug 195034
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: 0.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-23 12:24 UTC by Christoph Thielecke
Modified: 2010-11-24 19:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Thielecke 2010-11-23 12:24:43 UTC
Application: ksmserver (0.4)
KDE Platform Version: 4.5.3 (KDE 4.5.3)
Qt Version: 4.7.0
Operating System: Linux 2.6.37-6-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
I had a italc session running (client was showing a  demo) but I want my desktop back (instead of content from ica) and I killed all italc/ica pids on console as root.
after relogin as my user the ksmserver continously crashing.

-- Backtrace:
Application: Der KDE-Sitzungsmanager (ksmserver), signal: Segmentation fault
[KCrash Handler]
#7  0x001f1a27 in _IceTransGetConnectionNumber () from /usr/lib/libICE.so.6
#8  0x0041cf33 in KSMServer::newConnection (this=0x9fe58c0) at ../../ksmserver/server.cpp:834
#9  0x0041fcbf in KSMServer::qt_metacall (this=0x9fe58c0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf953338) at ./server.moc:121
#10 0x06e9fd4a in QMetaObject::metacall (object=0x9fe58c0, cl=167854144, idx=5, argv=0xbf953338) at kernel/qmetaobject.cpp:237
#11 0x06eb2ab5 in QMetaObject::activate (sender=0x9fe47f8, m=0x6fcb550, local_signal_index=0, argv=0xbf953338) at kernel/qobject.cpp:3280
#12 0x06f040a3 in QSocketNotifier::activated (this=0x9fe47f8, _t1=9) at .moc/release-shared/moc_qsocketnotifier.cpp:89
#13 0x06eb77d7 in QSocketNotifier::event (this=0x9fe47f8, e=0xbf9537c4) at kernel/qsocketnotifier.cpp:317
#14 0x02cb572c in QApplicationPrivate::notify_helper (this=0x9f5b398, receiver=0x9fe47f8, e=0xbf9537c4) at kernel/qapplication.cpp:4396
#15 0x02cbb77e in QApplication::notify (this=0x9f5b2d8, receiver=0x9fe47f8, e=0xbf9537c4) at kernel/qapplication.cpp:3798
#16 0x00a4e63a in KApplication::notify (this=0x9f5b2d8, receiver=0x9fe47f8, event=0xbf9537c4) at ../../kdeui/kernel/kapplication.cpp:310
#17 0x06e99feb in QCoreApplication::notifyInternal (this=0x9f5b2d8, receiver=0x9fe47f8, event=0xbf9537c4) at kernel/qcoreapplication.cpp:732
#18 0x06ec8bca in QCoreApplication::sendEvent (source=0x9f5e7a8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 socketNotifierSourceDispatch (source=0x9f5e7a8) at kernel/qeventdispatcher_glib.cpp:110
#20 0x0741f5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#21 0x074232d8 in ?? () from /lib/libglib-2.0.so.0
#22 0x074234b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#23 0x06ec87f5 in QEventDispatcherGlib::processEvents (this=0x9f3a568, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#24 0x02d76f85 in QGuiEventDispatcherGlib::processEvents (this=0x9f3a568, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x06e98a99 in QEventLoop::processEvents (this=0xbf953a64, flags=) at kernel/qeventloop.cpp:149
#26 0x06e98f1a in QEventLoop::exec (this=0xbf953a64, flags=...) at kernel/qeventloop.cpp:201
#27 0x06e9d4cf in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#28 0x02cb4557 in QApplication::exec () at kernel/qapplication.cpp:3672
#29 0x00419f63 in kdemain (argc=1, argv=0xbf953d24) at ../../ksmserver/main.cpp:311
#30 0x0804860b in main (argc=1, argv=0xbf953d24) at ksmserver_dummy.cpp:3

Reported using DrKonqi
Comment 1 Dario Andres 2010-11-24 19:19:43 UTC
[Comment from a bug triager]
This issue is being tracked at bug 195034. Merging. Thanks

*** This bug has been marked as a duplicate of bug 195034 ***