Bug 274565 - Plasma desktop crashed after boot up and log in
Summary: Plasma desktop crashed after boot up and log in
Status: RESOLVED DUPLICATE of bug 195034
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: 0.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-31 05:32 UTC by Reece
Modified: 2011-05-31 11:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Reece 2011-05-31 05:32:57 UTC
Application: ksmserver (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-9-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
Had just started computer and logged on start up continued when crash reporting system notified of this crash. Restarted application fromreporting system and again plasma crashed causing this report.

The crash can be reproduced every time.

-- Backtrace:
Application: The KDE Session Manager (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x00007facdf52ad80 in _IceTransGetConnectionNumber () from /usr/lib/x86_64-linux-gnu/libICE.so.6
#7  0x00007faccfef94cd in KSMServer::newConnection (this=<value optimized out>) at ../../ksmserver/server.cpp:838
#8  0x00007faccfefc613 in KSMServer::qt_metacall (this=0xfccc10, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fffbcced9e0) at ./server.moc:137
#9  0x00007face0deb5f8 in QMetaObject::activate (sender=0xfcbb20, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffbcced9e0) at kernel/qobject.cpp:3287
#10 0x00007face0e32b7e in QSocketNotifier::activated (this=<value optimized out>, _t1=9) at .moc/release-shared/moc_qsocketnotifier.cpp:89
#11 0x00007face0df0f4b in QSocketNotifier::event (this=0xfcbb20, e=0x7fffbccee070) at kernel/qsocketnotifier.cpp:317
#12 0x00007face01979e4 in QApplicationPrivate::notify_helper (this=0xf69cf0, receiver=0xfcbb20, e=0x7fffbccee070) at kernel/qapplication.cpp:4462
#13 0x00007face019c3aa in QApplication::notify (this=<value optimized out>, receiver=0xfcbb20, e=0x7fffbccee070) at kernel/qapplication.cpp:4341
#14 0x00007face1b51866 in KApplication::notify (this=0xf5b980, receiver=0xfcbb20, event=0x7fffbccee070) at ../../kdeui/kernel/kapplication.cpp:311
#15 0x00007face0dd649c in QCoreApplication::notifyInternal (this=0xf5b980, receiver=0xfcbb20, event=0x7fffbccee070) at kernel/qcoreapplication.cpp:731
#16 0x00007face0e00da9 in sendEvent (source=0xf6dd60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#17 socketNotifierSourceDispatch (source=0xf6dd60) at kernel/qeventdispatcher_glib.cpp:110
#18 0x00007facdce33bcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007facdce343a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007facdce34639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007face0e013ef in QEventDispatcherGlib::processEvents (this=0xe46ce0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#22 0x00007face023edfe in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007face0dd5882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007face0dd5abc in QEventLoop::exec (this=0x7fffbccee2a0, flags=...) at kernel/qeventloop.cpp:201
#25 0x00007face0dd9ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#26 0x00007faccfef7a3a in kdemain (argc=1, argv=<value optimized out>) at ../../ksmserver/main.cpp:311
#27 0x0000000000406dd3 in launch (argc=1, _name=0xf467f8 "ksmserver", args=<value optimized out>, cwd=0xf46802 "/home/artherdent", envc=<value optimized out>, envs=<value optimized out>, reset_env=true, tty=0xf46bd5 "", avoid_loops=false, startup_id_str=0xf46bde "") at ../../kinit/kinit.cpp:746
#28 0x0000000000407c59 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1238
#29 0x00000000004083b8 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1422
#30 0x0000000000408f8a in main (argc=4, argv=0x7fffbccef9a8, envp=0x7fffbccef9d0) at ../../kinit/kinit.cpp:1919

Possible duplicates by query: bug 263789, bug 257688, bug 254523, bug 250351, bug 240670.

Reported using DrKonqi
Comment 1 Lubos Lunak 2011-05-31 11:56:18 UTC

*** This bug has been marked as a duplicate of bug 195034 ***