Bug 263789 - KDE sessionmanager crashes on startup (OpenSUSE factory 20. jan. 2011)
Summary: KDE sessionmanager crashes on startup (OpenSUSE factory 20. jan. 2011)
Status: RESOLVED DUPLICATE of bug 195034
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: 0.4
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-20 22:13 UTC by leif
Modified: 2011-01-22 13:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description leif 2011-01-20 22:13:12 UTC
Application: ksmserver (0.4)
KDE Platform Version: 4.5.95 (4.6 RC2)
Qt Version: 4.7.1
Operating System: Linux 2.6.37-18-trace x86_64
Distribution: "openSUSE 11.4 Milestone 5 of 6 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
When log ind to KDE the session kan be restartet and next time it works.

The crash does not seem to be reproducible.

-- Backtrace:
Application: KDE-sessionshåndtering (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  _IceTransGetConnectionNumber (ciptr=0x0) at /usr/include/X11/Xtrans/Xtrans.c:1002
#7  0x00007f341f3d150d in KSMServer::newConnection (this=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.95/ksmserver/server.cpp:838
#8  0x00007f341f3d45c3 in KSMServer::qt_metacall (this=0x787360, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fffa97f0870) at /usr/src/debug/kdebase-workspace-4.5.95/build/ksmserver/server.moc:137
#9  0x00007f3430474e3f in QMetaObject::activate (sender=0x786010, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffa97f0870) at kernel/qobject.cpp:3272
#10 0x00007f34304bcf2e in QSocketNotifier::activated (this=<value optimized out>, _t1=9) at .moc/release-shared/moc_qsocketnotifier.cpp:89
#11 0x00007f343047a9eb in QSocketNotifier::event (this=0x786010, e=0x7fffa97f0f20) at kernel/qsocketnotifier.cpp:317
#12 0x00007f342f60ed44 in QApplicationPrivate::notify_helper (this=0x6b8570, receiver=0x786010, e=0x7fffa97f0f20) at kernel/qapplication.cpp:4445
#13 0x00007f342f61724a in QApplication::notify (this=<value optimized out>, receiver=0x786010, e=0x7fffa97f0f20) at kernel/qapplication.cpp:4324
#14 0x00007f34311039b6 in KApplication::notify (this=0x6b8460, receiver=0x786010, event=0x7fffa97f0f20) at /usr/src/debug/kdelibs-4.5.95/kdeui/kernel/kapplication.cpp:311
#15 0x00007f343045fc3c in QCoreApplication::notifyInternal (this=0x6b8460, receiver=0x786010, event=0x7fffa97f0f20) at kernel/qcoreapplication.cpp:732
#16 0x00007f343048a349 in sendEvent (source=0x6bd690) at kernel/qcoreapplication.h:215
#17 socketNotifierSourceDispatch (source=0x6bd690) at kernel/qeventdispatcher_glib.cpp:110
#18 0x00007f342bd0ec63 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#19 0x00007f342bd0f440 in ?? () from /lib64/libglib-2.0.so.0
#20 0x00007f342bd0f6e0 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#21 0x00007f343048a96f in QEventDispatcherGlib::processEvents (this=0x67cc40, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#22 0x00007f342f6b3d9e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f343045f092 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f343045f2a5 in QEventLoop::exec (this=0x7fffa97f1170, flags=...) at kernel/qeventloop.cpp:201
#25 0x00007f34304636eb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#26 0x00007f341f3cfb26 in kdemain (argc=6802256, argv=0x7fffa97f1200) at /usr/src/debug/kdebase-workspace-4.5.95/ksmserver/main.cpp:311
#27 0x00000000004075e9 in _start ()

Possible duplicates by query: bug 257688, bug 254523, bug 250351, bug 240670, bug 239900.

Reported using DrKonqi
Comment 1 Dario Andres 2011-01-22 13:30:05 UTC
[Comment from a bug triager]
This issue is being tracked at bug 195034. Merging. Thanks

*** This bug has been marked as a duplicate of bug 195034 ***