Bug 273271 - Kwin crash
Summary: Kwin crash
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-14 16:42 UTC by Nicolò
Modified: 2011-05-14 17:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolò 2011-05-14 16:42:38 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
Kwin has crash when i was looking megavideo

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77af720 (LWP 16867))]

Thread 3 (Thread 0xb2be8b70 (LWP 16889)):
#0  0x067f0d41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x04239dd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x043064f2 in updateCurrentTime (this=0x9117da0, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x9117da0, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x043083a3 in QEventDispatcherUNIX::processEvents (this=0x937e238, flags=...) at kernel/qeventdispatcher_unix.cpp:906
#6  0x042d7289 in QEventLoop::processEvents (this=0xb2be8280, flags=...) at kernel/qeventloop.cpp:149
#7  0x042d7522 in QEventLoop::exec (this=0xb2be8280, flags=...) at kernel/qeventloop.cpp:201
#8  0x041e12a0 in QThread::exec (this=0x9383088) at thread/qthread.cpp:492
#9  0x042b8fdb in QInotifyFileSystemWatcherEngine::run (this=0x9383088) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x041e3da2 in QThreadPrivate::start (arg=0x9383088) at thread/qthread_unix.cpp:320
#11 0x00a79e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00b5e73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb23e7b70 (LWP 16890)):
#0  0x009f5416 in __kernel_vsyscall ()
#1  0x00a7e48c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x00b6c3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x01014817 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x11281c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x01014851 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x11281c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x00a79e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x00b5e73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb77af720 (LWP 16867)):
[KCrash Handler]
#7  intel_region_buffer (intel=0x8d94258, region=0x0, flag=2) at intel_regions.c:514
#8  0x02244742 in intelClearWithBlit (ctx=0x8d94258, mask=2) at intel_blit.c:262
#9  0x0223d670 in intelClear (ctx=0x8d94258, mask=2) at intel_clear.c:177
#10 0x02807512 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:241
#11 0x0082384b in KWin::SceneOpenGL::paintBackground (this=0x901e868, region=...) at ../../kwin/scene_opengl.cpp:921
#12 0x0081a562 in KWin::Scene::paintGenericScreen (this=0x901e868, orig_mask=32) at ../../kwin/scene.cpp:188
#13 0x00823a31 in KWin::SceneOpenGL::paintGenericScreen (this=0x901e868, mask=32, data=...) at ../../kwin/scene_opengl.cpp:909
#14 0x008177c0 in KWin::Scene::finalPaintScreen (this=0x901e868, mask=32, region=..., data=...) at ../../kwin/scene.cpp:178
#15 0x008390fc in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:173
#16 0x071120e9 in KWin::StartupFeedbackEffect::paintScreen (this=0x92cab70, mask=32, region=..., data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#18 0x00578256 in KWin::Effect::paintScreen (this=0x9143ff8, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#19 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#20 0x070b407f in KWin::LogoutEffect::paintScreen (this=0x9236598, mask=32, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#21 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#22 0x070cfb10 in KWin::ShadowEffect::paintScreen (this=0x9263fd0, mask=32, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#23 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#24 0x070e4013 in KWin::BlurEffect::paintScreen (this=0x9100008, mask=32, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#25 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#26 0x070b8e6f in KWin::PresentWindowsEffect::paintScreen (this=0x92d98b0, mask=32, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#27 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#28 0x00578256 in KWin::Effect::paintScreen (this=0x92761a8, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#29 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#30 0x00578256 in KWin::Effect::paintScreen (this=0x9158b10, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#32 0x00578256 in KWin::Effect::paintScreen (this=0x91a5560, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#33 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#34 0x00578256 in KWin::Effect::paintScreen (this=0x91a3b80, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#35 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#36 0x00578256 in KWin::Effect::paintScreen (this=0x921f960, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#37 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#38 0x0709f7e9 in KWin::DesktopGridEffect::paintScreen (this=0x90e17c0, mask=32, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#39 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#40 0x070d6ce2 in KWin::SlideEffect::paintScreen (this=0x9151a88, mask=32, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#41 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#42 0x07098799 in KWin::BoxSwitchEffect::paintScreen (this=0x9101300, mask=32, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#43 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#44 0x070f2bcc in KWin::CubeEffect::paintScreen (this=0x92cf3d8, mask=32, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#45 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#46 0x00578256 in KWin::Effect::paintScreen (this=0x92d88b8, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#47 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#48 0x00578256 in KWin::Effect::paintScreen (this=0x90feaa0, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#49 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#50 0x00578256 in KWin::Effect::paintScreen (this=0x91d5908, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#51 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#52 0x070eba0c in KWin::CoverSwitchEffect::paintScreen (this=0x91e09f0, mask=32, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#53 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#54 0x00578256 in KWin::Effect::paintScreen (this=0x9274558, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#55 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#56 0x00578256 in KWin::Effect::paintScreen (this=0x90d9ff8, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#57 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#58 0x00578256 in KWin::Effect::paintScreen (this=0x9160e40, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#59 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#60 0x070e10c1 in KWin::ZoomEffect::paintScreen (this=0x9234ab0, mask=32, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#61 0x00839172 in KWin::EffectsHandlerImpl::paintScreen (this=0x90ae338, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#62 0x0081898c in KWin::Scene::paintScreen (this=0x901e868, mask=0xbfab6068, region=0xbfab60f0) at ../../kwin/scene.cpp:137
#63 0x0082f962 in KWin::SceneOpenGL::paint (this=0x901e868, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:772
#64 0x00814886 in KWin::Workspace::performCompositing (this=0x901c670) at ../../kwin/composite.cpp:448
#65 0x042ed214 in QObject::event (this=0x901c670, e=0xbfab661c) at kernel/qobject.cpp:1190
#66 0x05057d24 in QApplicationPrivate::notify_helper (this=0x8c297d0, receiver=0x901c670, e=0xbfab661c) at kernel/qapplication.cpp:4462
#67 0x0505c8ce in QApplication::notify (this=0xbfab6934, receiver=0x901c670, e=0xbfab661c) at kernel/qapplication.cpp:3862
#68 0x002f13ca in KApplication::notify (this=0xbfab6934, receiver=0x901c670, event=0xbfab661c) at ../../kdeui/kernel/kapplication.cpp:311
#69 0x007a3abf in KWin::Application::notify (this=0xbfab6934, o=0x901c670, e=0xbfab661c) at ../../kwin/main.cpp:376
#70 0x042d80bb in QCoreApplication::notifyInternal (this=0xbfab6934, receiver=0x901c670, event=0xbfab661c) at kernel/qcoreapplication.cpp:731
#71 0x043081e4 in sendEvent (this=0x8c2a1b8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#72 QTimerInfoList::activateTimers (this=0x8c2a1b8) at kernel/qeventdispatcher_unix.cpp:604
#73 0x04308338 in QEventDispatcherUNIX::processEvents (this=0x8be7aa8, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#74 0x0510c7ea in QEventDispatcherX11::processEvents (this=0x8be7aa8, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#75 0x042d7289 in QEventLoop::processEvents (this=0xbfab6874, flags=...) at kernel/qeventloop.cpp:149
#76 0x042d7522 in QEventLoop::exec (this=0xbfab6874, flags=...) at kernel/qeventloop.cpp:201
#77 0x042dbecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#78 0x050558e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#79 0x007a65b2 in kdemain (argc=3, argv=0xbfab6bb4) at ../../kwin/main.cpp:542
#80 0x080485bb in main (argc=3, argv=0xbfab6bb4) at kwin_dummy.cpp:3

This bug may be a duplicate of or related to bug 252817.

Possible duplicates by query: bug 273246, bug 273242, bug 273078, bug 273067, bug 273066.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-05-14 17:29:52 UTC

*** This bug has been marked as a duplicate of bug 252817 ***