Bug 264881 - knetworkmanager crashed upon network-manager restart
Summary: knetworkmanager crashed upon network-manager restart
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-30 20:25 UTC by Ekkehard Blanz
Modified: 2011-01-30 22:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ekkehard Blanz 2011-01-30 20:25:36 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-27-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
after a restart of the network-manager (needed after a sleep mode) knetowrkmanager crashed.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7726710 (LWP 3032))]

Thread 2 (Thread 0xb4e78b70 (LWP 3036)):
#0  0x0087b422 in __kernel_vsyscall ()
#1  0x01a71b86 in *__GI___poll (fds=0x1b07ff4, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x04aec4eb in g_poll () from /lib/libglib-2.0.so.0
#3  0x04adf0ac in ?? () from /lib/libglib-2.0.so.0
#4  0x04adf4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x00c7f60f in QEventDispatcherGlib::processEvents (this=0x83f2650, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#6  0x00c52059 in QEventLoop::processEvents (this=0xb4e78290, flags=) at kernel/qeventloop.cpp:149
#7  0x00c524aa in QEventLoop::exec (this=0xb4e78290, flags=...) at kernel/qeventloop.cpp:201
#8  0x00b4e5a8 in QThread::exec (this=0x8592740) at thread/qthread.cpp:487
#9  0x00c31c1b in QInotifyFileSystemWatcherEngine::run (this=0x8592740) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00b5132e in QThreadPrivate::start (arg=0x8592740) at thread/qthread_unix.cpp:248
#11 0x0037196e in start_thread (arg=0xb4e78b70) at pthread_create.c:300
#12 0x01a7fa4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb7726710 (LWP 3032)):
[KCrash Handler]
#6  0x00c58cc7 in QMetaObject::cast (this=0x806f860, obj=0x83add60) at kernel/qmetaobject.cpp:266
#7  0x0077f5c0 in ?? () from /usr/lib/libknmservice.so.4
#8  0x0077f871 in ?? () from /usr/lib/libknmservice.so.4
#9  0x0077faf2 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#10 0x0076e713 in ActivatableList::notifyOnAddActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#11 0x0076eaa8 in ActivatableList::addActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#12 0x00773076 in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#13 0x00770640 in NetworkInterfaceActivatableProvider::init() () from /usr/lib/libknmservice.so.4
#14 0x0076f4b3 in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#15 0x0076908b in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#16 0x00c58c9a in QMetaObject::metacall (object=0x83b5f80, cl=10948596, idx=138102848, argv=0x83b47c8) at kernel/qmetaobject.cpp:237
#17 0x00c673d5 in QMetaObject::activate (sender=0x838e428, m=0x83a540, local_signal_index=1, argv=0xbfc84a78) at kernel/qobject.cpp:3293
#18 0x0081a9a3 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded(QString const&) () from /usr/lib/libsolidcontrol.so.4
#19 0x0081b416 in ?? () from /usr/lib/libsolidcontrol.so.4
#20 0x0081b497 in ?? () from /usr/lib/libsolidcontrol.so.4
#21 0x00c58c9a in QMetaObject::metacall (object=0x838e428, cl=10948596, idx=0, argv=0x838e428) at kernel/qmetaobject.cpp:237
#22 0x00c673d5 in QMetaObject::activate (sender=0x83a6f20, m=0x1e17a70, local_signal_index=1, argv=0xbfc84be8) at kernel/qobject.cpp:3293
#23 0x01dff483 in NMNetworkManager::networkInterfaceAdded(QString const&) () from /usr/lib/kde4/solid_networkmanager07.so
#24 0x01dffd6a in NMNetworkManager::deviceAdded(QDBusObjectPath const&) () from /usr/lib/kde4/solid_networkmanager07.so
#25 0x01e0408d in NMNetworkManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#26 0x00c58c9a in QMetaObject::metacall (object=0x83a6f20, cl=10948596, idx=138137704, argv=0x83a6f20) at kernel/qmetaobject.cpp:237
#27 0x00c673d5 in QMetaObject::activate (sender=0x83a6fb0, m=0x1e18a80, local_signal_index=0, argv=0xbfc84d88) at kernel/qobject.cpp:3293
#28 0x01e0e3f3 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#29 0x01e0e7b5 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#30 0x00a92b34 in QDBusConnectionPrivate::deliverCall (this=0x837cbf0, object=0x83a6fb0, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#31 0x00a9dea7 in QDBusCallDeliveryEvent::placeMetaCall (this=0x83f56c8, object=0x83a6fb0) at qdbusintegrator_p.h:101
#32 0x00c643fe in QObject::event (this=0x83a6fb0, e=0x83f56c8) at kernel/qobject.cpp:1248
#33 0x0102b4dc in QApplicationPrivate::notify_helper (this=0x82db158, receiver=0x83a6fb0, e=0x83f56c8) at kernel/qapplication.cpp:4300
#34 0x0103205e in QApplication::notify (this=0xbfc85890, receiver=0x83a6fb0, e=0x83f56c8) at kernel/qapplication.cpp:3704
#35 0x0058340a in KApplication::notify (this=0xbfc85890, receiver=0x83a6fb0, event=0x83f56c8) at ../../kdeui/kernel/kapplication.cpp:302
#36 0x00c53a3b in QCoreApplication::notifyInternal (this=0xbfc85890, receiver=0x83a6fb0, event=0x83f56c8) at kernel/qcoreapplication.cpp:704
#37 0x00c56473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x82b2fd8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#38 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x82b2fd8) at kernel/qcoreapplication.cpp:1345
#39 0x00c565dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#40 0x00c7fadf in QCoreApplication::sendPostedEvents (s=0x82d1d90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#41 postEventSourceDispatch (s=0x82d1d90) at kernel/qeventdispatcher_glib.cpp:276
#42 0x04adb5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#43 0x04adf2d8 in ?? () from /lib/libglib-2.0.so.0
#44 0x04adf4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#45 0x00c7f5d5 in QEventDispatcherGlib::processEvents (this=0x82b2b70, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#46 0x010eb135 in QGuiEventDispatcherGlib::processEvents (this=0x82b2b70, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x00c52059 in QEventLoop::processEvents (this=0xbfc857f4, flags=) at kernel/qeventloop.cpp:149
#48 0x00c524aa in QEventLoop::exec (this=0xbfc857f4, flags=...) at kernel/qeventloop.cpp:201
#49 0x00c5669f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#50 0x0102b577 in QApplication::exec () at kernel/qapplication.cpp:3579
#51 0x08053d91 in _start ()

This bug may be a duplicate of or related to bug 210878.

Possible duplicates by query: bug 264185, bug 263968, bug 263827, bug 258907, bug 258168.

Reported using DrKonqi
Comment 1 Dario Andres 2011-01-30 22:55:26 UTC
[Comment from a bug triager]
This issue is fixed in the latest NetworkManager code.
Merging with bug 210878.
Regards

*** This bug has been marked as a duplicate of bug 210878 ***