Bug 258907 - After restart network-manager
Summary: After restart network-manager
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-05 14:37 UTC by Sonic
Modified: 2010-12-07 01:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sonic 2010-12-05 14:37:42 UTC
Application: kded4 ($Id: kded.cpp 1156841 2010-07-29 19:59:05Z zander $)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I was creating a VPN and It didn't work, so I went to restart the network-manager service and then this happend

-- Backtrace:
Application: Servicio de KDE (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#7  0x000000a8 in ?? ()
#8  0x00ea78f9 in QMetaObject::cast (this=0x2aeb490, obj=0x95b2708) at kernel/qmetaobject.cpp:266
#9  0x08eeb44e in qobject_cast<Knm::InterfaceConnection const*> (first=0x95b2708, second=0x95b6c38) at /usr/include/qt4/QtCore/qobject.h:468
#10 activatableLessThan (first=0x95b2708, second=0x95b6c38) at ../../../libs/service/sortedactivatablelist.cpp:183
#11 0x08eeb6d3 in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=<value optimized out>, end=) at /usr/include/qt4/QtCore/qalgorithms.h:356
#12 0x08eeb982 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x95b94f0, activatable=0x95f74c8) at /usr/include/qt4/QtCore/qalgorithms.h:187
#13 SortedActivatableList::handleAdd (this=0x95b94f0, activatable=0x95f74c8) at ../../../libs/service/sortedactivatablelist.cpp:96
#14 0x08ed9ac3 in ActivatableList::notifyOnAddActivatable (this=0x9599098, activatable=0x95f74c8) at ../../../libs/service/activatablelist.cpp:99
#15 0x08eda318 in ActivatableList::addActivatable (this=0x9599098, activatable=0x95f74c8) at ../../../libs/service/activatablelist.cpp:83
#16 0x08ede5c6 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x95c0480, addedConnection=0x95c1a38) at ../../../libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#17 0x08edbb40 in NetworkInterfaceActivatableProvider::init (this=0x95c0480) at ../../../libs/service/networkinterfaceactivatableprovider.cpp:64
#18 0x08eda9b3 in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x9598208, uni=...) at ../../../libs/service/networkinterfacemonitor.cpp:87
#19 0x08ed40eb in NetworkInterfaceMonitor::qt_metacall (this=0x9598208, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfd8d888) at moc_networkinterfacemonitor.cpp:75
#20 0x00ea78ca in QMetaObject::metacall (object=0x9598208, cl=156800513, idx=4, argv=0xbfd8d888) at kernel/qmetaobject.cpp:237
#21 0x00eba6ad in QMetaObject::activate (sender=0x959d100, m=0x295d540, local_signal_index=1, argv=0x95a6608) at kernel/qobject.cpp:3280
#22 0x0293df03 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x959d100, _t1=...) at ./networkmanager.moc:107
#23 0x0293e986 in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x959d100, uni=...) at ../../../../libs/solid/control/networkmanager.cpp:197
#24 0x0293ea07 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x959d100, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbfd8d9f8) at ./networkmanager_p.moc:81
#25 0x00ea78ca in QMetaObject::metacall (object=0x959d100, cl=156800513, idx=10, argv=0xbfd8d9f8) at kernel/qmetaobject.cpp:237
#26 0x00eba6ad in QMetaObject::activate (sender=0x959cfb0, m=0x32ce950, local_signal_index=1, argv=0x95a6608) at kernel/qobject.cpp:3280
#27 0x032ca6c3 in Solid::Control::Ifaces::NetworkManager::networkInterfaceAdded (this=0x959cfb0, _t1=...) at ./networkmanager.moc:115
#28 0x07c6098a in NMNetworkManager::deviceAdded (this=0x959cfb0, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:199
#29 0x07c64bd5 in NMNetworkManager::qt_metacall (this=0x959cfb0, _c=QMetaObject::InvokeMetaMethod, _id=15, _a=0xbfd8db98) at ./manager.moc:95
#30 0x00ea78ca in QMetaObject::metacall (object=0x959cfb0, cl=156800513, idx=15, argv=0xbfd8db98) at kernel/qmetaobject.cpp:237
#31 0x00eba6ad in QMetaObject::activate (sender=0x958f348, m=0x7c79a80, local_signal_index=0, argv=0x95a6608) at kernel/qobject.cpp:3280
#32 0x07c6f673 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x958f348, _t1=...) at ./nm-manager-clientinterface.moc:155
#33 0x07c6fbf5 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x958f348, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfd8dddc) at ./nm-manager-clientinterface.moc:102
#34 0x004e69dc in QDBusConnectionPrivate::deliverCall (this=0x957dc98, object=0x958f348, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:919
#35 0x004f21f7 in QDBusCallDeliveryEvent::placeMetaCall (this=0x95f54c0, object=0x958f348) at qdbusintegrator_p.h:103
#36 0x00eb46a2 in QObject::event (this=0x958f348, e=0x2aeb490) at kernel/qobject.cpp:1219
#37 0x01101fdc in QApplicationPrivate::notify_helper (this=0x94a1bf8, receiver=0x958f348, e=0x95f54c0) at kernel/qapplication.cpp:4396
#38 0x0110804e in QApplication::notify (this=0xbfd8e6b0, receiver=0x958f348, e=0x95f54c0) at kernel/qapplication.cpp:3798
#39 0x002e868a in KApplication::notify (this=0xbfd8e6b0, receiver=0x958f348, event=0x95f54c0) at ../../kdeui/kernel/kapplication.cpp:310
#40 0x00ea1b3b in QCoreApplication::notifyInternal (this=0xbfd8e6b0, receiver=0x958f348, event=0x95f54c0) at kernel/qcoreapplication.cpp:732
#41 0x00ea4d8b in sendEvent (receiver=0x0, event_type=0, data=0x93ebf08) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x93ebf08) at kernel/qcoreapplication.cpp:1373
#43 0x00ea4f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#44 0x00ed0a74 in sendPostedEvents (s=0x94a3f10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#45 postEventSourceDispatch (s=0x94a3f10) at kernel/qeventdispatcher_glib.cpp:277
#46 0x03a16855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#47 0x03a1a668 in ?? () from /lib/libglib-2.0.so.0
#48 0x03a1a848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#49 0x00ed0565 in QEventDispatcherGlib::processEvents (this=0x93ed1b8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#50 0x011c3be5 in QGuiEventDispatcherGlib::processEvents (this=0x93ed1b8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#51 0x00ea0609 in QEventLoop::processEvents (this=0xbfd8e604, flags=) at kernel/qeventloop.cpp:149
#52 0x00ea0a8a in QEventLoop::exec (this=0xbfd8e604, flags=...) at kernel/qeventloop.cpp:201
#53 0x00ea500f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#54 0x01100e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#55 0x06ccccf7 in kdemain (argc=1, argv=0x94704d8) at ../../kded/kded.cpp:894
#56 0x0804e4d1 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x0, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x80517f7 "0") at ../../kinit/kinit.cpp:723
#57 0x0805048d in main (argc=4, argv=0xbfd8ee34, envp=0xbfd8ee48) at ../../kinit/kinit.cpp:1835

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-07 01:22:11 UTC
[Comment from a bug triager]
This issue is being tracked at bug 210878. Merging. Thanks

*** This bug has been marked as a duplicate of bug 210878 ***