Bug 263968 - crash w/networkmanager stop/start
Summary: crash w/networkmanager stop/start
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-22 14:16 UTC by Jon Nelson
Modified: 2011-01-23 15:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Nelson 2011-01-22 14:16:37 UTC
Application: kded4 ($Id: kded.cpp 1156841 2010-07-29 19:59:05Z zander $)
KDE Platform Version: 4.5.5 (KDE 4.5.5) "release 1"
Qt Version: 4.6.3
Operating System: Linux 2.6.37-40-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
Software crashes every time I do "rcnetwork stop" and "rcnetwork start" on openSUSE 11.3

The crash can be reproduced some of the time.

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f64d19f3760 (LWP 3092))]

Thread 2 (Thread 0x7f64b7794710 (LWP 3100)):
#0  0x00007f64cf1a76b3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f64cc2bffd4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f64cc2c0510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f64d075e6d6 in QEventDispatcherGlib::processEvents (this=0x7f64b00008b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f64d0735292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f64d0735495 in QEventLoop::exec (this=0x7f64b7793e20, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f64d064c2cf in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f64d064ebf5 in QThreadPrivate::start (arg=0x87eb60) at thread/qthread_unix.cpp:248
#8  0x00007f64d03c0a4f in start_thread (arg=0x7f64b7794710) at pthread_create.c:297
#9  0x00007f64cf1b082d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f64d19f3760 (LWP 3092)):
[KCrash Handler]
#6  0x0000000000000030 in ?? ()
#7  0x00007f64d073b7a9 in QMetaObject::cast (this=0x7f64b5aba940, obj=0x8b8f50) at kernel/qmetaobject.cpp:266
#8  0x00007f64b5d2a24a in qobject_cast<Knm::InterfaceConnection const*> (first=0x8b8f50, second=0x8bfc70) at /usr/include/QtCore/qobject.h:468
#9  activatableLessThan (first=0x8b8f50, second=0x8bfc70) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:184
#10 0x00007f64b5d2ad1a in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., t=
    @0x8d74b0, lessThan=0x7f64b5d2a1e0 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:356
#11 0x00007f64b5d2aac7 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x8c5bc0, activatable=0x8c2040)
    at /usr/include/QtCore/qalgorithms.h:187
#12 SortedActivatableList::handleAdd (this=0x8c5bc0, activatable=0x8c2040) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:96
#13 0x00007f64b5d1b283 in ActivatableList::notifyOnAddActivatable (this=<value optimized out>, activatable=0x8c2040) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:120
#14 0x00007f64b5d1ec8e in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=<value optimized out>, addedConnection=<value optimized out>)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#15 0x00007f64b5d1c8bd in NetworkInterfaceActivatableProvider::init (this=0x93e4c0) at /usr/src/debug/networkmanagement/libs/service/networkinterfaceactivatableprovider.cpp:64
#16 0x00007f64b5d1bdfd in NetworkInterfaceMonitor::networkInterfaceAdded (this=<value optimized out>, uni=...) at /usr/src/debug/networkmanagement/libs/service/networkinterfacemonitor.cpp:87
#17 0x00007f64b5d171cd in NetworkInterfaceMonitor::qt_metacall (this=0x8bd780, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff22b6cbc0)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_networkinterfacemonitor.cpp:75
#18 0x00007f64d0749a1f in QMetaObject::activate (sender=0x8b2450, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff22b6cbc0) at kernel/qobject.cpp:3295
#19 0x00007f64ba8d3505 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.5.5/build/libs/solid/control/networkmanager.moc:107
#20 0x00007f64ba8d3ad7 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x8b2450, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff22b6cce0)
    at /usr/src/debug/kdebase-workspace-4.5.5/build/libs/solid/control/networkmanager_p.moc:81
#21 0x00007f64d0749a1f in QMetaObject::activate (sender=0x88a460, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff22b6cce0) at kernel/qobject.cpp:3295
#22 0x00007f64ba4afb85 in Solid::Control::Ifaces::NetworkManager::networkInterfaceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.5.5/build/libs/solid/control/ifaces/networkmanager.moc:115
#23 0x00007f64b4fdf04a in NMNetworkManager::deviceAdded (this=0x88a460, objpath=...) at /usr/src/debug/kdebase-workspace-4.5.5/solid/networkmanager-0.7/manager.cpp:199
#24 0x00007f64b4fe8d69 in NMNetworkManager::qt_metacall (this=0x88a460, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff22b6cea0)
    at /usr/src/debug/kdebase-workspace-4.5.5/build/solid/networkmanager-0.7/manager.moc:95
#25 0x00007f64d0749a1f in QMetaObject::activate (sender=0x88ba40, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff22b6cea0) at kernel/qobject.cpp:3295
#26 0x00007f64b4fdbaa2 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.5.5/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:155
#27 0x00007f64b4fe3f84 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x88ba40, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff22b6d2e0)
    at /usr/src/debug/kdebase-workspace-4.5.5/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:102
#28 0x00007f64cdb7a188 in QDBusConnectionPrivate::deliverCall (this=0x863470, object=0x88ba40, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#29 0x00007f64cdb86ecf in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:101
#30 0x00007f64d0747509 in QObject::event (this=0x88ba40, e=0x9f6350) at kernel/qobject.cpp:1248
#31 0x00007f64cf90a4d4 in QApplicationPrivate::notify_helper (this=0x6944d0, receiver=0x88ba40, e=0x9f6350) at kernel/qapplication.cpp:4302
#32 0x00007f64cf912aca in QApplication::notify (this=<value optimized out>, receiver=0x88ba40, e=0x9f6350) at kernel/qapplication.cpp:4185
#33 0x00007f64d139b876 in KApplication::notify (this=0x7fff22b6ddc0, receiver=0x88ba40, event=0x9f6350) at /usr/src/debug/kdelibs-4.5.5/kdeui/kernel/kapplication.cpp:310
#34 0x00007f64d0735e4c in QCoreApplication::notifyInternal (this=0x7fff22b6ddc0, receiver=0x88ba40, event=0x9f6350) at kernel/qcoreapplication.cpp:726
#35 0x00007f64d07395ba in sendEvent (receiver=0x0, event_type=0, data=0x60f500) at kernel/qcoreapplication.h:215
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60f500) at kernel/qcoreapplication.cpp:1367
#37 0x00007f64d075e173 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#38 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#39 0x00007f64cc2bfa93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#40 0x00007f64cc2c0270 in ?? () from /usr/lib64/libglib-2.0.so.0
#41 0x00007f64cc2c0510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#42 0x00007f64d075e67f in QEventDispatcherGlib::processEvents (this=0x616ba0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#43 0x00007f64cf9ab14e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#44 0x00007f64d0735292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#45 0x00007f64d0735495 in QEventLoop::exec (this=0x7fff22b6dd10, flags=...) at kernel/qeventloop.cpp:201
#46 0x00007f64d073988b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#47 0x00007f64c1b7e4a7 in kdemain (argc=1, argv=0x672650) at /usr/src/debug/kdelibs-4.5.5/kded/kded.cpp:894
#48 0x00000000004074a9 in launch (argc=1, _name=0x40b267 "kded4", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=
    false, startup_id_str=0x40b0f7 "0") at /usr/src/debug/kdelibs-4.5.5/kinit/kinit.cpp:723
#49 0x0000000000409cba in main (argc=4, argv=0x7fff22b6edb8, envp=0x7fff22b6ede0) at /usr/src/debug/kdelibs-4.5.5/kinit/kinit.cpp:1835

Reported using DrKonqi
Comment 1 Dario Andres 2011-01-23 15:38:47 UTC
[Comment from a bug triager]
This is a known bug being tracked at bug 210878.
Regards

*** This bug has been marked as a duplicate of bug 210878 ***