Bug 258168 - kded4 (networkmanagement) crashed when restarting network
Summary: kded4 (networkmanagement) crashed when restarting network
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-28 13:20 UTC by S. Burmeister
Modified: 2011-02-04 15:10 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2010-11-28 13:20:49 UTC
Application: kded4 ($Id: kded.cpp 1192875 2010-11-04 08:22:15Z ervin $)
KDE Platform Version: 4.5.80 (4.6 Beta1)
Qt Version: 4.7.1
Operating System: Linux 2.6.34.7-0.5-default i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:

Although rebooting several times the networkmanagement plasmoid showeda big red cross, i.e. no network interfaces found. However a working network connection (wifi) was established.

Restarting only the network instead of rebooting crashed kded4 and fixed the issue, i.e. the plasmoid now sees the network interfaces.

-- Backtrace:
Application: KDE-Dienst (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5904710 (LWP 2001))]

Thread 3 (Thread 0xad596b70 (LWP 2151)):
#0  0xb5c0322b in clock_gettime () from /lib/librt.so.1
#1  0xb6e13265 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6ee6d26 in updateCurrentTime (this=0x823a3e4, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x823a3e4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6ee555b in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xad59611c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6ee55fd in timerSourcePrepare (source=0x823a3b0, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb5b570c0 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#8  0xb5b57f22 in ?? () from /usr/lib/libglib-2.0.so.0
#9  0xb5b5860e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#10 0xb6ee5da7 in QEventDispatcherGlib::processEvents (this=0x812f490, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6eb689d in QEventLoop::processEvents (this=0xad5962b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6eb6ac9 in QEventLoop::exec (this=0xad5962b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6db57a9 in QThread::exec (this=0x8180200) at thread/qthread.cpp:490
#14 0xb6e964ad in QInotifyFileSystemWatcherEngine::run (this=0x8180200) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6db839a in QThreadPrivate::start (arg=0x8180200) at thread/qthread_unix.cpp:285
#16 0xb6d3cb25 in start_thread () from /lib/libpthread.so.0
#17 0xb60ec46e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xacd7cb70 (LWP 2504)):
#0  0xb5c0322b in clock_gettime () from /lib/librt.so.1
#1  0xb6e13265 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6ee6d26 in updateCurrentTime (this=0x81ba084, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x81ba084, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6ee555b in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xacd7c12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6ee55fd in timerSourcePrepare (source=0x81ba050, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb5b570c0 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#8  0xb5b57f22 in ?? () from /usr/lib/libglib-2.0.so.0
#9  0xb5b5860e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#10 0xb6ee5da7 in QEventDispatcherGlib::processEvents (this=0x816b7d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6eb689d in QEventLoop::processEvents (this=0xacd7c2c0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6eb6ac9 in QEventLoop::exec (this=0xacd7c2c0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6db57a9 in QThread::exec (this=0x8228ae8) at thread/qthread.cpp:490
#14 0xae0c7ef7 in ?? () from /usr/lib/kde4/kded_bluedevil.so
#15 0xb6db839a in QThreadPrivate::start (arg=0x8228ae8) at thread/qthread_unix.cpp:285
#16 0xb6d3cb25 in start_thread () from /lib/libpthread.so.0
#17 0xb60ec46e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5904710 (LWP 2001)):
[KCrash Handler]
#7  0x07000028 in ?? ()
#8  0xb6ebde98 in QMetaObject::cast (this=0xad6e33c0, obj=0x82d2158) at kernel/qmetaobject.cpp:266
#9  0xad754333 in qobject_cast<Knm::InterfaceConnection const*> (first=0x82d2158, second=0x82e0da0) at /usr/include/QtCore/qobject.h:379
#10 activatableLessThan (first=0x82d2158, second=0x82e0da0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:184
#11 0xad754e00 in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., t=
    @0x82bae98, lessThan=0xad7542c0 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:356
#12 0xad754663 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x8215a90, activatable=0x83a2b08)
    at /usr/include/QtCore/qalgorithms.h:187
#13 SortedActivatableList::handleAdd (this=0x8215a90, activatable=0x83a2b08) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:96
#14 0xad742444 in ActivatableList::notifyOnAddActivatable (this=0x8213478, activatable=0x83a2b08) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:120
#15 0xad7424c3 in ActivatableList::addActivatable (this=0x8213478, activatable=0x83a2b08) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:104
#16 0xad746756 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x82a4418, addedConnection=0x8225408)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#17 0xad7440d9 in NetworkInterfaceActivatableProvider::init (this=0x82a4418) at /usr/src/debug/networkmanagement/libs/service/networkinterfaceactivatableprovider.cpp:64
#18 0xad7432be in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x8215d28, uni=...) at /usr/src/debug/networkmanagement/libs/service/networkinterfacemonitor.cpp:87
#19 0xad73da45 in NetworkInterfaceMonitor::qt_metacall (this=0x8215d28, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd8d758)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_networkinterfacemonitor.cpp:75
#20 0xb6ebde5d in QMetaObject::metacall (object=0x8215d28, cl=QMetaObject::InvokeMetaMethod, idx=4, argv=0xbfd8d758) at kernel/qmetaobject.cpp:237
#21 0xb6ecdffc in QMetaObject::activate (sender=0x8213798, m=0xad6a5560, local_signal_index=1, argv=0xbfd8d758) at kernel/qobject.cpp:3272
#22 0xad682fe5 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x8213798, _t1=...) at /usr/src/debug/kdebase-workspace-4.5.80/build/libs/solid/control/networkmanager.moc:110
#23 0xad68369c in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x8213798, uni=...) at /usr/src/debug/kdebase-workspace-4.5.80/libs/solid/control/networkmanager.cpp:199
#24 0xad68371e in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x8213798, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd8d8b8)
    at /usr/src/debug/kdebase-workspace-4.5.80/build/libs/solid/control/networkmanager_p.moc:81
#25 0xb6ebde5d in QMetaObject::metacall (object=0x8213798, cl=QMetaObject::InvokeMetaMethod, idx=11, argv=0xbfd8d8b8) at kernel/qmetaobject.cpp:237
#26 0xb6ecdffc in QMetaObject::activate (sender=0x82156c8, m=0xad5d6990, local_signal_index=1, argv=0xbfd8d8b8) at kernel/qobject.cpp:3272
#27 0xad5bac65 in NMNetworkManager::networkInterfaceAdded (this=0x82156c8, _t1=...) at /usr/src/debug/kdebase-workspace-4.5.80/build/solid/networkmanager-0.7/manager.moc:134
#28 0xad5bb0fa in NMNetworkManager::deviceAdded (this=0x82156c8, objpath=...) at /usr/src/debug/kdebase-workspace-4.5.80/solid/networkmanager-0.7/manager.cpp:214
#29 0xad5be633 in NMNetworkManager::qt_metacall (this=0x82156c8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd8da38)
    at /usr/src/debug/kdebase-workspace-4.5.80/build/solid/networkmanager-0.7/manager.moc:111
#30 0xb6ebde5d in QMetaObject::metacall (object=0x82156c8, cl=QMetaObject::InvokeMetaMethod, idx=21, argv=0xbfd8da38) at kernel/qmetaobject.cpp:237
#31 0xb6ecdffc in QMetaObject::activate (sender=0x82077e8, m=0xad5d7a80, local_signal_index=0, argv=0xbfd8da38) at kernel/qobject.cpp:3272
#32 0xad5c8f45 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x82077e8, _t1=...)
    at /usr/src/debug/kdebase-workspace-4.5.80/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:161
#33 0xad5c9427 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x82077e8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfd8dc8c)
    at /usr/src/debug/kdebase-workspace-4.5.80/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:105
#34 0xb5cefe17 in QDBusConnectionPrivate::deliverCall (this=0x81a4348, object=0x82077e8, msg=..., metaTypes=..., slotIdx=137526816) at qdbusintegrator.cpp:919
#35 0xb5cfc8d6 in QDBusCallDeliveryEvent::placeMetaCall (this=0x8194b28, object=0x82077e8) at qdbusintegrator_p.h:103
#36 0xb6eccb7f in QObject::event (this=0x82077e8, e=0x8194b28) at kernel/qobject.cpp:1211
#37 0xb63b3414 in QApplicationPrivate::notify_helper (this=0x80b0058, receiver=0x82077e8, e=0x8194b28) at kernel/qapplication.cpp:4445
#38 0xb63bc137 in QApplication::notify (this=0xbfd8e4f0, receiver=0x82077e8, e=0x8194b28) at kernel/qapplication.cpp:3845
#39 0xb7523471 in KApplication::notify (this=0xbfd8e4f0, receiver=0x82077e8, event=0x8194b28) at /usr/src/debug/kdelibs-4.5.80/kdeui/kernel/kapplication.cpp:311
#40 0xb6eb75be in QCoreApplication::notifyInternal (this=0xbfd8e4f0, receiver=0x82077e8, event=0x8194b28) at kernel/qcoreapplication.cpp:732
#41 0xb6ebb34c in sendEvent (receiver=0x0, event_type=0, data=0x80582b0) at kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80582b0) at kernel/qcoreapplication.cpp:1373
#43 0xb6ebb49c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#44 0xb6ee5bd4 in sendPostedEvents (s=0x80b2320) at kernel/qcoreapplication.h:220
#45 postEventSourceDispatch (s=0x80b2320) at kernel/qeventdispatcher_glib.cpp:277
#46 0xb5b57b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#47 0xb5b58350 in ?? () from /usr/lib/libglib-2.0.so.0
#48 0xb5b5860e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#49 0xb6ee5d5b in QEventDispatcherGlib::processEvents (this=0x80b0038, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#50 0xb64699aa in QGuiEventDispatcherGlib::processEvents (this=0x80b0038, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#51 0xb6eb689d in QEventLoop::processEvents (this=0xbfd8e454, flags=...) at kernel/qeventloop.cpp:149
#52 0xb6eb6ac9 in QEventLoop::exec (this=0xbfd8e454, flags=...) at kernel/qeventloop.cpp:201
#53 0xb6ebb570 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#54 0xb63b1114 in QApplication::exec () at kernel/qapplication.cpp:3719
#55 0xb551438d in kdemain (argc=1, argv=0x809d710) at /usr/src/debug/kdelibs-4.5.80/kded/kded.cpp:907
#56 0x0804e521 in launch (argc=1, _name=0x8052708 "kded4", args=<value optimized out>, cwd=0x0, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=
    0x80525a3 "0") at /usr/src/debug/kdelibs-4.5.80/kinit/kinit.cpp:730
#57 0x08050f28 in main (argc=) at /usr/src/debug/kdelibs-4.5.80/kinit/kinit.cpp:1844

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-04 15:55:11 UTC
[Comment from a bug triager]
This may be related to bug 210878. Regards
Comment 2 Lamarque V. Souza 2011-02-04 15:10:36 UTC

*** This bug has been marked as a duplicate of bug 210878 ***