Bug 263827 - KNetworkManager crash after updating YaST's network settings
Summary: KNetworkManager crash after updating YaST's network settings
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-21 09:42 UTC by Pieter De Decker
Modified: 2011-04-11 23:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pieter De Decker 2011-01-21 09:42:33 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.5.5 (KDE 4.5.5) "release 1"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.7-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I was trying to change the host name of my computer using openSUSE's YaST configuration tool. KNetworkManager crashed while openSUSE was saving my changes.

-- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  0x0000000000000020 in ?? ()
#7  0x00007f5072b757a9 in QMetaObject::cast (this=0x62b0a0, obj=0x7a5290) at kernel/qmetaobject.cpp:266
#8  0x00007f50735a224a in qobject_cast<Knm::InterfaceConnection const*> (first=0x7a5290, second=0x967130) at /usr/include/QtCore/qobject.h:468
#9  activatableLessThan (first=0x7a5290, second=0x967130) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:184
#10 0x00007f50735a2d1a in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., t=
    @0x927ee0, lessThan=0x7f50735a21e0 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:356
#11 0x00007f50735a2ac7 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x7d2ac0, activatable=0x9c8190)
    at /usr/include/QtCore/qalgorithms.h:187
#12 SortedActivatableList::handleAdd (this=0x7d2ac0, activatable=0x9c8190) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:96
#13 0x00007f5073593283 in ActivatableList::notifyOnAddActivatable (this=<value optimized out>, activatable=0x9c8190) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:120
#14 0x00007f5073596c8e in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=<value optimized out>, addedConnection=<value optimized out>)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#15 0x00007f50735948bd in NetworkInterfaceActivatableProvider::init (this=0x9b1300) at /usr/src/debug/networkmanagement/libs/service/networkinterfaceactivatableprovider.cpp:64
#16 0x00007f5073593dfd in NetworkInterfaceMonitor::networkInterfaceAdded (this=<value optimized out>, uni=...) at /usr/src/debug/networkmanagement/libs/service/networkinterfacemonitor.cpp:87
#17 0x00007f507358f1cd in NetworkInterfaceMonitor::qt_metacall (this=0x7b9150, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffffac406f0)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_networkinterfacemonitor.cpp:75
#18 0x00007f5072b83a1f in QMetaObject::activate (sender=0x77ae80, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ffffac406f0) at kernel/qobject.cpp:3295
#19 0x00007f5073116505 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.5.5/build/libs/solid/control/networkmanager.moc:107
#20 0x00007f5073116ad7 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x77ae80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffffac40810)
    at /usr/src/debug/kdebase-workspace-4.5.5/build/libs/solid/control/networkmanager_p.moc:81
#21 0x00007f5072b83a1f in QMetaObject::activate (sender=0x789de0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ffffac40810) at kernel/qobject.cpp:3295
#22 0x00007f506e6e2b85 in Solid::Control::Ifaces::NetworkManager::networkInterfaceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.5.5/build/libs/solid/control/ifaces/networkmanager.moc:115
#23 0x00007f5063afc04a in NMNetworkManager::deviceAdded (this=0x789de0, objpath=...) at /usr/src/debug/kdebase-workspace-4.5.5/solid/networkmanager-0.7/manager.cpp:199
#24 0x00007f5063b05d69 in NMNetworkManager::qt_metacall (this=0x789de0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffffac409d0)
    at /usr/src/debug/kdebase-workspace-4.5.5/build/solid/networkmanager-0.7/manager.moc:95
#25 0x00007f5072b83a1f in QMetaObject::activate (sender=0x78a890, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ffffac409d0) at kernel/qobject.cpp:3295
#26 0x00007f5063af8aa2 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.5.5/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:155
#27 0x00007f5063b00f84 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x78a890, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7ffffac40e10)
    at /usr/src/debug/kdebase-workspace-4.5.5/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:102
#28 0x00007f5072ea7188 in QDBusConnectionPrivate::deliverCall (this=0x770d50, object=0x78a890, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#29 0x00007f5072eb3ecf in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:101
#30 0x00007f5072b81509 in QObject::event (this=0x78a890, e=0x7bc0d0) at kernel/qobject.cpp:1248
#31 0x00007f5071f614d4 in QApplicationPrivate::notify_helper (this=0x65fc00, receiver=0x78a890, e=0x7bc0d0) at kernel/qapplication.cpp:4302
#32 0x00007f5071f69aca in QApplication::notify (this=<value optimized out>, receiver=0x78a890, e=0x7bc0d0) at kernel/qapplication.cpp:4185
#33 0x00007f5073e8e876 in KApplication::notify (this=0x7ffffac418f0, receiver=0x78a890, event=0x7bc0d0) at /usr/src/debug/kdelibs-4.5.5/kdeui/kernel/kapplication.cpp:310
#34 0x00007f5072b6fe4c in QCoreApplication::notifyInternal (this=0x7ffffac418f0, receiver=0x78a890, event=0x7bc0d0) at kernel/qcoreapplication.cpp:726
#35 0x00007f5072b735ba in sendEvent (receiver=0x0, event_type=0, data=0x632220) at kernel/qcoreapplication.h:215
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x632220) at kernel/qcoreapplication.cpp:1367
#37 0x00007f5072b98173 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#38 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#39 0x00007f506d9d6a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#40 0x00007f506d9d7270 in ?? () from /usr/lib64/libglib-2.0.so.0
#41 0x00007f506d9d7510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#42 0x00007f5072b9867f in QEventDispatcherGlib::processEvents (this=0x6378b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#43 0x00007f507200214e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#44 0x00007f5072b6f292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#45 0x00007f5072b6f495 in QEventLoop::exec (this=0x7ffffac41840, flags=...) at kernel/qeventloop.cpp:201
#46 0x00007f5072b7388b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#47 0x000000000040eca3 in _start ()

This bug may be a duplicate of or related to bug 258168.

Possible duplicates by query: bug 263047, bug 258907, bug 258168, bug 256676, bug 256662.

Reported using DrKonqi
Comment 1 Dario Andres 2011-01-22 12:58:33 UTC
[Comment from a bug triager]
This is probably related to bug 258168 / bug 256662 / bug 210878.
Regards
Comment 2 Lamarque V. Souza 2011-04-11 23:06:25 UTC

*** This bug has been marked as a duplicate of bug 210878 ***