Bug 264185 - KDE crashed when Network Connections open to Wireless tab and network-manager restarted.
Summary: KDE crashed when Network Connections open to Wireless tab and network-manager...
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: KDED Module (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-24 17:12 UTC by Mark Wickham
Modified: 2011-01-29 14:23 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Wickham 2011-01-24 17:12:05 UTC
Application: kded4 ($Id: kded.cpp 1156841 2010-07-29 19:59:05Z zander $)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic-pae i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I was trying to get my wifi adapter running, and googling was not giving me the information necessary to start it.  I tried to iwconfig and ifconfig the wlan0 and then tried to ./network-manager restart which suggested sudo restart network-manager, which "worked" but then caused the crash.  Network Connections - System Settings was open to the Wiireless tab.  Transcript follows:

          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

markw@markw4:/etc/init.d$ ping google.com
ping: unknown host google.com
markw@markw4:/etc/init.d$ sudo ifconfig wlan0 up
markw@markw4:/etc/init.d$ ifconfig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1200 (1.2 KB)  TX bytes:1200 (1.2 KB)

vmnet1    Link encap:Ethernet  HWaddr 00:50:56:c0:00:01  
          inet addr:192.168.65.1  Bcast:192.168.65.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

vmnet8    Link encap:Ethernet  HWaddr 00:50:56:c0:00:08  
          inet addr:192.168.232.1  Bcast:192.168.232.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:59 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:24:d7:20:91:74  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

markw@markw4:/etc/init.d$ ls
acpid              dmesg                       pcmciautils      ssh
acpi-support       dns-clean                   plymouth         stop-bootlogd
alsa-mixer-save    failsafe-x                  plymouth-log     stop-bootlogd-single
anacron            fancontrol                  plymouth-splash  sudo
apparmor           grub-common                 plymouth-stop    udev
apport             halt                        pppd-dns         udev-finish
atd                hostname                    procps           udevmonitor
avahi-daemon       hwclock                     pulseaudio       udevtrigger
binfmt-support     hwclock-save                rc               ufw
bluetooth          irqbalance                  rc.local         umountfs
bootlogd           kdm                         rcS              umountnfs.sh
brltty             kerneloops                  README           umountroot
console-setup      killprocs                   reboot           unattended-upgrades
cron               lm-sensors                  rsync            urandom
cryptdisks         module-init-tools           rsyslog          vmware
cryptdisks-early   networking                  saned            winbind
cryptdisks-enable  network-interface           screen-cleanup   x11-common
cryptdisks-udev    network-interface-security  sendsigs
cups               network-manager             single
dbus               ondemand                    skeleton
markw@markw4:/etc/init.d$ ./network-manager restart
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service network-manager restart

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the restart(8) utility, e.g. restart network-manager
restart: Rejected send message, 1 matched rules; type="method_call", sender=":1.51" (uid=1000 pid=2726 comm="restart) interface="com.ubuntu.Upstart0_6.Job" member="Restart" error name="(unset)" requested_reply=0 destination="com.ubuntu.Upstart" (uid=0 pid=1 comm="/sbin/init"))
markw@markw4:/etc/init.d$ sudo restart network-manager
network-manager start/running, process 2732
markw@markw4:/etc/init.d$

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5ab0710 (LWP 1866))]

Thread 2 (Thread 0xb01ceb70 (LWP 2239)):
#0  0xb5d6ee36 in clock_gettime () from /lib/librt.so.1
#1  0xb6e6a50b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0xb6f416e5 in QTimerInfoList::updateCurrentTime (this=0x842f514) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb6f4172a in QTimerInfoList::timerWait (this=0x842f514, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6f3f7a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb01ce0cc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6f3f83d in timerSourcePrepare (source=0x0, timeout=0xb5d72ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb5cdce6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb5cdd279 in ?? () from /lib/libglib-2.0.so.0
#9  0xb5cdd848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb6f3f59f in QEventDispatcherGlib::processEvents (this=0x8416b48, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0xb6f0f609 in QEventLoop::processEvents (this=0xb01ce2a0, flags=) at kernel/qeventloop.cpp:149
#12 0xb6f0fa8a in QEventLoop::exec (this=0xb01ce2a0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6e0bb7e in QThread::exec (this=0x842cb50) at thread/qthread.cpp:490
#14 0xb0e25e76 in ?? () from /usr/lib/kde4/kded_bluedevil.so
#15 0xb6e0edf9 in QThreadPrivate::start (arg=0x842cb50) at thread/qthread_unix.cpp:266
#16 0xb6d98cc9 in start_thread () from /lib/libpthread.so.0
#17 0xb60b769e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5ab0710 (LWP 1866)):
[KCrash Handler]
#7  0x00670061 in ?? ()
#8  0xb6f168f9 in QMetaObject::cast (this=0xb04eb490, obj=0x848b6e8) at kernel/qmetaobject.cpp:266
#9  0xb04a344e in qobject_cast<Knm::InterfaceConnection const*> (first=0x848b6e8, second=0x848f518) at /usr/include/qt4/QtCore/qobject.h:468
#10 activatableLessThan (first=0x848b6e8, second=0x848f518) at ../../../libs/service/sortedactivatablelist.cpp:183
#11 0xb04a36d3 in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=<value optimized out>, end=) at /usr/include/qt4/QtCore/qalgorithms.h:356
#12 0xb04a3982 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x83f3020, activatable=0x8469030) at /usr/include/qt4/QtCore/qalgorithms.h:187
#13 SortedActivatableList::handleAdd (this=0x83f3020, activatable=0x8469030) at ../../../libs/service/sortedactivatablelist.cpp:96
#14 0xb0491ac3 in ActivatableList::notifyOnAddActivatable (this=0x83e7d38, activatable=0x8469030) at ../../../libs/service/activatablelist.cpp:99
#15 0xb0492318 in ActivatableList::addActivatable (this=0x83e7d38, activatable=0x8469030) at ../../../libs/service/activatablelist.cpp:83
#16 0xb04965c6 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x8489788, addedConnection=0x8496170) at ../../../libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#17 0xb0493b40 in NetworkInterfaceActivatableProvider::init (this=0x8489788) at ../../../libs/service/networkinterfaceactivatableprovider.cpp:64
#18 0xb04929b3 in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x83f0570, uni=...) at ../../../libs/service/networkinterfacemonitor.cpp:87
#19 0xb048c0eb in NetworkInterfaceMonitor::qt_metacall (this=0x83f0570, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbffabaa8) at moc_networkinterfacemonitor.cpp:75
#20 0xb6f168ca in QMetaObject::metacall (object=0x83f0570, cl=138979073, idx=4, argv=0xbffabaa8) at kernel/qmetaobject.cpp:237
#21 0xb6f296ad in QMetaObject::activate (sender=0x83e73d8, m=0xb0e97540, local_signal_index=1, argv=0x847efb0) at kernel/qobject.cpp:3280
#22 0xb0e77f03 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x83e73d8, _t1=...) at ./networkmanager.moc:107
#23 0xb0e78986 in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x83e73d8, uni=...) at ../../../../libs/solid/control/networkmanager.cpp:197
#24 0xb0e78a07 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x83e73d8, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbffabc18) at ./networkmanager_p.moc:81
#25 0xb6f168ca in QMetaObject::metacall (object=0x83e73d8, cl=138979073, idx=10, argv=0xbffabc18) at kernel/qmetaobject.cpp:237
#26 0xb6f296ad in QMetaObject::activate (sender=0x83ed358, m=0xb0e61950, local_signal_index=1, argv=0x847efb0) at kernel/qobject.cpp:3280
#27 0xb0e5d6c3 in Solid::Control::Ifaces::NetworkManager::networkInterfaceAdded (this=0x83ed358, _t1=...) at ./networkmanager.moc:115
#28 0xb039e98a in NMNetworkManager::deviceAdded (this=0x83ed358, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:199
#29 0xb03a2bd5 in NMNetworkManager::qt_metacall (this=0x83ed358, _c=QMetaObject::InvokeMetaMethod, _id=15, _a=0xbffabdb8) at ./manager.moc:95
#30 0xb6f168ca in QMetaObject::metacall (object=0x83ed358, cl=138979073, idx=15, argv=0xbffabdb8) at kernel/qmetaobject.cpp:237
#31 0xb6f296ad in QMetaObject::activate (sender=0x83ede00, m=0xb03b7a80, local_signal_index=0, argv=0x847efb0) at kernel/qobject.cpp:3280
#32 0xb03ad673 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x83ede00, _t1=...) at ./nm-manager-clientinterface.moc:155
#33 0xb03adbf5 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x83ede00, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbffabffc) at ./nm-manager-clientinterface.moc:102
#34 0xb70649dc in QDBusConnectionPrivate::deliverCall (this=0x83d6418, object=0x83ede00, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:919
#35 0xb70701f7 in QDBusCallDeliveryEvent::placeMetaCall (this=0x8430948, object=0x83ede00) at qdbusintegrator_p.h:103
#36 0xb6f236a2 in QObject::event (this=0x83ede00, e=0xb04eb490) at kernel/qobject.cpp:1219
#37 0xb639dfdc in QApplicationPrivate::notify_helper (this=0x8317988, receiver=0x83ede00, e=0x8430948) at kernel/qapplication.cpp:4396
#38 0xb63a404e in QApplication::notify (this=0xbffac8d0, receiver=0x83ede00, e=0x8430948) at kernel/qapplication.cpp:3798
#39 0xb763c68a in KApplication::notify (this=0xbffac8d0, receiver=0x83ede00, event=0x8430948) at ../../kdeui/kernel/kapplication.cpp:310
#40 0xb6f10b3b in QCoreApplication::notifyInternal (this=0xbffac8d0, receiver=0x83ede00, event=0x8430948) at kernel/qcoreapplication.cpp:732
#41 0xb6f13d8b in sendEvent (receiver=0x0, event_type=0, data=0x82bef20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x82bef20) at kernel/qcoreapplication.cpp:1373
#43 0xb6f13f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#44 0xb6f3fa74 in sendPostedEvents (s=0x8319b10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#45 postEventSourceDispatch (s=0x8319b10) at kernel/qeventdispatcher_glib.cpp:277
#46 0xb5cd9855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#47 0xb5cdd668 in ?? () from /lib/libglib-2.0.so.0
#48 0xb5cdd848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#49 0xb6f3f565 in QEventDispatcherGlib::processEvents (this=0x82c01d0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#50 0xb645fbe5 in QGuiEventDispatcherGlib::processEvents (this=0x82c01d0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#51 0xb6f0f609 in QEventLoop::processEvents (this=0xbffac824, flags=) at kernel/qeventloop.cpp:149
#52 0xb6f0fa8a in QEventLoop::exec (this=0xbffac824, flags=...) at kernel/qeventloop.cpp:201
#53 0xb6f1400f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#54 0xb639ce07 in QApplication::exec () at kernel/qapplication.cpp:3672
#55 0xb5635cf7 in kdemain (argc=1, argv=0x83020e8) at ../../kded/kded.cpp:894
#56 0x0804e4d1 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x0, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x80517f7 "0") at ../../kinit/kinit.cpp:723
#57 0x0805048d in main (argc=4, argv=0xbffad054, envp=0xbffad068) at ../../kinit/kinit.cpp:1835

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-01-24 20:31:15 UTC
This is a duplicate of bug http://bugs.kde.org/210878 and is already fixed since last november. You need to checkout a more recent networkmanagement revision or wait for your distribution to do so.
Comment 2 Dario Andres 2011-01-29 14:23:30 UTC

*** This bug has been marked as a duplicate of bug 210878 ***