Bug 263663 - Nepomuk crush
Summary: Nepomuk crush
Status: RESOLVED DUPLICATE of bug 245266
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-19 16:52 UTC by Andrew Tee
Modified: 2011-03-17 11:09 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Tee 2011-01-19 16:52:08 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.5.5 (KDE 4.5.5)
Qt Version: 4.7.1
Operating System: Linux 2.6.35.10-74.fc14.x86_64 x86_64
Distribution: "RFRemix release 14 (Laughlin)"

-- Information about the crash:
- What I was doing when the application crashed:

actually nothing.. demons started but i never use it and leave all settings in default state.
same problems i have on my arch laptop with lastest RC of kde.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fde6b2c9980 (LWP 3098))]

Thread 2 (Thread 0x7fde5ec25700 (LWP 3151)):
[KCrash Handler]
#6  0x0000003761e6e17c in QMutex::lock (this=0x1d589a8) at thread/qmutex.cpp:151
#7  0x000000376565092c in QMutexLocker (this=0x7fde580bb170) at /usr/include/QtCore/qmutex.h:102
#8  Soprano::Error::ErrorCache::clearError (this=0x7fde580bb170) at /usr/src/debug/soprano-2.5.2/soprano/error.cpp:238
#9  0x0000003765650bc0 in Soprano::Error::ErrorCache::setError (this=0x7fde580bb170, error=...) at /usr/src/debug/soprano-2.5.2/soprano/error.cpp:225
#10 0x0000003765237211 in Soprano::Client::DBusModel::executeQuery (this=0x7fde580bb160, query=<value optimized out>, language=<value optimized out>, userQueryLanguage=<value optimized out>) at /usr/src/debug/soprano-2.5.2/client/dbus/dbusmodel.cpp:108
#11 0x00007fde6b525134 in Nepomuk::MainModel::executeQuery (this=0x1e0cbf0, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/nepomukmainmodel.cpp:212
#12 0x000000376565c2ac in Soprano::FilterModel::executeQuery (this=0x1e0b830, query=<value optimized out>, language=<value optimized out>, userQueryLanguage=<value optimized out>) at /usr/src/debug/soprano-2.5.2/soprano/filtermodel.cpp:164
#13 0x00007fde6b51b55e in Nepomuk::ResourceData::determineUri (this=0x7fde580bc0d0) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resourcedata.cpp:580
#14 0x00007fde6b52e4ba in Nepomuk::Resource::determineFinalResourceData (this=0x7fde5ec24110) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resource.cpp:885
#15 0x00007fde6b52fe73 in Nepomuk::Resource::resourceUri (this=0x7fde5ec24110) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resource.cpp:165
#16 0x00007fde5f199c36 in FileMetaData (this=0x7fde58026500, idx=0x7fde5ec247a0) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/strigibackend/nepomukindexwriter.cpp:190
#17 Strigi::NepomukIndexWriter::startAnalysis (this=0x7fde58026500, idx=0x7fde5ec247a0) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/strigibackend/nepomukindexwriter.cpp:373
#18 0x00007fde5f5c9528 in Nepomuk::IndexScheduler::analyzeFile (this=<value optimized out>, file=..., analyzer=0x7fde5ec24bf0) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/services/strigi/indexscheduler.cpp:443
#19 0x00007fde5f5cd4c0 in Nepomuk::IndexScheduler::updateDir (this=0x1e10560, dir=<value optimized out>, analyzer=0x7fde5ec24bf0, flags=...) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/services/strigi/indexscheduler.cpp:413
#20 0x00007fde5f5ce089 in Nepomuk::IndexScheduler::run (this=0x1e10560) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/services/strigi/indexscheduler.cpp:314
#21 0x0000003761e726ee in QThreadPrivate::start (arg=0x1e10560) at thread/qthread_unix.cpp:285
#22 0x0000003d71206d5b in start_thread () from /lib64/libpthread.so.0
#23 0x0000003d706e4a7d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fde6b2c9980 (LWP 3098)):
#0  0x0000003d706db083 in poll () from /lib64/libc.so.6
#1  0x0000003761a25420 in socket_do_iteration (transport=0x1d588b0, flags=7, timeout_milliseconds=<value optimized out>) at dbus-transport-socket.c:1125
#2  0x0000003761a2431d in _dbus_transport_do_iteration (transport=0x1d588b0, flags=<value optimized out>, timeout_milliseconds=<value optimized out>) at dbus-transport.c:980
#3  0x0000003761a0edd5 in _dbus_connection_do_iteration_unlocked (connection=0x1d5b8a0, pending=<value optimized out>, flags=7, timeout_milliseconds=-1) at dbus-connection.c:1206
#4  0x0000003761a0ffb4 in _dbus_connection_flush_unlocked (connection=0x1d5b8a0) at dbus-connection.c:3603
#5  0x0000003761a100d1 in _dbus_connection_block_pending_call (pending=0x1e86430) at dbus-connection.c:2379
#6  0x0000003761a0f6f4 in dbus_connection_send_with_reply_and_block (connection=0x1d5b8a0, message=0x1d5bd90, timeout_milliseconds=-1, error=0x7fff06c22060) at dbus-connection.c:3559
#7  0x0000003762824356 in q_dbus_connection_send_with_reply_and_block (this=0x1d57800, message=..., sendMode=<value optimized out>, timeout=-1) at qdbus_symbols_p.h:135
#8  QDBusConnectionPrivate::sendWithReply (this=0x1d57800, message=..., sendMode=<value optimized out>, timeout=-1) at qdbusintegrator.cpp:1844
#9  0x0000003762812d73 in QDBusConnection::call (this=0x1e0da80, message=<value optimized out>, mode=<value optimized out>, timeout=<value optimized out>) at qdbusconnection.cpp:529
#10 0x0000003762831f42 in QDBusAbstractInterface::callWithArgumentList (this=0x1e0d980, mode=QDBus::Block, method=<value optimized out>, args=...) at qdbusabstractinterface.cpp:444
#11 0x000000376523486d in createModel (this=0x1e0d660, name=<value optimized out>, settings=<value optimized out>) at /usr/src/debug/soprano-2.5.2/client/dbus/dbusserverinterface.h:57
#12 Soprano::Client::DBusClient::createModel (this=0x1e0d660, name=<value optimized out>, settings=<value optimized out>) at /usr/src/debug/soprano-2.5.2/client/dbus/dbusclient.cpp:73
#13 0x00007fde6b52a162 in init (this=0x1e0cbf0) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/nepomukmainmodel.cpp:92
#14 Nepomuk::MainModel::init (this=0x1e0cbf0) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/nepomukmainmodel.cpp:176
#15 0x00007fde6b51e9f7 in Nepomuk::ResourceManager::init (this=0x1e0b3f0) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resourcemanager.cpp:329
#16 0x00007fde6b520665 in Nepomuk::ResourceManagerPrivate::_k_storageServiceInitialized (this=0x1e0b6d0, success=<value optimized out>) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resourcemanager.cpp:220
#17 0x00007fde6b520775 in Nepomuk::ResourceManager::qt_metacall (this=0x1e0b3f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff06c22a70) at /usr/src/debug/kdelibs-4.5.5/x86_64-redhat-linux-gnu/nepomuk/resourcemanager.moc:90
#18 0x0000003762820228 in QDBusConnectionPrivate::deliverCall (this=0x1d57800, object=0x1e0b3f0, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:919
#19 0x000000376282b0ff in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:103
#20 0x0000003761f6fb4a in QObject::event (this=0x1e0b3f0, e=<value optimized out>) at kernel/qobject.cpp:1211
#21 0x00000037631b78c4 in QApplicationPrivate::notify_helper (this=0x1cae490, receiver=0x1e0b3f0, e=0x1ef0790) at kernel/qapplication.cpp:4445
#22 0x00000037631bc3da in QApplication::notify (this=<value optimized out>, receiver=0x1e0b3f0, e=0x1ef0790) at kernel/qapplication.cpp:4324
#23 0x00007fde6b99f596 in KApplication::notify (this=0x7fff06c236c0, receiver=0x1e0b3f0, event=0x1ef0790) at /usr/src/debug/kdelibs-4.5.5/kdeui/kernel/kapplication.cpp:310
#24 0x0000003761f5b7ac in QCoreApplication::notifyInternal (this=0x7fff06c236c0, receiver=0x1e0b3f0, event=0x1ef0790) at kernel/qcoreapplication.cpp:732
#25 0x0000003761f5ef95 in sendEvent (receiver=0x0, event_type=0, data=0x1c96b00) at kernel/qcoreapplication.h:215
#26 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1c96b00) at kernel/qcoreapplication.cpp:1373
#27 0x0000003761f86723 in sendPostedEvents (s=0x1cb2040) at kernel/qcoreapplication.h:220
#28 postEventSourceDispatch (s=0x1cb2040) at kernel/qeventdispatcher_glib.cpp:277
#29 0x0000003d72e41e33 in g_main_dispatch (context=0x1cb1120) at gmain.c:2149
#30 g_main_context_dispatch (context=0x1cb1120) at gmain.c:2702
#31 0x0000003d72e42610 in g_main_context_iterate (context=0x1cb1120, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#32 0x0000003d72e428ad in g_main_context_iteration (context=0x1cb1120, may_block=1) at gmain.c:2843
#33 0x0000003761f868bf in QEventDispatcherGlib::processEvents (this=0x1c961f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#34 0x000000376325c59e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#35 0x0000003761f5ab42 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#36 0x0000003761f5ad8c in QEventLoop::exec (this=0x7fff06c23490, flags=...) at kernel/qeventloop.cpp:201
#37 0x0000003761f5f24b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#38 0x0000000000403c32 in main (argc=2, argv=0x7fff06c23b18) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/servicestub/main.cpp:165

This bug may be a duplicate of or related to bug 245266.

Possible duplicates by query: bug 263078, bug 260856, bug 258235, bug 256895, bug 252766.

Reported using DrKonqi
Comment 1 Sebastian Trueg 2011-01-19 17:05:40 UTC

*** This bug has been marked as a duplicate of bug 245266 ***
Comment 2 Scott 2011-03-17 10:08:52 UTC
Still happening for me with KDE 4.6.1 from backports.
Comment 3 Sebastian Trueg 2011-03-17 10:44:38 UTC
@Scott: are you sure it is the same crash and not bug #267666
Comment 4 Scott 2011-03-17 11:09:32 UTC
@Sebastian - yep was about to correct myself. It was #267666. Sorry and thanks for the response.