Bug 267666 - Nepomuk crashes on startup/login [Nepomuk::Repository::close, Nepomuk::Repository::~Repository, Soprano::Server::ServerCore::~ServerCore]
Summary: Nepomuk crashes on startup/login [Nepomuk::Repository::close, Nepomuk::Reposi...
Status: RESOLVED FIXED
Alias: None
Product: nepomuk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash with 60 votes (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
: 256189 266804 267681 267703 267724 267798 267821 267834 267847 267921 267922 267945 267994 268002 268039 268192 268249 268381 268633 268651 268682 268725 268748 268905 268943 269066 269283 269487 269527 270334 270427 270745 270804 271726 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-04 23:54 UTC by Thilo-Alexander Ginkel
Modified: 2011-12-07 10:43 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.6.2


Attachments
New crash information added by DrKonqi (2.28 KB, text/plain)
2011-03-05 07:52 UTC, Michael Chalvatzis
Details
New crash information added by DrKonqi (2.42 KB, text/plain)
2011-03-05 08:33 UTC, lpoujoulat
Details
New crash information added by DrKonqi (2.57 KB, text/plain)
2011-03-06 02:34 UTC, Chris Samuel
Details
New crash information added by DrKonqi (2.41 KB, text/plain)
2011-03-07 12:36 UTC, Leo
Details
New crash information added by DrKonqi (2.34 KB, text/plain)
2011-03-07 17:05 UTC, adam.hawthorne
Details
New crash information added by DrKonqi (2.32 KB, text/plain)
2011-03-07 17:23 UTC, David
Details
New crash information added by DrKonqi (2.64 KB, text/plain)
2011-03-07 20:27 UTC, Paul Lemmons
Details
New crash information added by DrKonqi (2.39 KB, text/plain)
2011-03-09 17:16 UTC, Michael Trace
Details
New crash information added by DrKonqi (3.28 KB, text/plain)
2011-03-09 18:01 UTC, Stephan Menzel
Details
New crash information added by DrKonqi (3.28 KB, text/plain)
2011-03-14 20:56 UTC, Adam Porter
Details
New crash information added by DrKonqi (2.67 KB, text/plain)
2011-03-14 22:28 UTC, Waleed Hamra
Details
New crash information added by DrKonqi (2.46 KB, text/plain)
2011-03-15 13:00 UTC, Graziano
Details
New crash information added by DrKonqi (2.61 KB, text/plain)
2011-03-15 22:13 UTC, Craig Lillie
Details
New crash information added by DrKonqi (2.15 KB, text/plain)
2011-03-16 07:21 UTC, Alexandr
Details
New crash information added by DrKonqi (2.67 KB, text/plain)
2011-03-25 08:59 UTC, Sven Eden
Details
New crash information added by DrKonqi (2.57 KB, text/plain)
2011-03-29 11:40 UTC, shani
Details
New crash information added by DrKonqi (2.39 KB, text/plain)
2011-04-05 12:15 UTC, Sylvain Garsault
Details
New crash information added by DrKonqi (3.41 KB, text/plain)
2011-04-09 07:00 UTC, Weonjong Lee
Details
New crash information added by DrKonqi (4.02 KB, text/plain)
2011-10-04 22:27 UTC, Christoph Feck
Details
New crash information added by DrKonqi (3.49 KB, text/plain)
2011-10-05 18:37 UTC, Jaime Torres
Details
New crash information added by DrKonqi (3.39 KB, text/plain)
2011-10-30 16:44 UTC, Andre
Details
New crash information added by DrKonqi (2.91 KB, text/plain)
2011-12-06 22:56 UTC, Gianfranco L'Abbate
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thilo-Alexander Ginkel 2011-03-04 23:54:20 UTC
Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

When logging in, I am immediately greeted with a crash dialog that provides me with the following details:

Application: Nepomuk Service Stub (nepomukservicestub), signal: Segmentation fault
[KCrash Handler]
#6  0x00007effa0cd252c in Nepomuk::Repository::close (this=0x2475080) at ../../../../nepomuk/services/storage/repository.cpp:73
#7  0x00007effa0cd261d in Nepomuk::Repository::~Repository (this=0x2475080, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/repository.cpp:65
#8  0x00007effa0a9e68f in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#9  0x00007effa0cd1405 in Nepomuk::Core::~Core (this=0x24711b0, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#10 0x00007effb1195d5f in QObjectPrivate::deleteChildren (this=0x2471790) at kernel/qobject.cpp:1957
#11 0x00007effb119d41b in QObject::~QObject (this=<value optimized out>, __in_chrg=<value optimized out>) at kernel/qobject.cpp:945
#12 0x00007effa0cd0163 in Nepomuk::Storage::~Storage (this=0x2517720, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:52
#13 0x00007effb1195d5f in QObjectPrivate::deleteChildren (this=0x2492880) at kernel/qobject.cpp:1957
#14 0x00007effb119d41b in QObject::~QObject (this=<value optimized out>, __in_chrg=<value optimized out>) at kernel/qobject.cpp:945
#15 0x000000000040451e in Nepomuk::ServiceControl::~ServiceControl (this=0x2492420, __in_chrg=<value optimized out>) at ../../../nepomuk/servicestub/servicecontrol.cpp:39
#16 0x00007effb1195d5f in QObjectPrivate::deleteChildren (this=0x2370400) at kernel/qobject.cpp:1957
#17 0x00007effb119d41b in QObject::~QObject (this=<value optimized out>, __in_chrg=<value optimized out>) at kernel/qobject.cpp:945
#18 0x00007effaf42172a in QApplication::~QApplication (this=0x7fffaa31a0d0, __in_chrg=<value optimized out>) at kernel/qapplication.cpp:1153
#19 0x0000000000403c66 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../nepomuk/servicestub/main.cpp:165


Reproducible: Always




This is actually KDE 4.6.1 (which I could not select from the version list as it is not yet available)
Comment 1 Thilo-Alexander Ginkel 2011-03-05 00:11:55 UTC
Seems to be related to this error message in ~/.kde/share/apps/nepomuk/repository/main/data/virtuosobackend/soprano-virtuoso.log:

                Fri Mar 04 2011
23:41:22 The transaction log file has been produced by server version '06.01.3126'. The version of this server is '06.01.3127'. If the transaction log is empty or you do not want to replay it then delete it and start the server again. Otherwise replay the log using the server of version '06.01.3126' and make checkpoint and shutdown to ensure that the log is empty, then delete it and start using new version.

After clearing this error Nepomuk and Strigi are starting correctly and the crash is no longer reproducible (still, KDE 4.6.0 did not crash despite the presence of this issue).
Comment 2 Michael Chalvatzis 2011-03-05 07:52:34 UTC
Created attachment 57686 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.0

Duplicate of the marked bug report

-- Backtrace (Reduced):
#6  0x00007f82cafe752c in Nepomuk::Repository::close (this=0x1fe2830) at ../../../../nepomuk/services/storage/repository.cpp:73
#7  0x00007f82cafe761d in Nepomuk::Repository::~Repository (this=0x1fe2830, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/repository.cpp:65
#8  0x00007f82cadb368f in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#9  0x00007f82cafe6405 in Nepomuk::Core::~Core (this=0x1fe0ab0, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#10 0x00007f82dbef4d5f in QObjectPrivate::deleteChildren (this=0x1fe0390) at kernel/qobject.cpp:1957
Comment 3 lpoujoulat 2011-03-05 08:33:39 UTC
Created attachment 57687 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.0

- What I was doing when the application crashed:
Trying to restore default "used memory" in the nepomuk settings from the system settings panel
Also happens on session startup

-- Backtrace (Reduced):
#6  0x00007f573bb3e52c in Nepomuk::Repository::close (this=0x1e210d0) at ../../../../nepomuk/services/storage/repository.cpp:73
#7  0x00007f573bb3e61d in Nepomuk::Repository::~Repository (this=0x1e210d0, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/repository.cpp:65
#8  0x00007f573b8dc68f in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#9  0x00007f573bb3d405 in Nepomuk::Core::~Core (this=0x1f18c80, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#10 0x00007f574becad5f in QObjectPrivate::deleteChildren (this=0x1f18560) at kernel/qobject.cpp:1957
Comment 4 Chris Samuel 2011-03-06 02:34:10 UTC
Created attachment 57710 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.0

- What I was doing when the application crashed:

First login to KDE 4.6.1 after upgrading to the Kubuntu backport PPA packages.

Unlike the original reporter I don't see any messages in my ~/.kde/share/apps/nepomuk/repository/main/data/virtuosobackend/soprano-virtuoso.log log file as log file was last updated on 6th January.

-- Backtrace (Reduced):
#6  0x00007f5fc44ea529 in Nepomuk::Repository::close (this=0x1bd48b0) at ../../../../nepomuk/services/storage/repository.cpp:73
#7  0x00007f5fc44ea61d in Nepomuk::Repository::~Repository (this=0x1bd48b0, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/repository.cpp:65
#8  0x00007f5fc42b668f in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#9  0x00007f5fc44e9405 in Nepomuk::Core::~Core (this=0x1bcfd60, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#10 0x00007f5fd47b5d5f in QObjectPrivate::deleteChildren (this=0x1bd0340) at kernel/qobject.cpp:1957
Comment 5 Chris Samuel 2011-03-06 02:49:08 UTC
This crash happens whenever I try and enable Strigi from the "Desktop Search" "Basic Setting" tab.
Comment 6 Christoph Feck 2011-03-07 03:12:04 UTC
*** Bug 267681 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Feck 2011-03-07 03:12:35 UTC
*** Bug 267703 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Feck 2011-03-07 03:12:54 UTC
*** Bug 267724 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Feck 2011-03-07 03:13:12 UTC
*** Bug 267798 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Feck 2011-03-07 03:13:30 UTC
*** Bug 267821 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Feck 2011-03-07 03:13:44 UTC
*** Bug 267834 has been marked as a duplicate of this bug. ***
Comment 12 Christoph Feck 2011-03-07 03:13:58 UTC
*** Bug 267847 has been marked as a duplicate of this bug. ***
Comment 13 Leo 2011-03-07 12:36:32 UTC
Created attachment 57744 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.0

- What I was doing when the application crashed:

Just log in in the kde enviroment and you get the error message

-- Backtrace (Reduced):
#6  0x00007f7124fed52c in Nepomuk::Repository::close (this=0x23a5170) at ../../../../nepomuk/services/storage/repository.cpp:73
#7  0x00007f7124fed61d in Nepomuk::Repository::~Repository (this=0x23a5170, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/repository.cpp:65
#8  0x00007f7124d9668f in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#9  0x00007f7124fec405 in Nepomuk::Core::~Core (this=0x23a3270, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#10 0x00007f713525bd5f in QObjectPrivate::deleteChildren (this=0x23a3a30) at kernel/qobject.cpp:1957
Comment 14 Leo 2011-03-07 12:51:29 UTC
I have tried to stop strigi system, clean the log file (> soprano-virtuoso.log), restarted the system and got the same crash :(
 

(In reply to comment #1)
> Seems to be related to this error message in
> ~/.kde/share/apps/nepomuk/repository/main/data/virtuosobackend/soprano-virtuoso.log:
> 
>                 Fri Mar 04 2011
> 23:41:22 The transaction log file has been produced by server version
> '06.01.3126'. The version of this server is '06.01.3127'. If the transaction
> log is empty or you do not want to replay it then delete it and start the
> server again. Otherwise replay the log using the server of version '06.01.3126'
> and make checkpoint and shutdown to ensure that the log is empty, then delete
> it and start using new version.
> 
> After clearing this error Nepomuk and Strigi are starting correctly and the
> crash is no longer reproducible (still, KDE 4.6.0 did not crash despite the
> presence of this issue).
Comment 15 nenad 2011-03-07 12:56:17 UTC
It seems to be plasma-related. Now I don't get the crash on loging, but rather when I mess around in plasma.

I did a uninstall of gmail-plasmoid, then installed the new version, and after adding it to a panel I got the nepomuk crash report. Don't know if it's coincidence though. 

I'm new at reporting bugs, so I hope you'll pardon me if these comments are useless.
Comment 16 adam.hawthorne 2011-03-07 17:05:10 UTC
Created attachment 57746 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.0

- What I was doing when the application crashed: It was on startup, just as the original bug report stated.

-- Backtrace (Reduced):
#6  0x00007f209f501529 in Nepomuk::Repository::close (this=0x10f5580) at ../../../../nepomuk/services/storage/repository.cpp:73
#7  0x00007f209f50161d in Nepomuk::Repository::~Repository (this=0x10f5580, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/repository.cpp:65
#8  0x00007f209f2cd68f in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#9  0x00007f209f500405 in Nepomuk::Core::~Core (this=0x10f52e0, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#10 0x00007f20b0357d5f in QObjectPrivate::deleteChildren (this=0x10f58c0) at kernel/qobject.cpp:1957
Comment 17 David 2011-03-07 17:23:14 UTC
Created attachment 57748 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.0

Cant say much, read previous statements ...

-- Backtrace (Reduced):
#6  0x00007fc279bbd529 in Nepomuk::Repository::close (this=0xb04830) at ../../../../nepomuk/services/storage/repository.cpp:73
#7  0x00007fc279bbd61d in Nepomuk::Repository::~Repository (this=0xb04830, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/repository.cpp:65
#8  0x00007fc27998968f in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#9  0x00007fc279bbc405 in Nepomuk::Core::~Core (this=0xaff190, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#10 0x00007fc289e60d5f in QObjectPrivate::deleteChildren (this=0xaff770) at kernel/qobject.cpp:1957
Comment 18 Paul Lemmons 2011-03-07 20:27:38 UTC
Created attachment 57754 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.0

- What I was doing when the application crashed: 
Crashed on startup. This happens every time I reboot and login to my account.

-- Backtrace (Reduced):
#7  0xb29a644c in Nepomuk::Repository::close (this=0x82d2f20) at ../../../../nepomuk/services/storage/repository.cpp:73
#8  0xb29a656b in Nepomuk::Repository::~Repository (this=0x82d2f20, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/repository.cpp:65
#9  0xb2973077 in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#10 0xb29a4f9b in Nepomuk::Core::~Core (this=0x82d3550, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#11 0xb75c2816 in QObjectPrivate::deleteChildren (this=0x82d39e8) at kernel/qobject.cpp:1957
Comment 19 Dario Andres 2011-03-07 22:00:49 UTC
[Comment from a bug triager]
From 267921:
- What I was doing when the application crashed:

* Update 4.6.0 -> 4.6.1
* Log out
* Log in -> crash
* Log out
* Log in -> same crash (this report)

The crash can be reproduced every time.
Comment 20 Dario Andres 2011-03-07 22:00:53 UTC
*** Bug 267921 has been marked as a duplicate of this bug. ***
Comment 21 Dario Andres 2011-03-08 14:48:19 UTC
[Comment from a bug triager]
From 267922:
- What I was doing when the application crashed:
Enabling Strigi Desktop File Indexer from System Settings

(other report)
- What I was doing when the application crashed:
I can confirm that this occurs on KDE 4.6.1 in Kubuntu also. I have even tested
a clean user account.

(other report)
- What I was doing when the application crashed:
Upgraded from 4.6.0 to 4.6.1. After reboot and login, I was greeted with the
attached backtrace and the message, that nepomuk service stub crashed.
Comment 22 Dario Andres 2011-03-08 14:48:24 UTC
*** Bug 267922 has been marked as a duplicate of this bug. ***
Comment 23 Dario Andres 2011-03-08 14:48:27 UTC
*** Bug 267945 has been marked as a duplicate of this bug. ***
Comment 24 Dario Andres 2011-03-08 19:48:05 UTC
*** Bug 267994 has been marked as a duplicate of this bug. ***
Comment 25 Dario Andres 2011-03-08 21:05:31 UTC
*** Bug 268002 has been marked as a duplicate of this bug. ***
Comment 26 Michael Trace 2011-03-09 17:16:17 UTC
Created attachment 57806 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.0

- What I was doing when the application crashed:  It just crashes upon boot and has since updating to 4.6.1 on Kubuntu 10.10.

-- Backtrace (Reduced):
#6  0x00007f8068de952c in Nepomuk::Repository::close (this=0x826880) at ../../../../nepomuk/services/storage/repository.cpp:73
#7  0x00007f8068de961d in Nepomuk::Repository::~Repository (this=0x826880, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/repository.cpp:65
#8  0x00007f8068bb568f in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#9  0x00007f8068de8405 in Nepomuk::Core::~Core (this=0x820540, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#10 0x00007f8079044d5f in QObjectPrivate::deleteChildren (this=0x820d00) at kernel/qobject.cpp:1957
Comment 27 Stephan Menzel 2011-03-09 18:01:53 UTC
Created attachment 57810 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.2

- What I was doing when the application crashed:

booting after upgrade to 4.6.1
Reproducable always

-- Backtrace (Reduced):
#6  0x00007ffec3384319 in Nepomuk::Repository::close (this=0xbdff60) at /var/tmp/portage/kde-base/nepomuk-4.6.1/work/nepomuk-4.6.1/nepomuk/services/storage/repository.cpp:73
#7  0x00007ffec33843fd in Nepomuk::Repository::~Repository (this=0xbdff60, __in_chrg=<value optimized out>) at /var/tmp/portage/kde-base/nepomuk-4.6.1/work/nepomuk-4.6.1/nepomuk/services/storage/repository.cpp:65
#8  0x00007ffec33844c9 in Nepomuk::Repository::~Repository (this=0xbdff60, __in_chrg=<value optimized out>) at /var/tmp/portage/kde-base/nepomuk-4.6.1/work/nepomuk-4.6.1/nepomuk/services/storage/repository.cpp:66
[...]
#10 0x00007ffec3151a8f in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#11 0x00007ffec33831e5 in Nepomuk::Core::~Core (this=0xbd7fa0, __in_chrg=<value optimized out>) at /var/tmp/portage/kde-base/nepomuk-4.6.1/work/nepomuk-4.6.1/nepomuk/services/storage/nepomukcore.cpp:45
Comment 28 Dario Andres 2011-03-11 00:43:27 UTC
*** Bug 268039 has been marked as a duplicate of this bug. ***
Comment 29 Dario Andres 2011-03-13 14:25:54 UTC
[Comment from a bug triager]
From bug 268249 (KDE SC 4.6.1):
-- Information about the crash:
When i boot, nepomuk crash, when moving files with Dolphin happens the same
thing, when openinig Digikam the crash appears for the third time.

From bug 268249 comment 1(KDE SC 4.6.1):
- What I was doing when the application crashed:
Same here. When starting digikam Nepomuk immediately crashed.
Comment 30 Dario Andres 2011-03-13 14:26:03 UTC
*** Bug 268192 has been marked as a duplicate of this bug. ***
Comment 31 Dario Andres 2011-03-13 14:26:06 UTC
*** Bug 268249 has been marked as a duplicate of this bug. ***
Comment 32 Dario Andres 2011-03-13 18:35:40 UTC
*** Bug 268381 has been marked as a duplicate of this bug. ***
Comment 33 Adam Porter 2011-03-14 20:56:50 UTC
Created attachment 58000 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.0

~/.kde/share/apps/nepomuk/repository/main/data/virtuosobackend/soprano-virtuoso.log shows:

----
                Mon Mar 14 2011
14:32:02 It is impossible to have a database file /home/me/.kde/share/apps/nepomuk/repository/main/data/virtuosobackend/soprano-virtuoso.db with a length not multiple of 2MB.
14:32:02 The process must have last terminated while growing the file.
14:32:02 Please contact OpenLink Customer Support

                Mon Mar 14 2011
14:50:43 It is impossible to have a database file /home/me/.kde/share/apps/nepomuk/repository/main/data/virtuosobackend/soprano-virtuoso.db with a length not multiple of 2MB.
14:50:43 The process must have last terminated while growing the file.
14:50:43 Please contact OpenLink Customer Support
----

Crashes on every login now.

-- Backtrace (Reduced):
#7  0x00d21451 in Nepomuk::Repository::close (this=0x8297330) at ../../../../nepomuk/services/storage/repository.cpp:73
#8  0x00d2156b in Nepomuk::Repository::~Repository (this=0x8297330, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/repository.cpp:65
#9  0x00f3f5d7 in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#10 0x00d1ff9b in Nepomuk::Core::~Core (this=0x8292048, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#11 0x022acb36 in QObjectPrivate::deleteChildren (this=0x82920b8) at kernel/qobject.cpp:1957
Comment 34 Waleed Hamra 2011-03-14 22:28:51 UTC
Created attachment 58005 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.0

- What I was doing when the application crashed:

it crashes immediately after logging in. this started happening after the upgrade to 4.6.1, using the kubuntu PPA.

-- Backtrace (Reduced):
#7  0x04f27451 in Nepomuk::Repository::close (this=0xa016fe0) at ../../../../nepomuk/services/storage/repository.cpp:73
#8  0x04f2756b in Nepomuk::Repository::~Repository (this=0xa016fe0, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/repository.cpp:65
#9  0x03ea6077 in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#10 0x04f25f9b in Nepomuk::Core::~Core (this=0xa012430, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#11 0x00dc8816 in QObjectPrivate::deleteChildren (this=0x9ff2948) at kernel/qobject.cpp:1957
Comment 35 Graziano 2011-03-15 13:00:28 UTC
Created attachment 58025 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.0

- What I was doing when the application crashed:

after logging in on kde 4.6 (upgrade on Maverick Meerklat 10.10 by ppa launchpad) system notification open up this crash information.

-- Backtrace (Reduced):
#6  0x00007f8df7fff529 in Nepomuk::Repository::close (this=0x10b80e0) at ../../../../nepomuk/services/storage/repository.cpp:73
#7  0x00007f8df7fff61d in Nepomuk::Repository::~Repository (this=0x10b80e0, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/repository.cpp:65
#8  0x00007f8df7dcb68f in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#9  0x00007f8df7ffe405 in Nepomuk::Core::~Core (this=0x10b96c0, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#10 0x00007f8e08253d5f in QObjectPrivate::deleteChildren (this=0x10b95e0) at kernel/qobject.cpp:1957
Comment 36 Sebastian Trueg 2011-03-15 18:52:19 UTC
Git commit 8fb7c4c74ab1a4de41b1fc8a9a9a1dfaca864a3c by Sebastian Trueg.
Committed on 15/03/2011 at 18:48.
Pushed by trueg into branch 'master'.

Initialize m_inferencer to 0.
This fixes a crash when Virtuoso fails to start. It does not fix the failed start though.
That is another topic I need to tackle.

BUG: 267666
FIXED-IN: 4.6.2

M  +1    -0    nepomuk/services/storage/repository.cpp     

http://commits.kde.org/kde-runtime/8fb7c4c74ab1a4de41b1fc8a9a9a1dfaca864a3c
Comment 37 Sebastian Trueg 2011-03-15 18:52:38 UTC
Git commit c1e733f5f715fe058c48fcc94bb5f67f4ae9cfc6 by Sebastian Trueg.
Committed on 15/03/2011 at 18:48.
Pushed by trueg into branch 'KDE/4.6'.

Initialize m_inferencer to 0.
This fixes a crash when Virtuoso fails to start. It does not fix the failed start though.
That is another topic I need to tackle.

BUG: 267666
FIXED-IN: 4.6.2

M  +1    -0    nepomuk/services/storage/repository.cpp     

http://commits.kde.org/kde-runtime/c1e733f5f715fe058c48fcc94bb5f67f4ae9cfc6
Comment 38 Craig Lillie 2011-03-15 22:13:17 UTC
Created attachment 58053 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.0

Booted KDE 4.6.1 & keep getting: Executable: nepomukservicestub PID: 1848 Signal: Segmentation fault (11)

-- Backtrace (Reduced):
#7  0x04772451 in Nepomuk::Repository::close (this=0x8546600) at ../../../../nepomuk/services/storage/repository.cpp:73
#8  0x0477256b in Nepomuk::Repository::~Repository (this=0x8546600, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/repository.cpp:65
#9  0x04a0a077 in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#10 0x04770f9b in Nepomuk::Core::~Core (this=0x8542bc8, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#11 0x0078d816 in QObjectPrivate::deleteChildren (this=0x8542d08) at kernel/qobject.cpp:1957
Comment 39 Alexandr 2011-03-16 07:21:53 UTC
Created attachment 58073 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.2

- What I was doing when the application crashed:

nepomuk always crash on kde startup if not turned off

-- Backtrace (Reduced):
#6  0x00007f83dbb50029 in Nepomuk::Repository::close() () from /usr/lib64/kde4/nepomukstorage.so
#7  0x00007f83dbb5010d in Nepomuk::Repository::~Repository() () from /usr/lib64/kde4/nepomukstorage.so
#8  0x00007f83dbb501d9 in Nepomuk::Repository::~Repository() () from /usr/lib64/kde4/nepomukstorage.so
#9  0x00007f83db9203c7 in void qDeleteAll<QHash<QString, Soprano::Model*>::const_iterator>(QHash<QString, Soprano::Model*>::const_iterator, QHash<QString, Soprano::Model*>::const_iterator) () from /usr/lib/libsopranoserver.so.1
#10 0x00007f83db91e69f in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
Comment 40 Sebastian Trueg 2011-03-16 19:09:06 UTC
*** Bug 268633 has been marked as a duplicate of this bug. ***
Comment 41 Sebastian Trueg 2011-03-17 07:45:03 UTC
*** Bug 268682 has been marked as a duplicate of this bug. ***
Comment 42 Sebastian Trueg 2011-03-17 07:47:21 UTC
*** Bug 268651 has been marked as a duplicate of this bug. ***
Comment 43 Sebastian Trueg 2011-03-17 11:22:57 UTC
*** Bug 268725 has been marked as a duplicate of this bug. ***
Comment 44 Sebastian Trueg 2011-03-17 16:27:00 UTC
*** Bug 268748 has been marked as a duplicate of this bug. ***
Comment 45 Sebastian Trueg 2011-03-21 17:23:24 UTC
*** Bug 268905 has been marked as a duplicate of this bug. ***
Comment 46 Sebastian Trueg 2011-03-21 17:24:40 UTC
*** Bug 268943 has been marked as a duplicate of this bug. ***
Comment 47 Sebastian Trueg 2011-03-21 19:45:04 UTC
*** Bug 269066 has been marked as a duplicate of this bug. ***
Comment 48 Michael Mikowski 2011-03-21 22:15:06 UTC
WORKAROUND:

Comment #1 was perhaps a little vague.  You need to remove the TRANSACTION file.  This worked for me:

cd ~/.kde/share/apps/nepomuk/repository/main/data/virtuosobackend
rm soprano-virtuoso.trx
# and you can remove the log file too, if you like
rm soprano-virtuoso.log

# And then restart stigi:

nohup /usr/bin/strigidaemon > /dev/null &2>1 &


Note there is probably a better (e.g. more correct way) to restart the stigi daemon.  I expect it will start properly on restart (although I have yet to reboot).




(In reply to comment #14)
> I have tried to stop strigi system, clean the log file (>
> soprano-virtuoso.log), restarted the system and got the same crash :(
> 
> 
> (In reply to comment #1)
> > Seems to be related to this error message in
> > ~/.kde/share/apps/nepomuk/repository/main/data/virtuosobackend/soprano-virtuoso.log:
> > 
> >                 Fri Mar 04 2011
> > 23:41:22 The transaction log file has been produced by server version
> > '06.01.3126'. The version of this server is '06.01.3127'. If the transaction
> > log is empty or you do not want to replay it then delete it and start the
> > server again. Otherwise replay the log using the server of version '06.01.3126'
> > and make checkpoint and shutdown to ensure that the log is empty, then delete
> > it and start using new version.
> > 
> > After clearing this error Nepomuk and Strigi are starting correctly and the
> > crash is no longer reproducible (still, KDE 4.6.0 did not crash despite the
> > presence of this issue).
Comment 49 Stephan Menzel 2011-03-21 22:37:34 UTC
Now who would've known! That worked. Thanks a bunch.

However, I wonder how such as beat could have passed unnoticed? A lot of people seemed to be having this problem so is there something special about their configurations that may have caused this?

Cheers,
Stephan

He(In reply to comment #48)
> WORKAROUND:
> 
> Comment #1 was perhaps a little vague.  You need to remove the TRANSACTION
> file.  This worked for me:
> 
> cd ~/.kde/share/apps/nepomuk/repository/main/data/virtuosobackend
> rm soprano-virtuoso.trx
> # and you can remove the log file too, if you like
> rm soprano-virtuoso.log
> 
> # And then restart stigi:
> 
> nohup /usr/bin/strigidaemon > /dev/null &2>1 &
> 
> 
> Note there is probably a better (e.g. more correct way) to restart the stigi
> daemon.  I expect it will start properly on restart (although I have yet to
> reboot).
> 
> 
> 
> 
> (In reply to comment #14)
> > I have tried to stop strigi system, clean the log file (>
> > soprano-virtuoso.log), restarted the system and got the same crash :(
> > 
> > 
> > (In reply to comment #1)
> > > Seems to be related to this error message in
> > > ~/.kde/share/apps/nepomuk/repository/main/data/virtuosobackend/soprano-virtuoso.log:
> > > 
> > >                 Fri Mar 04 2011
> > > 23:41:22 The transaction log file has been produced by server version
> > > '06.01.3126'. The version of this server is '06.01.3127'. If the transaction
> > > log is empty or you do not want to replay it then delete it and start the
> > > server again. Otherwise replay the log using the server of version '06.01.3126'
> > > and make checkpoint and shutdown to ensure that the log is empty, then delete
> > > it and start using new version.
> > > 
> > > After clearing this error Nepomuk and Strigi are starting correctly and the
> > > crash is no longer reproducible (still, KDE 4.6.0 did not crash despite the
> > > presence of this issue).
Comment 50 Sebastian Trueg 2011-03-22 15:56:31 UTC
This is impressive. After years and years people still start strigidaemon. :)
It has nothing to do with Nepomuk. Nepomuk has "nepomukserver" and a bunch of services which are started as dedicated processes by the nepomukserver binary.

However, the logfile removing workaround could still work. I will have to investigate though. So far I was not able to reproduce the issue.
Comment 51 Vishesh Handa 2011-03-22 17:47:49 UTC
@Sebastian: It's not exactly their fault. The Strigi daemon is still being used in kdepim. Code: kdepim-runtime/agents/strigifeeder/strigifeeder.cpp
Comment 52 Sebastian Trueg 2011-03-22 20:21:42 UTC
@vhanda: hm, I thought that was only for mobile?
Comment 53 Sebastian Trueg 2011-03-23 20:13:43 UTC
*** Bug 266804 has been marked as a duplicate of this bug. ***
Comment 54 Christoph Feck 2011-03-24 13:23:44 UTC
*** Bug 269283 has been marked as a duplicate of this bug. ***
Comment 55 Sven Eden 2011-03-25 08:59:05 UTC
Created attachment 58321 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.2

I used the "Workaround" from comment #48 and the crash was gone then. But there seems to be something else wrong, too, not only the nepumuk transactions:

- What I was doing when the application crashed:
Plugged in a second monitor and started system-settings. When I started the screen settings, my laptops panel went black and I had to drop back to the console and restart kdm (via xdm)
When I then logged back in into KDE, the crash greeted me again.

I am pretty sure that the mis-initialization after waking up from hibernation that led to the black panel has nothing to do with it. But closing the session hard and restarting it surely has.

-- Backtrace (Reduced):
#6  0x00007fd470548029 in Nepomuk::Repository::close() () from /usr/lib64/kde4/nepomukstorage.so
#7  0x00007fd47054810d in Nepomuk::Repository::~Repository() () from /usr/lib64/kde4/nepomukstorage.so
#8  0x00007fd4705481d9 in Nepomuk::Repository::~Repository() () from /usr/lib64/kde4/nepomukstorage.so
#9  0x00007fd4703183c7 in void qDeleteAll<QHash<QString, Soprano::Model*>::const_iterator>(QHash<QString, Soprano::Model*>::const_iterator, QHash<QString, Soprano::Model*>::const_iterator) () from /usr/lib/libsopranoserver.so.1
#10 0x00007fd47031669f in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
Comment 56 Sven Eden 2011-03-25 09:08:15 UTC
(In reply to comment #52)
> @vhanda: hm, I thought that was only for mobile?

Without the daemon running, there is no file indexing, right? After the said crash, Strigi-File-Indexer says it is not running. After the restart I get the message "Strigi is currently indexing files in folder <foldername>". (In systemsettings->Desktop Search)

So, isn't this neccessary any more for nepomuk finding files via desktop search?
Comment 57 Sebastian Trueg 2011-03-25 10:15:46 UTC
@Sven: I can only repeat that strigidaemon was never used by Nepomuk for file indexing. Nepomuk has its own service to handle that.
Comment 58 Stephan Menzel 2011-03-26 12:53:38 UTC
(In reply to comment #57)
> @Sven: I can only repeat that strigidaemon was never used by Nepomuk for file
> indexing. Nepomuk has its own service to handle that.

Well, if this ic indeed the case, that should be way more transparent to the KDE user. When I open the configuration tab for "Desktop search" the GUI pretty much implies that Nepomuk depends on strigi for indexing. A ordinary user should not have to care about the Desktop's internal architecture to configure it correctly. Furthermore: If Nepomuk is not using it, then what is? What purpose serves this 'strigi file indexing' checkbox?

Cheers,
Stephan
Comment 59 Christoph Feck 2011-03-27 01:52:02 UTC
*** Bug 269487 has been marked as a duplicate of this bug. ***
Comment 60 Sebastian Trueg 2011-03-28 12:27:01 UTC
*** Bug 269527 has been marked as a duplicate of this bug. ***
Comment 61 Sebastian Trueg 2011-03-28 12:27:46 UTC
*** Bug 256189 has been marked as a duplicate of this bug. ***
Comment 62 Sebastian Trueg 2011-03-28 12:31:32 UTC
@Stephan: Nepomuk is not using "strigidaemon". It uses libstreamanalyzer which is part of the Strigi package. We use the term "Strigi" in the config dialog to acknowledge the usage of the Strigi libraries. We could remove that but why should the user care what it is called anyway?
The whole config dialog is used to configure Nepomuk. strigidaemon is another tool which uses libstreamanalyzer, the "Strigi-library". You could look at it as the reference implementation of Strigi.
Comment 63 shani 2011-03-29 11:40:00 UTC
Created attachment 58426 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.0

- What I was doing when the application crashed: neopmukservice crashes every start up since 2.6.38-7

-- Backtrace (Reduced):
#7  0x05177451 in Nepomuk::Repository::close (this=0x8587bd8) at ../../../../nepomuk/services/storage/repository.cpp:73
#8  0x0517756b in Nepomuk::Repository::~Repository (this=0x8587bd8, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/repository.cpp:65
#9  0x0713e077 in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#10 0x05175f9b in Nepomuk::Core::~Core (this=0x85854d8, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#11 0x00324816 in QObjectPrivate::deleteChildren (this=0x8585560) at kernel/qobject.cpp:1957
Comment 64 Sylvain Garsault 2011-04-05 12:15:10 UTC
Created attachment 58595 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.0

- What I was doing when the application crashed:
Normal start-up, after upgrading to KDE 4.6.1 with Kubuntu ppa.

-- Backtrace (Reduced):
#6  0x00007ff6699bb529 in Nepomuk::Repository::close (this=0xe05e60) at ../../../../nepomuk/services/storage/repository.cpp:73
#7  0x00007ff6699bb61d in Nepomuk::Repository::~Repository (this=0xe05e60, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/repository.cpp:65
#8  0x00007ff66975e68f in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#9  0x00007ff6699ba405 in Nepomuk::Core::~Core (this=0xe08e40, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#10 0x00007ff679db1d5f in QObjectPrivate::deleteChildren (this=0xe09600) at kernel/qobject.cpp:1957
Comment 65 Rex Dieter 2011-04-08 16:08:18 UTC
*** Bug 270427 has been marked as a duplicate of this bug. ***
Comment 66 Rex Dieter 2011-04-08 16:08:25 UTC
*** Bug 270334 has been marked as a duplicate of this bug. ***
Comment 67 Weonjong Lee 2011-04-09 07:00:50 UTC
Created attachment 58735 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.1

- What I was doing when the application crashed:
Whenever I login, the KDE generate this error of Nepamuk.

-- Backtrace (Reduced):
#6  0x00007fb997e91039 in Nepomuk::Repository::close (this=0x97d590) at /usr/src/debug/kdebase-runtime-4.6.1/nepomuk/services/storage/repository.cpp:73
#7  0x00007fb997e9111d in Nepomuk::Repository::~Repository (this=0x97d590, __in_chrg=<value optimized out>) at /usr/src/debug/kdebase-runtime-4.6.1/nepomuk/services/storage/repository.cpp:65
#8  0x00007fb997e911e9 in Nepomuk::Repository::~Repository (this=0x97d590, __in_chrg=<value optimized out>) at /usr/src/debug/kdebase-runtime-4.6.1/nepomuk/services/storage/repository.cpp:66
#9  0x000000337dc0e117 in qDeleteAll<QHash<QString, Soprano::Model*>::const_iterator> (begin=..., end=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#10 0x000000337dc0ca78 in qDeleteAll<QHash<QString, Soprano::Model*> > (this=0x97a2b0, __in_chrg=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:330
Comment 68 Adam Porter 2011-04-11 07:47:01 UTC
...Uh...adding myself back to the bug, since I didn't ask to be removed...
Comment 69 Dario Andres 2011-04-17 00:19:14 UTC
*** Bug 270804 has been marked as a duplicate of this bug. ***
Comment 70 Dario Andres 2011-04-17 00:19:19 UTC
*** Bug 270745 has been marked as a duplicate of this bug. ***
Comment 71 Dario Andres 2011-05-01 16:42:32 UTC
*** Bug 271726 has been marked as a duplicate of this bug. ***
Comment 72 Alexander Opitz 2011-09-19 21:12:26 UTC
As there are different problems possible, here a way how to get the error, and maybe fix it.

1.) Stop nepomuk server

@desktop:~$ qdbus org.kde.NepomukServer /nepomukserver org.kde.NepomukServer.quit

2.) Check virtuoso directory

2.1.) Remove the trx file caused by incompatible versions

@desktop:~$ cd ~/.kde/share/apps/nepomuk/repository/main/data/virtuosobackend
@desktop:~$ rm soprano-virtuoso.trx

2.2.) Remove _empty_ checkpoint file cpt as it crashs virtuoso on startup

@desktop:~$ cd ~/.kde/share/apps/nepomuk/repository/main/data/virtuosobackend
@desktop:~$ ls *.cpt
@desktop:~$ rm soprano-virtuoso.cpt

3.) Startup nepomukserver

@desktop:~$ nepomukserver

4.) Look into output if virtuoso runs.
Comment 73 Sebastian Trueg 2011-09-20 07:56:52 UTC
(In reply to comment #72)
> As there are different problems possible, here a way how to get the error, and
> maybe fix it.
> 
> 1.) Stop nepomuk server
> 
> @desktop:~$ qdbus org.kde.NepomukServer /nepomukserver
> org.kde.NepomukServer.quit
> 
> 2.) Check virtuoso directory
> 
> 2.1.) Remove the trx file caused by incompatible versions
> 
> @desktop:~$ cd ~/.kde/share/apps/nepomuk/repository/main/data/virtuosobackend
> @desktop:~$ rm soprano-virtuoso.trx
> 
> 2.2.) Remove _empty_ checkpoint file cpt as it crashs virtuoso on startup
> 
> @desktop:~$ cd ~/.kde/share/apps/nepomuk/repository/main/data/virtuosobackend
> @desktop:~$ ls *.cpt
> @desktop:~$ rm soprano-virtuoso.cpt
> 
> 3.) Startup nepomukserver
> 
> @desktop:~$ nepomukserver
> 
> 4.) Look into output if virtuoso runs.

Is it possible that you are talking about another problem than this bug. If so, would you please open a new bug report since the bug originally reported here is in fact fixed. Thanks. :)
Comment 74 Christoph Feck 2011-10-04 22:27:18 UTC
Created attachment 64220 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.7.2 (4.7.2) using Qt 4.7.4

- What I was doing when the application crashed:

I just started KDE, Nepomuk is enabled, but indexing disabled. Never happened before, probably caused by today's updates (running master).

-- Backtrace (Reduced):
#7  0xb36e9a18 in Nepomuk::Repository::close (this=0x819cbb0) at /local/git/KDE/base/kde-runtime/nepomuk/services/storage/repository.cpp:86
#8  0xb36e98b0 in Nepomuk::Repository::~Repository (this=0x819cbb0, __in_chrg=<optimized out>) at /local/git/KDE/base/kde-runtime/nepomuk/services/storage/repository.cpp:75
#9  0xb36e9935 in Nepomuk::Repository::~Repository (this=0x819cbb0, __in_chrg=<optimized out>) at /local/git/KDE/base/kde-runtime/nepomuk/services/storage/repository.cpp:76
#10 0xb36b0b46 in void qDeleteAll<QHash<QString, Soprano::Model*>::const_iterator>(QHash<QString, Soprano::Model*>::const_iterator, QHash<QString, Soprano::Model*>::const_iterator) () from /local/kde4/lib/libsopranoserver.so.1
#11 0xb36afebd in void qDeleteAll<QHash<QString, Soprano::Model*> >(QHash<QString, Soprano::Model*> const&) () from /local/kde4/lib/libsopranoserver.so.1
Comment 75 Sebastian Trueg 2011-10-05 14:02:05 UTC
(In reply to comment #74)
> I just started KDE, Nepomuk is enabled, but indexing disabled. Never happened
> before, probably caused by today's updates (running master).


I just fixed this one. It is also in the 4.7 branch.
Comment 76 Jaime Torres 2011-10-05 18:37:22 UTC
Created attachment 64253 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.7.2 (4.7.2) using Qt 4.7.4

- What I was doing when the application crashed:

It's happening to me in 4.8 development (opensuse packages except Qt and KDE compiled from sources.

-- Backtrace (Reduced):
#6  0x00007f42a911761e in Nepomuk::Repository::close (this=0x7f42b0b7ec80) at /g/kdegit/kde-runtime/nepomuk/services/storage/repository.cpp:86
#7  0x00007f42a9117740 in Nepomuk::Repository::~Repository (this=0x7f42b0b7ec80, __in_chrg=<optimized out>) at /g/kdegit/kde-runtime/nepomuk/services/storage/repository.cpp:75
#8  0x00007f42a9117799 in Nepomuk::Repository::~Repository (this=0x7f42b0b7ec80, __in_chrg=<optimized out>) at /g/kdegit/kde-runtime/nepomuk/services/storage/repository.cpp:76
#9  0x00007f42a8ed73dd in qDeleteAll<QHash<QString, Soprano::Model*>::const_iterator> (begin=..., end=...) at /usr/lib/qt4.5/include/QtCore/qalgorithms.h:322
#10 0x00007f42a8ed65ce in qDeleteAll<QHash<QString, Soprano::Model*> > (c=...) at /usr/lib/qt4.5/include/QtCore/qalgorithms.h:330
Comment 77 Sebastian Trueg 2011-10-05 18:50:16 UTC
(In reply to comment #76)
> Created an attachment (id=64253) [details]
> New crash information added by DrKonqi
> 
> nepomukservicestub (0.2) on KDE Platform 4.7.2 (4.7.2) using Qt 4.7.4
> 
> - What I was doing when the application crashed:
> 
> It's happening to me in 4.8 development (opensuse packages except Qt and KDE
> compiled from sources.
> 
> -- Backtrace (Reduced):
> #6  0x00007f42a911761e in Nepomuk::Repository::close (this=0x7f42b0b7ec80) at
> /g/kdegit/kde-runtime/nepomuk/services/storage/repository.cpp:86
> #7  0x00007f42a9117740 in Nepomuk::Repository::~Repository
> (this=0x7f42b0b7ec80, __in_chrg=<optimized out>) at
> /g/kdegit/kde-runtime/nepomuk/services/storage/repository.cpp:75
> #8  0x00007f42a9117799 in Nepomuk::Repository::~Repository
> (this=0x7f42b0b7ec80, __in_chrg=<optimized out>) at
> /g/kdegit/kde-runtime/nepomuk/services/storage/repository.cpp:76
> #9  0x00007f42a8ed73dd in qDeleteAll<QHash<QString,
> Soprano::Model*>::const_iterator> (begin=..., end=...) at
> /usr/lib/qt4.5/include/QtCore/qalgorithms.h:322
> #10 0x00007f42a8ed65ce in qDeleteAll<QHash<QString, Soprano::Model*> > (c=...)
> at /usr/lib/qt4.5/include/QtCore/qalgorithms.h:330

This is a different crash which was introduced in 4.7.2 (as always not reproducable on my system) and which I fixed today.
Comment 78 Andre 2011-10-30 16:44:59 UTC
Created attachment 65044 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.7.2 (4.7.2) using Qt 4.7.4

- What I was doing when the application crashed:
it pc has just booted up and this buge pooped out

-- Backtrace (Reduced):
#6  0xb3c84ff7 in Nepomuk::Repository::close (this=0x8174ce0) at /usr/src/debug/kde-runtime-4.7.2/nepomuk/services/storage/repository.cpp:86
#7  0xb3c8514c in Nepomuk::Repository::~Repository (this=0x8174ce0, __in_chrg=<optimized out>) at /usr/src/debug/kde-runtime-4.7.2/nepomuk/services/storage/repository.cpp:75
#8  0xb3c85252 in Nepomuk::Repository::~Repository (this=0x8174ce0, __in_chrg=<optimized out>) at /usr/src/debug/kde-runtime-4.7.2/nepomuk/services/storage/repository.cpp:76
#9  0xb3c3447f in qDeleteAll<QHash<QString, Soprano::Model*>::const_iterator> (end=<optimized out>, begin=<optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#10 qDeleteAll<QHash<QString, Soprano::Model*> > (c=...) at /usr/include/QtCore/qalgorithms.h:330
Comment 79 Gianfranco L'Abbate 2011-12-06 22:56:07 UTC
Created attachment 66451 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

The crash happened any time I start Digikam

-- Backtrace (Reduced):
#7  0x071aa108 in Nepomuk::Repository::close (this=0x81d8740) at ../../../../nepomuk/services/storage/repository.cpp:96
#8  0x071aa24c in Nepomuk::Repository::~Repository (this=0x81d8740, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/repository.cpp:78
#9  0x071aa352 in Nepomuk::Repository::~Repository (this=0x81d8740, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/repository.cpp:79
#10 0x0170caaf in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#11 0x071a8b00 in Nepomuk::Core::~Core (this=0x81d4bd8, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:45
Comment 80 Sebastian Trueg 2011-12-07 10:43:49 UTC
(In reply to comment #79)
> Created an attachment (id=66451) [details]
> New crash information added by DrKonqi
> 
> nepomukservicestub (0.2) on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4
> 
> The crash happened any time I start Digikam
> 
> -- Backtrace (Reduced):
> #7  0x071aa108 in Nepomuk::Repository::close (this=0x81d8740) at
> ../../../../nepomuk/services/storage/repository.cpp:96
> #8  0x071aa24c in Nepomuk::Repository::~Repository (this=0x81d8740,
> __in_chrg=<optimized out>) at
> ../../../../nepomuk/services/storage/repository.cpp:78
> #9  0x071aa352 in Nepomuk::Repository::~Repository (this=0x81d8740,
> __in_chrg=<optimized out>) at
> ../../../../nepomuk/services/storage/repository.cpp:79
> #10 0x0170caaf in Soprano::Server::ServerCore::~ServerCore() () from
> /usr/lib/libsopranoserver.so.1
> #11 0x071a8b00 in Nepomuk::Core::~Core (this=0x81d4bd8, __in_chrg=<optimized
> out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:45

You are seeing already fixed bug 285789.