Bug 263078 - Nepomuk crash at login
Summary: Nepomuk crash at login
Status: RESOLVED DUPLICATE of bug 245266
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-13 22:37 UTC by Cyrille Dunant
Modified: 2011-01-17 17:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cyrille Dunant 2011-01-13 22:37:21 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.5.95 (4.6 RC2)
Qt Version: 4.7.1
Operating System: Linux 2.6.34.7-0.7-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
Nepomuk crashes upon login. It might to be related to strigiservice, but I have excluded all files causing the latter to crash.

The crash can be reproduced every time.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f71a35d8760 (LWP 3803))]

Thread 3 (Thread 0x7f71929f4710 (LWP 4354)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f71a2fe010b in wait (this=<value optimized out>, mutex=0x7006e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x7006e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f7193029fc9 in Nepomuk::IndexFeeder::run (this=0x7006c0) at /usr/src/debug/kdebase-runtime-4.5.95/nepomuk/services/strigi/nepomukindexfeeder.cpp:188
#4  0x00007f71a2fdfa1e in QThreadPrivate::start (arg=0x7006c0) at thread/qthread_unix.cpp:285
#5  0x00007f71a2d50a4f in start_thread (arg=0x7f71929f4710) at pthread_create.c:297
#6  0x00007f71a0ac582d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f71854d8710 (LWP 4427)):
[KCrash Handler]
#6  QMutex::lock (this=0x8) at thread/qmutex.cpp:151
#7  0x00007f719d2ede42 in QMutexLocker (this=<value optimized out>) at /usr/include/QtCore/qmutex.h:102
#8  Soprano::Error::ErrorCache::clearError (this=<value optimized out>) at /usr/src/debug/soprano-2.5.63/soprano/error.cpp:238
#9  0x00007f719d2ee4d0 in Soprano::Error::ErrorCache::setError (this=0x8e0190, error=...) at /usr/src/debug/soprano-2.5.63/soprano/error.cpp:225
#10 0x00007f719d08369a in Soprano::Client::DBusModel::executeQuery (this=0x8e0180, query=<value optimized out>, language=<value optimized out>, userQueryLanguage=<value optimized out>)
    at /usr/src/debug/soprano-2.5.63/client/dbus/dbusmodel.cpp:108
#11 0x00007f71a1d4f194 in Nepomuk::MainModel::executeQuery (this=0x6e9290, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...)
    at /usr/src/debug/kdelibs-4.5.95/nepomuk/core/nepomukmainmodel.cpp:212
#12 0x00007f719d2fe2e9 in Soprano::FilterModel::executeQuery (this=0x6e71b0, query=<value optimized out>, language=<value optimized out>, userQueryLanguage=<value optimized out>)
    at /usr/src/debug/soprano-2.5.63/soprano/filtermodel.cpp:164
#13 0x00007f719301d788 in Nepomuk::IndexScheduler::removeAllGraphsFromQuery (this=0x6ee460, query=...) at /usr/src/debug/kdebase-runtime-4.5.95/nepomuk/services/strigi/indexscheduler.cpp:713
#14 0x00007f719301efab in Nepomuk::IndexScheduler::removeOldAndUnwantedEntries (this=0x6ee460) at /usr/src/debug/kdebase-runtime-4.5.95/nepomuk/services/strigi/indexscheduler.cpp:626
#15 0x00007f7193020ff2 in Nepomuk::IndexScheduler::run (this=0x6ee460) at /usr/src/debug/kdebase-runtime-4.5.95/nepomuk/services/strigi/indexscheduler.cpp:298
#16 0x00007f71a2fdfa1e in QThreadPrivate::start (arg=0x6ee460) at thread/qthread_unix.cpp:285
#17 0x00007f71a2d50a4f in start_thread (arg=0x7f71854d8710) at pthread_create.c:297
#18 0x00007f71a0ac582d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f71a35d8760 (LWP 3803)):
#0  0x00007f71a0abc6b3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f719f60ddf0 in ?? () from /lib64/libdbus-1.so.3
#2  0x00007f719f60cced in ?? () from /lib64/libdbus-1.so.3
#3  0x00007f719f5f7745 in ?? () from /lib64/libdbus-1.so.3
#4  0x00007f719f5f8924 in ?? () from /lib64/libdbus-1.so.3
#5  0x00007f719f5f8a41 in ?? () from /lib64/libdbus-1.so.3
#6  0x00007f719f5f8064 in dbus_connection_send_with_reply_and_block () from /lib64/libdbus-1.so.3
#7  0x00007f71a2af7e36 in q_dbus_connection_send_with_reply_and_block (this=0x694ae0, message=..., sendMode=<value optimized out>, timeout=-1) at qdbus_symbols_p.h:135
#8  QDBusConnectionPrivate::sendWithReply (this=0x694ae0, message=..., sendMode=<value optimized out>, timeout=-1) at qdbusintegrator.cpp:1844
#9  0x00007f71a2ae58c3 in QDBusConnection::call (this=0x6e9690, message=<value optimized out>, mode=<value optimized out>, timeout=<value optimized out>) at qdbusconnection.cpp:529
#10 0x00007f71a2b06302 in QDBusAbstractInterface::callWithArgumentList (this=0x72ec30, mode=QDBus::Block, method=<value optimized out>, args=...) at qdbusabstractinterface.cpp:444
#11 0x00007f719d0801dd in createModel (this=0x6e8340, name=<value optimized out>, settings=<value optimized out>) at /usr/src/debug/soprano-2.5.63/client/dbus/dbusserverinterface.h:57
#12 Soprano::Client::DBusClient::createModel (this=0x6e8340, name=<value optimized out>, settings=<value optimized out>) at /usr/src/debug/soprano-2.5.63/client/dbus/dbusclient.cpp:73
#13 0x00007f71a1d45b92 in init (this=0x6e9290) at /usr/src/debug/kdelibs-4.5.95/nepomuk/core/nepomukmainmodel.cpp:92
#14 Nepomuk::MainModel::init (this=0x6e9290) at /usr/src/debug/kdelibs-4.5.95/nepomuk/core/nepomukmainmodel.cpp:176
#15 0x00007f71a1d46867 in Nepomuk::ResourceManager::init (this=0x781e60) at /usr/src/debug/kdelibs-4.5.95/nepomuk/core/resourcemanager.cpp:328
#16 0x00007f71a1d66bf5 in Nepomuk::ResourceManagerPrivate::_k_storageServiceInitialized (this=0x7039d0, success=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.95/nepomuk/core/resourcemanager.cpp:219
#17 0x00007f71a1d66cf5 in Nepomuk::ResourceManager::qt_metacall (this=0x781e60, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff7ebf6ff0)
    at /usr/src/debug/kdelibs-4.5.95/build/nepomuk/resourcemanager.moc:90
#18 0x00007f71a2af33b8 in QDBusConnectionPrivate::deliverCall (this=0x694ae0, object=0x781e60, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:919
#19 0x00007f71a2afef5f in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:103
#20 0x00007f71a30dec6a in QObject::event (this=0x781e60, e=<value optimized out>) at kernel/qobject.cpp:1211
#21 0x00007f71a1228cd4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#22 0x00007f71a12311ca in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#23 0x00007f71a2162ec6 in KApplication::notify (this=0x7fff7ebf7c50, receiver=0x781e60, event=0x9198d0) at /usr/src/debug/kdelibs-4.5.95/kdeui/kernel/kapplication.cpp:311
#24 0x00007f71a30cae2c in QCoreApplication::notifyInternal (this=0x7fff7ebf7c50, receiver=0x781e60, event=0x9198d0) at kernel/qcoreapplication.cpp:732
#25 0x00007f71a30ce625 in sendEvent (receiver=0x0, event_type=0, data=0x609660) at kernel/qcoreapplication.h:215
#26 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x609660) at kernel/qcoreapplication.cpp:1373
#27 0x00007f71a30f58f3 in sendPostedEvents (s=0x628ea0) at kernel/qcoreapplication.h:220
#28 postEventSourceDispatch (s=0x628ea0) at kernel/qeventdispatcher_glib.cpp:277
#29 0x00007f719ff24cb3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#30 0x00007f719ff25490 in ?? () from /lib64/libglib-2.0.so.0
#31 0x00007f719ff25730 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#32 0x00007f71a30f5a8f in QEventDispatcherGlib::processEvents (this=0x60f360, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007f71a12cdeae in ?? () from /usr/lib64/libQtGui.so.4
#34 0x00007f71a30ca262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f71a30ca475 in QEventLoop::exec (this=0x7fff7ebf7a20, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007f71a30ce8db in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#37 0x0000000000403ea2 in main (argc=2, argv=0x7fff7ebf80a8) at /usr/src/debug/kdebase-runtime-4.5.95/nepomuk/servicestub/main.cpp:165

This bug may be a duplicate of or related to bug 234994.

Possible duplicates by query: bug 260856, bug 258235, bug 256895, bug 252766, bug 252140.

Reported using DrKonqi
Comment 1 Sebastian Trueg 2011-01-17 17:08:30 UTC

*** This bug has been marked as a duplicate of bug 245266 ***