Bug 252766 - nepomukservicestub crashes while scanning files
Summary: nepomukservicestub crashes while scanning files
Status: RESOLVED DUPLICATE of bug 245266
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
: 251418 253349 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-09-29 16:10 UTC by René Serral
Modified: 2011-01-17 17:07 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description René Serral 2010-09-29 16:10:23 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.5.1 (KDE 4.5.1) (Compiled from sources)
Qt Version: 4.6.3
Operating System: Linux 2.6.35.6-last i686
Distribution: Debian GNU/Linux unstable (sid)

-- Information about the crash:
Everytime I log in to the computer it keeps crashing all the time while generating the database.

I tried to restart the nepomuk service but it keeps crashing while indexing all type of files, 
e.g. .odt, .pdf....

The crash can be reproduced every time.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Segmentation fault
[Current thread is 1 (Thread 0xb57f9710 (LWP 4612))]

Thread 2 (Thread 0xb271ab70 (LWP 4918)):
[KCrash Handler]
#7  0xb75069b9 in QMutex::lock() () from /usr/lib/libQtCore.so.4
#8  0xb6c67f06 in QMutexLocker::relock (this=0xb2719d60) at /usr/include/qt4/QtCore/qmutex.h:120
#9  0xb6c67e62 in QMutexLocker::QMutexLocker (this=0xb2719d60, m=0x87ae71e) at /usr/include/qt4/QtCore/qmutex.h:102
#10 0xb6c674fa in Soprano::Error::ErrorCache::clearError (this=0x87ae710) at /media/kdesvn/kde4svn/src/kdesupport_trunk/soprano/soprano/error.cpp:238
#11 0xb6c67452 in Soprano::Error::ErrorCache::setError (this=0x87ae710, error=...) at /media/kdesvn/kde4svn/src/kdesupport_trunk/soprano/soprano/error.cpp:225
#12 0xb5a227d8 in Soprano::Client::DBusModel::addStatement (this=0x87ae708, statement=...) at /media/kdesvn/kde4svn/src/kdesupport_trunk/soprano/client/dbus/dbusmodel.cpp:82
#13 0xb6d57e23 in Nepomuk::MainModel::addStatement (this=0x84cce08, statement=...) at /media/kdesvn/kde4svn/src/kdelibs/nepomuk/core/nepomukmainmodel.cpp:252
#14 0xb6c74ff4 in Soprano::FilterModel::addStatement (this=0x84cc1b0, statement=...) at /media/kdesvn/kde4svn/src/kdesupport_trunk/soprano/soprano/filtermodel.cpp:92
#15 0xb6d54c2d in Nepomuk::ResourceFilterModel::addStatement (this=0x84cc1b0, statement=...) at /media/kdesvn/kde4svn/src/kdelibs/nepomuk/core/resourcefiltermodel.cpp:71
#16 0xb6c5d9f0 in Soprano::Model::addStatement (this=0x84cc1b0, subject=..., predicate=..., object=..., context=...) at /media/kdesvn/kde4svn/src/kdesupport_trunk/soprano/soprano/model.cpp:135
#17 0xb2971d9c in (anonymous namespace)::FileMetaData::storeBasicData (this=0x87aef80, model=0x84cc1b0) at /media/kdesvn/kde4svn/src/kdebase/runtime/nepomuk/strigibackend/nepomukindexwriter.cpp:241
#18 0xb2972788 in Strigi::NepomukIndexWriter::startAnalysis (this=0x87587e8, idx=0xb271a128) at /media/kdesvn/kde4svn/src/kdebase/runtime/nepomuk/strigibackend/nepomukindexwriter.cpp:394
#19 0xb5234005 in Strigi::AnalysisResult::AnalysisResult (this=0xb271a128, path=..., mt=1258211625, w=..., indexer=..., parentpath=...) at /media/kdesvn/kde4svn/src/kdesupport_trunk/strigi/libstreamanalyzer/lib/analysisresult.cpp:178
#20 0xb2a23dc8 in Nepomuk::IndexScheduler::analyzeFile (this=0x84cf0c0, file=..., analyzer=0xb271a300) at /media/kdesvn/kde4svn/src/kdebase/runtime/nepomuk/services/strigi/indexscheduler.cpp:443
#21 0xb2a239eb in Nepomuk::IndexScheduler::updateDir (this=0x84cf0c0, dir=..., analyzer=0xb271a300, flags=...) at /media/kdesvn/kde4svn/src/kdebase/runtime/nepomuk/services/strigi/indexscheduler.cpp:413
#22 0xb2a2305d in Nepomuk::IndexScheduler::run (this=0x84cf0c0) at /media/kdesvn/kde4svn/src/kdebase/runtime/nepomuk/services/strigi/indexscheduler.cpp:314
#23 0xb750bfbe in ?? () from /usr/lib/libQtCore.so.4
#24 0xb7488955 in start_thread (arg=0xb271ab70) at pthread_create.c:300
#25 0xb5f6fe7e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb57f9710 (LWP 4612)):
#0  0xb7752424 in __kernel_vsyscall ()
#1  0xb5f62696 in __poll (fds=0xb5fe5ff4, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0xb4f63a2b in ?? () from /lib/libdbus-1.so.3
#3  0xb4f5ba9f in ?? () from /lib/libdbus-1.so.3
#4  0xb4f59c8c in ?? () from /lib/libdbus-1.so.3
#5  0xb4f44473 in ?? () from /lib/libdbus-1.so.3
#6  0xb4f44cf8 in ?? () from /lib/libdbus-1.so.3
#7  0xb4f46aaf in ?? () from /lib/libdbus-1.so.3
#8  0xb4f54441 in dbus_pending_call_block () from /lib/libdbus-1.so.3
#9  0xb4f460bc in dbus_connection_send_with_reply_and_block () from /lib/libdbus-1.so.3
#10 0xb742f74f in ?? () from /usr/lib/libQtDBus.so.4
#11 0xb741a28b in QDBusConnection::call(QDBusMessage const&, QDBus::CallMode, int) const () from /usr/lib/libQtDBus.so.4
#12 0xb743aabf in QDBusAbstractInterface::callWithArgumentList(QDBus::CallMode, QString const&, QList<QVariant> const&) () from /usr/lib/libQtDBus.so.4
#13 0xb5a212eb in Soprano::Client::DBusServerInterface::createModel (this=0x84cd368, name=...) at /media/kdesvn/kde4svn/src/kdesupport_trunk/soprano/client/dbus/dbusserverinterface.h:57
#14 0xb5a21b94 in Soprano::Client::DBusClient::createModel (this=0x84ccbd8, name=..., settings=...) at /media/kdesvn/kde4svn/src/kdesupport_trunk/soprano/client/dbus/dbusclient.cpp:73
#15 0xb6d57034 in (anonymous namespace)::GlobalModelContainer::init (this=0x84ccbd8, forced=true) at /media/kdesvn/kde4svn/src/kdelibs/nepomuk/core/nepomukmainmodel.cpp:92
#16 0xb6d57810 in Nepomuk::MainModel::init (this=0x84cce08) at /media/kdesvn/kde4svn/src/kdelibs/nepomuk/core/nepomukmainmodel.cpp:176
#17 0xb6d512f6 in Nepomuk::ResourceManager::init (this=0x84cc1d0) at /media/kdesvn/kde4svn/src/kdelibs/nepomuk/core/resourcemanager.cpp:329
#18 0xb6d50532 in Nepomuk::ResourceManagerPrivate::_k_storageServiceInitialized (this=0x84d4810, success=true) at /media/kdesvn/kde4svn/src/kdelibs/nepomuk/core/resourcemanager.cpp:220
#19 0xb6d5287c in Nepomuk::ResourceManager::qt_metacall (this=0x84cc1d0, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbfc56488) at /media/kdesvn/kde4svn/build/kdelibs/nepomuk/resourcemanager.moc:90
#20 0xb742a011 in ?? () from /usr/lib/libQtDBus.so.4
#21 0xb7435107 in ?? () from /usr/lib/libQtDBus.so.4
#22 0xb7618e1e in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#23 0xb627b5cc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#24 0xb628215e in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#25 0xb6f93926 in KApplication::notify (this=0xbfc56dd8, receiver=0x84cc1d0, event=0x87af7c0) at /media/kdesvn/kde4svn/src/kdelibs/kdeui/kernel/kapplication.cpp:310
#26 0xb76084eb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#27 0xb760bf4c in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#28 0xb760c0cd in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#29 0xb763459f in ?? () from /usr/lib/libQtCore.so.4
#30 0xb5def305 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#31 0xb5df2fe8 in ?? () from /lib/libglib-2.0.so.0
#32 0xb5df31c8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#33 0xb7634095 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#34 0xb6339ef5 in ?? () from /usr/lib/libQtGui.so.4
#35 0xb7606b09 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#36 0xb7606f5a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#37 0xb760c18f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#38 0xb627b667 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#39 0x0804bb1c in main (argc=2, argv=0xbfc56fe4) at /media/kdesvn/kde4svn/src/kdebase/runtime/nepomuk/servicestub/main.cpp:165

Possible duplicates by query: bug 241600.

Reported using DrKonqi
Comment 1 Dario Andres 2010-11-18 19:07:04 UTC
[Comment from a bug triager]
This may be related to bug 246110 and/or 245266. Thanks
Comment 2 Sebastian Trueg 2011-01-14 14:04:40 UTC
*** Bug 253349 has been marked as a duplicate of this bug. ***
Comment 3 Sebastian Trueg 2011-01-14 14:05:28 UTC
*** Bug 251418 has been marked as a duplicate of this bug. ***
Comment 4 Sebastian Trueg 2011-01-17 17:07:35 UTC

*** This bug has been marked as a duplicate of bug 245266 ***