Bug 256895 - Crash of Nepomuk, about a minute after login
Summary: Crash of Nepomuk, about a minute after login
Status: RESOLVED DUPLICATE of bug 245266
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-14 16:05 UTC by Laurent RINEAU
Modified: 2010-11-18 19:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent RINEAU 2010-11-14 16:05:20 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.5.3 (KDE 4.5.3)
Qt Version: 4.7.0
Operating System: Linux 2.6.34.7-61.fc13.i686 i686
Distribution: "Fedora release 13 (Goddard)"

-- Information about the crash:
- What I was doing when the application crashed:
Nothing special. I logged in using kdm. Then my session started, a few konsole, firefox, and kontact (with kmail and kaddressbook in it). The Dr Konqi about the crash of Nepomuk popped up before kontact.

The crash can be reproduced every time.

-- Backtrace:
Application: Jeton du service Nepomuk (nepomukservicestub), signal: Segmentation fault
Array<int>::~Array (this=0x690605c, __in_chrg=<value optimized out>)
    at CLucene/debug/mem.h:111
111		~Array(){}
[Current thread is 1 (Thread 0xb7787780 (LWP 2119))]

Thread 2 (Thread 0xb5336b70 (LWP 2512)):
[KCrash Handler]
#7  0x00308c9a in QMutex::lock (this=0x9ec1b6c) at thread/qmutex.cpp:151
#8  0x0319e1e3 in relock (this=0xb484fdb8) at /usr/include/QtCore/qmutex.h:120
#9  QMutexLocker (this=0xb484fdb8) at /usr/include/QtCore/qmutex.h:102
#10 Soprano::Error::ErrorCache::clearError (this=0xb484fdb8) at /usr/src/debug/soprano-2.5.2/soprano/error.cpp:238
#11 0x0319e468 in Soprano::Error::ErrorCache::setError (this=0xb484fdb8, error=...) at /usr/src/debug/soprano-2.5.2/soprano/error.cpp:225
#12 0x04fcf56f in Soprano::Client::DBusModel::executeQuery (this=0xb484fdb0, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...)
    at /usr/src/debug/soprano-2.5.2/client/dbus/dbusmodel.cpp:108
#13 0x0717c1e4 in Nepomuk::MainModel::executeQuery (this=0x9f23d48, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...)
    at /usr/src/debug/kdelibs-4.5.3/nepomuk/core/nepomukmainmodel.cpp:212
#14 0x031aabbb in Soprano::FilterModel::executeQuery (this=0x9f23ad8, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...)
    at /usr/src/debug/soprano-2.5.2/soprano/filtermodel.cpp:164
#15 0x07170469 in Nepomuk::ResourceData::determineUri (this=0xb48cf690) at /usr/src/debug/kdelibs-4.5.3/nepomuk/core/resourcedata.cpp:580
#16 0x071808d4 in Nepomuk::Resource::determineFinalResourceData (this=0xb5335de0) at /usr/src/debug/kdelibs-4.5.3/nepomuk/core/resource.cpp:885
#17 0x07182b30 in Nepomuk::Resource::resourceUri (this=0xb5335de0) at /usr/src/debug/kdelibs-4.5.3/nepomuk/core/resource.cpp:165
#18 0x00fd6cdf in FileMetaData (this=0xb4818af0, idx=0xb533604c) at /usr/src/debug/kdebase-runtime-4.5.3/nepomuk/strigibackend/nepomukindexwriter.cpp:190
#19 Strigi::NepomukIndexWriter::startAnalysis (this=0xb4818af0, idx=0xb533604c) at /usr/src/debug/kdebase-runtime-4.5.3/nepomuk/strigibackend/nepomukindexwriter.cpp:373
#20 0x04f3d61b in Strigi::AnalysisResult::AnalysisResult (this=0xb533604c, path="/home/lrineau/metro.pdf", mt=1208770312, w=..., indexer=..., parentpath="/home/lrineau")
    at /usr/src/debug/strigi-0.7.2/src/streamanalyzer/analysisresult.cpp:178
#21 0x010020ca in Nepomuk::IndexScheduler::analyzeFile (this=0x9f261c8, file=..., analyzer=0xb533627c) at /usr/src/debug/kdebase-runtime-4.5.3/nepomuk/services/strigi/indexscheduler.cpp:443
#22 0x0100399f in Nepomuk::IndexScheduler::updateDir (this=0x9f261c8, dir=..., analyzer=0xb533627c, flags=...) at /usr/src/debug/kdebase-runtime-4.5.3/nepomuk/services/strigi/indexscheduler.cpp:413
#23 0x0100617b in Nepomuk::IndexScheduler::run (this=0x9f261c8) at /usr/src/debug/kdebase-runtime-4.5.3/nepomuk/services/strigi/indexscheduler.cpp:314
#24 0x0030d6da in QThreadPrivate::start (arg=0x9f261c8) at thread/qthread_unix.cpp:266
#25 0x00936919 in start_thread (arg=0xb5336b70) at pthread_create.c:301
#26 0x0084ccce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb7787780 (LWP 2119)):
#0  Array<int>::~Array (this=0x690605c, __in_chrg=<value optimized out>) at CLucene/debug/mem.h:111
#1  0x0079d42f in __run_exit_handlers (status=1) at exit.c:78
#2  exit (status=1) at exit.c:100
#3  0x0749e90c in qt_xio_errhandler () at kernel/qapplication_x11.cpp:745
#4  0x02efc7bb in KApplication::xioErrhandler (this=0xbf939d58, dpy=0x9e4c078) at /usr/src/debug/kdelibs-4.5.3/kdeui/kernel/kapplication.cpp:416
#5  0x02efc7f7 in kde_xio_errhandler (dpy=0x9e4c078) at /usr/src/debug/kdelibs-4.5.3/kdeui/kernel/kapplication.cpp:125
#6  0x009a7a57 in _XIOError (dpy=0x9e4c078) at XlibInt.c:3138
#7  0x009afa43 in process_responses (dpy=<value optimized out>, wait_for_first_event=0, current_error=0x0, current_request=0) at xcb_io.c:247
#8  0x009b03e7 in _XEventsQueued (dpy=0x9e4c078, mode=2) at xcb_io.c:263
#9  0x009989fb in XEventsQueued (dpy=0x9e4c078, mode=2) at Pending.c:44
#10 0x074da95f in x11EventSourcePrepare (s=0x9e31940, timeout=0xbf9399cc) at kernel/qguieventdispatcher_glib.cpp:79
#11 0x00b1ba6a in IA__g_main_context_prepare (context=<value optimized out>, priority=0xbf939a4c) at gmain.c:2280
#12 0x00b1be81 in g_main_context_iterate (context=0x9e30310, block=1, dispatch=1, self=0x9e2e6d0) at gmain.c:2571
#13 0x00b1c449 in IA__g_main_context_iteration (context=0x9e30310, may_block=1) at gmain.c:2654
#14 0x0042d5b6 in QEventDispatcherGlib::processEvents (this=0x9e1a180, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#15 0x074da7c6 in QGuiEventDispatcherGlib::processEvents (this=0x9e1a180, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#16 0x0040171a in QEventLoop::processEvents (this=0xbf939be4, flags=...) at kernel/qeventloop.cpp:149
#17 0x00401a7a in QEventLoop::exec (this=0xbf939be4, flags=...) at kernel/qeventloop.cpp:201
#18 0x004069d7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#19 0x07429458 in QApplication::exec () at kernel/qapplication.cpp:3672
#20 0x0804b07e in main (argc=4, argv=0xf4e75223) at /usr/src/debug/kdebase-runtime-4.5.3/nepomuk/servicestub/main.cpp:165

Possible duplicates by query: bug 255649, bug 252766, bug 252062, bug 251375, bug 251099.

Reported using DrKonqi
Comment 1 Dario Andres 2010-11-18 19:01:53 UTC
[Comment from a bug triager]
This issue is being tracked at bug 245266. Merging. Thanks

*** This bug has been marked as a duplicate of bug 245266 ***