Bug 258235 - Nepomuk stub service crashes at login
Summary: Nepomuk stub service crashes at login
Status: RESOLVED DUPLICATE of bug 245266
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-29 00:37 UTC by zork
Modified: 2011-01-17 17:08 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (8.73 KB, text/plain)
2010-12-08 12:39 UTC, Thomas Janssen
Details
New crash information added by DrKonqi (8.49 KB, text/plain)
2011-01-01 02:20 UTC, jamundso
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zork 2010-11-29 00:37:21 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.5.3 (KDE 4.5.3)
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-61.fc13.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:

I was logging in and some windows appeared on the desktop, as usual: dolphin, xterm, amarok, and firefox, and then the crash reporting window came up messaging me about "nepomuk stub service" (which I'd never heard of) havin seg-faulted.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Segmentation fault
87	  int result = INLINE_SYSCALL (poll, 3, CHECK_N (fds, nfds), nfds, timeout);
[Current thread is 1 (Thread 0x7fab7bebd820 (LWP 2495))]

Thread 2 (Thread 0x7fab6fd40710 (LWP 2529)):
[KCrash Handler]
#6  QMutex::lock (this=0x2e0031003a0008) at thread/qmutex.cpp:150
#7  0x0000003ce66501d1 in relock (this=0x7fab680127a0) at /usr/include/QtCore/qmutex.h:120
#8  QMutexLocker (this=0x7fab680127a0) at /usr/include/QtCore/qmutex.h:102
#9  Soprano::Error::ErrorCache::clearError (this=0x7fab680127a0) at /usr/src/debug/soprano-2.5.2/soprano/error.cpp:238
#10 0x0000003ce6650420 in Soprano::Error::ErrorCache::setError (this=0x7fab680127a0, error=...) at /usr/src/debug/soprano-2.5.2/soprano/error.cpp:225
#11 0x0000003ce6a30df5 in Soprano::Client::DBusModel::containsStatement (this=0x7fab68012790, statement=<value optimized out>) at /usr/src/debug/soprano-2.5.2/client/dbus/dbusmodel.cpp:186
#12 0x0000003ce743e613 in Nepomuk::MainModel::containsStatement (this=0x7b9040, statement=...) at /usr/src/debug/kdelibs-4.5.3/nepomuk/core/nepomukmainmodel.cpp:220
#13 0x0000003ce665b101 in Soprano::FilterModel::containsStatement (this=0x7b7ed0, statement=...) at /usr/src/debug/soprano-2.5.2/soprano/filtermodel.cpp:125
#14 0x00007fab703a9b83 in Strigi::Util::storeStrigiMiniOntology (model=0x7b7ed0) at /usr/src/debug/kdebase-runtime-4.5.3/nepomuk/strigibackend/util.cpp:133
#15 0x00007fab703a8a76 in Strigi::NepomukIndexWriter::NepomukIndexWriter (this=0x7fab68028150, model=0x7b7ed0) at /usr/src/debug/kdebase-runtime-4.5.3/nepomuk/strigibackend/nepomukindexwriter.cpp:326
#16 0x00007fab703a52d0 in Strigi::NepomukIndexManager::indexWriter (this=0x7257f0) at /usr/src/debug/kdebase-runtime-4.5.3/nepomuk/strigibackend/nepomukindexmanager.cpp:100
#17 0x00007fab705cce30 in Nepomuk::IndexScheduler::run (this=0x7bbfb0) at /usr/src/debug/kdebase-runtime-4.5.3/nepomuk/services/strigi/indexscheduler.cpp:286
#18 0x0000003ce28711a5 in QThreadPrivate::start (arg=0x7bbfb0) at thread/qthread_unix.cpp:248
#19 0x00000036c9a07761 in start_thread (arg=0x7fab6fd40710) at pthread_create.c:301
#20 0x00000036c8ee14fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fab7bebd820 (LWP 2495)):
#0  0x00000036c8ed7df3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00000036cf624310 in socket_do_iteration (transport=0x722630, flags=7, timeout_milliseconds=<value optimized out>) at dbus-transport-socket.c:1066
#2  0x00000036cf6226fd in _dbus_transport_do_iteration (transport=0x722630, flags=<value optimized out>, timeout_milliseconds=<value optimized out>) at dbus-transport.c:956
#3  0x00000036cf60ebae in _dbus_connection_do_iteration_unlocked (connection=0x722ce0, flags=7, timeout_milliseconds=-1) at dbus-connection.c:1163
#4  0x00000036cf60f362 in _dbus_connection_flush_unlocked (connection=0x722ce0) at dbus-connection.c:3405
#5  0x00000036cf610eb1 in _dbus_connection_block_pending_call (pending=0x89e380) at dbus-connection.c:2302
#6  0x00000036cf610586 in dbus_connection_send_with_reply_and_block (connection=0x722ce0, message=0xa50860, timeout_milliseconds=-1, error=0x7fff87254d80) at dbus-connection.c:3361
#7  0x0000003ce3227085 in q_dbus_connection_send_with_reply_and_block (this=0x71ebb0, message=..., sendMode=<value optimized out>, timeout=-1) at qdbus_symbols_p.h:133
#8  QDBusConnectionPrivate::sendWithReply (this=0x71ebb0, message=..., sendMode=<value optimized out>, timeout=-1) at qdbusintegrator.cpp:1828
#9  0x0000003ce3213ab3 in QDBusConnection::call (this=0x7b9bb0, message=<value optimized out>, mode=<value optimized out>, timeout=<value optimized out>) at qdbusconnection.cpp:522
#10 0x0000003ce3230342 in QDBusAbstractInterface::callWithArgumentList (this=0x7b9ab0, mode=QDBus::Block, method=<value optimized out>, args=...) at qdbusabstractinterface.cpp:440
#11 0x0000003ce6a2ece4 in Soprano::Client::DBusServerInterface::createModel (this=0x7b9ab0, name=<value optimized out>) at /usr/src/debug/soprano-2.5.2/client/dbus/dbusserverinterface.h:57
#12 0x0000003ce6a2f8cd in Soprano::Client::DBusClient::createModel (this=0x7b9850, name=<value optimized out>, settings=<value optimized out>)
    at /usr/src/debug/soprano-2.5.2/client/dbus/dbusclient.cpp:73
#13 0x0000003ce743d1a0 in (anonymous namespace)::GlobalModelContainer::init (this=0x7b9850, forced=<value optimized out>) at /usr/src/debug/kdelibs-4.5.3/nepomuk/core/nepomukmainmodel.cpp:92
#14 0x0000003ce74409ba in Nepomuk::MainModel::init (this=0x7b9040) at /usr/src/debug/kdelibs-4.5.3/nepomuk/core/nepomukmainmodel.cpp:176
#15 0x0000003ce743762e in Nepomuk::ResourceManager::init (this=0x7b7a40) at /usr/src/debug/kdelibs-4.5.3/nepomuk/core/resourcemanager.cpp:329
#16 0x0000003ce7439815 in Nepomuk::ResourceManagerPrivate::_k_storageServiceInitialized (this=0x7b7d70, success=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.3/nepomuk/core/resourcemanager.cpp:220
#17 0x0000003ce7439905 in Nepomuk::ResourceManager::qt_metacall (this=0x7b7a40, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff87255740)
    at /usr/src/debug/kdelibs-4.5.3/x86_64-redhat-linux-gnu/nepomuk/resourcemanager.moc:90
#18 0x0000003ce3221eb6 in QDBusConnectionPrivate::deliverCall (this=0x71ebb0, object=0x7b7a40, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:904
#19 0x0000003ce322c18f in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:101
#20 0x0000003ce2962f31 in QObject::event (this=0x7b7a40, e=0x82e0e0) at kernel/qobject.cpp:1248
#21 0x0000003ce45ab39c in QApplicationPrivate::notify_helper (this=0x6983f0, receiver=0x7b7a40, e=0x82e0e0) at kernel/qapplication.cpp:4306
#22 0x0000003ce45b165b in QApplication::notify (this=<value optimized out>, receiver=0x7b7a40, e=0x82e0e0) at kernel/qapplication.cpp:4189
#23 0x0000003ce581d166 in KApplication::notify (this=0x7fff87256350, receiver=0x7b7a40, event=0x82e0e0) at /usr/src/debug/kdelibs-4.5.3/kdeui/kernel/kapplication.cpp:310
#24 0x0000003ce2953ddc in QCoreApplication::notifyInternal (this=0x7fff87256350, receiver=0x7b7a40, event=0x82e0e0) at kernel/qcoreapplication.cpp:726
#25 0x0000003ce2955ed4 in sendEvent (receiver=0x0, event_type=0, data=0x681850) at kernel/qcoreapplication.h:215
#26 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x681850) at kernel/qcoreapplication.cpp:1367
#27 0x0000003ce2979d23 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#28 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#29 0x00000036cba3bd02 in g_main_dispatch (context=0x69adf0) at gmain.c:1960
#30 IA__g_main_context_dispatch (context=0x69adf0) at gmain.c:2513
#31 0x00000036cba3fae8 in g_main_context_iterate (context=0x69adf0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2591
#32 0x00000036cba3fc9c in IA__g_main_context_iteration (context=0x69adf0, may_block=1) at gmain.c:2654
#33 0x0000003ce2979863 in QEventDispatcherGlib::processEvents (this=0x680f40, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#34 0x0000003ce464a84e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x0000003ce2952822 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#36 0x0000003ce2952aec in QEventLoop::exec (this=0x7fff87256180, flags=...) at kernel/qeventloop.cpp:201
#37 0x0000003ce29561bb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#38 0x0000000000403b94 in main (argc=2, argv=0x7fff872567a8) at /usr/src/debug/kdebase-runtime-4.5.3/nepomuk/servicestub/main.cpp:165

This bug may be a duplicate of or related to bug 246110.

Possible duplicates by query: bug 256895, bug 255649, bug 252766, bug 252062, bug 251375.

Reported using DrKonqi
Comment 1 Thomas Janssen 2010-12-08 12:39:41 UTC
Created attachment 54295 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.5.4 (KDE 4.5.4) using Qt 4.7.1

- What I was doing when the application crashed:

Log in into KDE 4.5.4 with Qt-4.7. It's that way since a long time.

Reproducable: Everytime

Log in and wait a ~1 minute to see the crash happen.

-- Backtrace (Reduced):
#6  0x0000003626a6e17c in QMutex::lock (this=0x11d5028) at thread/qmutex.cpp:151
#7  0x000000362d45092c in QMutexLocker (this=0x7f15500bd990) at /usr/include/QtCore/qmutex.h:102
#8  Soprano::Error::ErrorCache::clearError (this=0x7f15500bd990) at /usr/src/debug/soprano-2.5.2/soprano/error.cpp:238
#9  0x000000362d450bc0 in Soprano::Error::ErrorCache::setError (this=0x7f15500bd990, error=...) at /usr/src/debug/soprano-2.5.2/soprano/error.cpp:225
#10 0x0000003623637211 in Soprano::Client::DBusModel::executeQuery (this=0x7f15500bd980, query=<value optimized out>, language=<value optimized out>, userQueryLanguage=<value optimized out>) at /usr/src/debug/soprano-2.5.2/client/dbus/dbusmodel.cpp:108
Comment 2 jamundso 2011-01-01 02:20:43 UTC
Created attachment 55432 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.5.4 (KDE 4.5.4) using Qt 4.6.3

- What I was doing when the application crashed:

I had just logged in, and did not have much running yet.

-- Backtrace (Reduced):
#7  0x06e3508a in QMutex::lock (this=0x96912cc) at thread/qmutex.cpp:150
#8  0x0263b1e3 in relock (this=0xb485a430) at /usr/include/QtCore/qmutex.h:120
#9  QMutexLocker (this=0xb485a430) at /usr/include/QtCore/qmutex.h:102
#10 Soprano::Error::ErrorCache::clearError (this=0xb485a430) at /usr/src/debug/soprano-2.5.2/soprano/error.cpp:238
#11 0x0263b468 in Soprano::Error::ErrorCache::setError (this=0xb485a430, error=...) at /usr/src/debug/soprano-2.5.2/soprano/error.cpp:225
Comment 3 Sebastian Trueg 2011-01-17 17:08:11 UTC

*** This bug has been marked as a duplicate of bug 245266 ***