Bug 262664 - plasma crashes on startup floating point exception
Summary: plasma crashes on startup floating point exception
Status: RESOLVED DUPLICATE of bug 251719
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-09 15:15 UTC by Jakub Holý
Modified: 2011-01-10 12:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jakub Holý 2011-01-09 15:15:21 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.5 (KDE 4.5.5) "release 1"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.7-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
plasma crashes on startup, regardless of nv/nvidia driver

The crash can be reproduced every time.

-- Backtrace:
Application: Pracovní plocha Plasma (kdeinit4), signal: Floating point exception
[Current thread is 1 (Thread 0xb5a2f710 (LWP 3533))]

Thread 2 (Thread 0xa98d7b70 (LWP 3624)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6d9c452 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6e1269c in wait (this=0x864151c, mutex=0x8641518, time=30000) at thread/qwaitcondition_unix.cpp:85
#3  QWaitCondition::wait (this=0x864151c, mutex=0x8641518, time=30000) at thread/qwaitcondition_unix.cpp:159
#4  0xb6e07cc4 in QThreadPoolThread::run (this=0x8640fd0) at concurrent/qthreadpool.cpp:140
#5  0xb6e1204f in QThreadPrivate::start (arg=0x8640fd0) at thread/qthread_unix.cpp:248
#6  0xb37bbde7 in ?? () from /usr/X11R6/lib/libGL.so.1
#7  0xb618446e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5a2f710 (LWP 3533)):
[KCrash Handler]
#7  0xb781a10a in enter.8102 () from /lib/ld-linux.so.2
#8  0xb781a771 in do_lookup_x () from /lib/ld-linux.so.2
#9  0xb781ab49 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#10 0xb781c45b in _dl_relocate_object () from /lib/ld-linux.so.2
#11 0xb7823823 in dl_open_worker () from /lib/ld-linux.so.2
#12 0xb781f50f in _dl_catch_error () from /lib/ld-linux.so.2
#13 0xb78232e6 in _dl_open () from /lib/ld-linux.so.2
#14 0xb5ebfbdd in dlopen_doit () from /lib/libdl.so.2
#15 0xb781f50f in _dl_catch_error () from /lib/ld-linux.so.2
#16 0xb5ec0342 in _dlerror_run () from /lib/libdl.so.2
#17 0xb5ebfca7 in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#18 0xb6efc469 in QLibraryPrivate::load_sys (this=0x886cf10) at plugin/qlibrary_unix.cpp:205
#19 0xb6ef69c4 in QLibraryPrivate::load (this=0x886cf10) at plugin/qlibrary.cpp:484
#20 0xb6ef6aa8 in QLibraryPrivate::loadPlugin (this=0x886cf10) at plugin/qlibrary.cpp:516
#21 0xb6ef1223 in QPluginLoader::load (this=0xbfe2fe2c) at plugin/qpluginloader.cpp:227
#22 0xb719b08f in KPluginLoader::load (this=0xbfe2fe2c) at /usr/src/debug/kdelibs-4.5.5/kdecore/util/kpluginloader.cpp:222
#23 0xb719b555 in KPluginLoader::KPluginLoader (this=0xbfe2fe2c, service=..., componentdata=..., parent=0x0) at /usr/src/debug/kdelibs-4.5.5/kdecore/util/kpluginloader.cpp:180
#24 0xb502452a in Plasma::DataEngineManager::loadEngine (this=0x81e57a0, name=...) at /usr/src/debug/kdelibs-4.5.5/plasma/dataenginemanager.cpp:137
#25 0xb505b085 in Plasma::DataEngineConsumer::dataEngine (this=0x8596240, name=...) at /usr/src/debug/kdelibs-4.5.5/plasma/private/dataengineconsumer.cpp:100
#26 0xb4fe29b7 in Plasma::Applet::dataEngine (this=0x86081d8, name=...) at /usr/src/debug/kdelibs-4.5.5/plasma/applet.cpp:663
#27 0xa9a0cc72 in ClockApplet::init (this=0x86081d8) at /usr/src/debug/kdebase-workspace-4.5.5/libs/plasmaclock/clockapplet.cpp:570
#28 0xa9a50a3e in Clock::init (this=0x86081d8) at /usr/src/debug/kdebase-workspace-4.5.5/plasma/generic/applets/digital-clock/clock.cpp:72
#29 0xb500607f in Plasma::ContainmentPrivate::initApplets (this=0x8347d70) at /usr/src/debug/kdelibs-4.5.5/plasma/containment.cpp:474
#30 0xb501b3d6 in Plasma::CoronaPrivate::importLayout (this=0x817db70, conf=..., mergeConfig=false) at /usr/src/debug/kdelibs-4.5.5/plasma/corona.cpp:558
#31 0xb501c125 in Plasma::Corona::loadLayout (this=0x81825d0, configName=...) at /usr/src/debug/kdelibs-4.5.5/plasma/corona.cpp:493
#32 0xb501c204 in Plasma::Corona::initializeLayout (this=0x81825d0, configName=...) at /usr/src/debug/kdelibs-4.5.5/plasma/corona.cpp:396
#33 0xb1823dd2 in PlasmaApp::corona (this=0x80dac88) at /usr/src/debug/kdebase-workspace-4.5.5/plasma/desktop/shell/plasmaapp.cpp:806
#34 0xb182475e in PlasmaApp::setupDesktop (this=0x80dac88) at /usr/src/debug/kdebase-workspace-4.5.5/plasma/desktop/shell/plasmaapp.cpp:286
#35 0xb182e749 in PlasmaApp::qt_metacall (this=0x80dac88, _c=QMetaObject::InvokeMetaMethod, _id=15, _a=0xbfe3060c)
    at /usr/src/debug/kdebase-workspace-4.5.5/build/plasma/desktop/shell/plasmaapp.moc:149
#36 0xb6f11efd in QMetaObject::metacall (object=0x80dac88, cl=QMetaObject::InvokeMetaMethod, idx=42, argv=0xbfe3060c) at kernel/qmetaobject.cpp:237
#37 0xb6f20fe8 in QMetaObject::activate (sender=0x817aad8, m=0xb7027188, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#38 0xb6f269d5 in QSingleShotTimer::timeout (this=0x817aad8) at .moc/release-shared/qtimer.moc:82
#39 0xb6f26a8c in QSingleShotTimer::timerEvent (this=0x817aad8) at kernel/qtimer.cpp:308
#40 0xb6f1e774 in QObject::event (this=0x817aad8, e=0xbfe30b40) at kernel/qobject.cpp:1212
#41 0xb6444c64 in QApplicationPrivate::notify_helper (this=0x80e2c90, receiver=0x817aad8, e=0xbfe30b40) at kernel/qapplication.cpp:4302
#42 0xb644cbf7 in QApplication::notify (this=0x80dac88, receiver=0x817aad8, e=0xbfe30b40) at kernel/qapplication.cpp:3706
#43 0xb752a9f1 in KApplication::notify (this=0x80dac88, receiver=0x817aad8, event=0xbfe30b40) at /usr/src/debug/kdelibs-4.5.5/kdeui/kernel/kapplication.cpp:310
#44 0xb6f0be0e in QCoreApplication::notifyInternal (this=0x80dac88, receiver=0x817aad8, event=0xbfe30b40) at kernel/qcoreapplication.cpp:726
#45 0xb6f3a70e in sendEvent (this=0x80e597c) at kernel/qcoreapplication.h:215
#46 QTimerInfoList::activateTimers (this=0x80e597c) at kernel/qeventdispatcher_unix.cpp:618
#47 0xb6f37642 in timerSourceDispatch (source=0x80e5948) at kernel/qeventdispatcher_glib.cpp:184
#48 0xb5c92b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#49 0xb5c93350 in ?? () from /usr/lib/libglib-2.0.so.0
#50 0xb5c9360e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#51 0xb6f37d4b in QEventDispatcherGlib::processEvents (this=0x80e2870, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#52 0xb64f519a in QGuiEventDispatcherGlib::processEvents (this=0x80e2870, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#53 0xb6f0b11d in QEventLoop::processEvents (this=0xbfe30e04, flags=...) at kernel/qeventloop.cpp:149
#54 0xb6f0b319 in QEventLoop::exec (this=0xbfe30e04, flags=...) at kernel/qeventloop.cpp:201
#55 0xb6f0fc70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#56 0xb6442164 in QApplication::exec () at kernel/qapplication.cpp:3581
#57 0xb18176aa in kdemain (argc=1, argv=0x80d4e00) at /usr/src/debug/kdebase-workspace-4.5.5/plasma/desktop/shell/main.cpp:118
#58 0x0804e3f1 in _start ()

This bug may be a duplicate of or related to bug 251719.

Possible duplicates by query: bug 261129, bug 261066, bug 257409, bug 256446, bug 255639.

Reported using DrKonqi
Comment 1 Marco Martin 2011-01-10 12:54:03 UTC

*** This bug has been marked as a duplicate of bug 251719 ***