Bug 261129 - While booting, KDE application crashes
Summary: While booting, KDE application crashes
Status: RESOLVED DUPLICATE of bug 251719
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kded (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-24 09:07 UTC by steiwol
Modified: 2010-12-24 13:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description steiwol 2010-12-24 09:07:09 UTC
Application: kded4 ($Id: kded.cpp 1031637 2009-10-05 16:58:19Z lunakl $)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.5-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
it occurs always during booting, when the graphic screen is showing.

 -- Backtrace:
Application: KDE-Dienst (kdeinit4), signal: Floating point exception
[KCrash Handler]
#6  0xb774b10a in enter.8102 () from /lib/ld-linux.so.2
#7  0xb774b771 in do_lookup_x () from /lib/ld-linux.so.2
#8  0xb774bb49 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#9  0xb774d45b in _dl_relocate_object () from /lib/ld-linux.so.2
#10 0xb7754823 in dl_open_worker () from /lib/ld-linux.so.2
#11 0xb775050f in _dl_catch_error () from /lib/ld-linux.so.2
#12 0xb77542e6 in _dl_open () from /lib/ld-linux.so.2
#13 0xb5ae8bdd in dlopen_doit () from /lib/libdl.so.2
#14 0xb775050f in _dl_catch_error () from /lib/ld-linux.so.2
#15 0xb5ae9342 in _dlerror_run () from /lib/libdl.so.2
#16 0xb5ae8ca7 in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#17 0xb6bc6469 in ?? () from /usr/lib/libQtCore.so.4
#18 0xb6bc09c4 in ?? () from /usr/lib/libQtCore.so.4
#19 0xb6bc0aa8 in ?? () from /usr/lib/libQtCore.so.4
#20 0xb6bbb223 in QPluginLoader::load() () from /usr/lib/libQtCore.so.4
#21 0xb762a60f in KPluginLoader::load() () from /usr/lib/libkdecore.so.5
#22 0xb762af0d in KPluginLoader::KPluginLoader(QString const&, KComponentData const&, QObject*) () from /usr/lib/libkdecore.so.5
#23 0xb504d944 in Kded::loadModule (this=0x80e2cc8, s=..., onDemand=false) at /usr/src/debug/kdelibs-4.4.4/kded/kded.cpp:354
#24 0xb504f0f0 in Kded::initModules (this=0x80e2cc8) at /usr/src/debug/kdelibs-4.4.4/kded/kded.cpp:234
#25 0xb5051dd5 in KDEDApplication::newInstance (this=0xbfa0ee60) at /usr/src/debug/kdelibs-4.4.4/kded/kded.cpp:856
#26 0xb6f2d793 in ?? () from /usr/lib/libkdeui.so.5
#27 0xb6f2d84c in ?? () from /usr/lib/libkdeui.so.5
#28 0xb5bffa37 in QDBusConnectionPrivate::deliverCall (this=0x80d8c10, object=0x81b2848, msg=..., metaTypes=..., slotIdx=-1580852999) at qdbusintegrator.cpp:904
#29 0xb5c01be7 in QDBusConnectionPrivate::activateCall (this=0x80d8c10, object=0x81b2848, flags=337, msg=...) at qdbusintegrator.cpp:809
#30 0xb5c02378 in QDBusConnectionPrivate::activateObject (this=0x80d8c10, node=..., msg=..., pathStartPos=135136904) at qdbusintegrator.cpp:1383
#31 0xb5c02878 in QDBusActivateObjectEvent::placeMetaCall (this=0x81baa90) at qdbusintegrator.cpp:1477
#32 0xb6be893f in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#33 0xb6bd63ea in QCoreApplication::event(QEvent*) () from /usr/lib/libQtCore.so.4
#34 0xb6111578 in QApplication::event (this=0xbfa0ee60, e=0x81baa90) at kernel/qapplication.cpp:2355
#35 0xb610fc64 in QApplicationPrivate::notify_helper (this=0x80e3e28, receiver=0xbfa0ee60, e=0x81baa90) at kernel/qapplication.cpp:4302
#36 0xb6117bf7 in QApplication::notify (this=0xbfa0ee60, receiver=0xbfa0ee60, e=0x81baa90) at kernel/qapplication.cpp:3706
#37 0xb6e199d1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#38 0xb6bd5e0e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#39 0xb6bd99b4 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#40 0xb6bd9b9c in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#41 0xb6c0183d in ?? () from /usr/lib/libQtCore.so.4
#42 0xb5858b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#43 0xb5859350 in ?? () from /usr/lib/libglib-2.0.so.0
#44 0xb585960e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#45 0xb6c01d4b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#46 0xb61c019a in QGuiEventDispatcherGlib::processEvents (this=0x805ee10, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#47 0xb6bd511d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#48 0xb6bd5319 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#49 0xb6bd9c70 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#50 0xb610d164 in QApplication::exec () at kernel/qapplication.cpp:3581
#51 0xb504d04d in kdemain (argc=1, argv=0x80d2758) at /usr/src/debug/kdelibs-4.4.4/kded/kded.cpp:932
#52 0x0804e5b1 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2010-12-24 13:00:43 UTC

*** This bug has been marked as a duplicate of bug 251719 ***