Bug 261066 - Search and Launch activity crashes on search (KDE 4.6 RC1)
Summary: Search and Launch activity crashes on search (KDE 4.6 RC1)
Status: RESOLVED DUPLICATE of bug 251719
Alias: None
Product: plasma4
Classification: Plasma
Component: desktop (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-23 12:58 UTC by Jorge Adriano
Modified: 2011-01-31 14:10 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jorge Adriano 2010-12-23 12:58:24 UTC
Version:           unspecified (using Devel) 
OS:                Linux

Search and Launch activity 
Input anything in the search field
Desktop Crashes

Reproducible: Always
Comment 1 Dario Andres 2010-12-23 13:43:43 UTC
[Comment from a bug triager]
- Try using GDB to retrieve a backtrace:

- Run Konsole
- Type "kquitapp plasma-desktop" + Enter to quit all the possible Plasma instances
- Type "gdb plasma-desktop" + Enter
- On the GDB prompt type "r" + Enter
KRunner should start and crash
- When you are on the GDB prompt again, type "thread apply bt full" + Enter
- Then type "bt full" + Enter (press Enter a couple of times)
- Copy the output of that last command here.

You can get more information at:
http://techbase.kde.org/User:DarioAndres/CreateUsefulReports#Retrieving_a_backtrace_with_GDB


BTW; are you using the NVIDIA drivers ? We lately got a lot of crash reports from OpenSuse which were caused by the official NVidia driver.

Thanks
Comment 2 Dario Andres 2010-12-23 13:44:06 UTC
[Comment from a bug triager]
Waiting for a backtrace
Comment 3 Jorge Adriano 2010-12-23 15:42:04 UTC
Sorry, I had to downgrade to 4.5.4 to get work done. 
I'll upgrade and get the backtrace soon.
Comment 4 Jorge Adriano 2010-12-23 15:44:21 UTC
Oh and yes, I have the problematic NVidia drivers. 

  Model:  GeForce 8600M GT
  2D driver:  nvidia
  3D driver:  NVIDIA 260.19.21

Not affecting krunner on 4.5.x though.
Comment 5 Jorge Adriano 2010-12-23 21:25:10 UTC
Here is the backtrace:


Application: Nepomuk Service Stub (nepomukservicestub), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5e2b710 (LWP 15523))]

Thread 2 (Thread 0xb2d53b70 (LWP 15988)):
[KCrash Handler]
#7  0xb681e778 in _int_malloc () from /lib/libc.so.6
#8  0xb6820403 in _int_realloc () from /lib/libc.so.6
#9  0xb6821c43 in realloc () from /lib/libc.so.6
#10 0xb7d7d433 in qRealloc (ptr=0xb24007b8, size=40) at global/qmalloc.cpp:65
#11 0xb7dd2e9e in QString::realloc (this=0xb2d5312c, alloc=10) at tools/qstring.cpp:1319
#12 0xb7dd96dc in operator+= (this=0xb2d52ec0, numArgs=2, args=0xb2d52ea4) at ../../src/corelib/tools/qstring.h:274
#13 QString::multiArg (this=0xb2d52ec0, numArgs=2, args=0xb2d52ea4) at tools/qstring.cpp:6939
#14 0xb60b61c5 in Soprano::Node::literalToN3(Soprano::LiteralValue const&) () from /usr/lib/libsoprano.so.4
#15 0xb3574632 in Nepomuk::Query::Query::toSparqlQuery (this=0xb2d532bc, sparqlFlags=...) at /usr/src/debug/kdelibs-4.5.90/nepomuk/query/query.cpp:505
#16 0xb3935aa4 in Nepomuk::Query::CountQueryRunnable::run (this=0x81245c8) at /usr/src/debug/kdebase-runtime-4.5.90/nepomuk/services/queryservice/countqueryrunnable.cpp:74
#17 0xb7d77d63 in QThreadPoolThread::run (this=0x8124660) at concurrent/qthreadpool.cpp:106
#18 0xb7d8239a in QThreadPrivate::start (arg=0x8124660) at thread/qthread_unix.cpp:285
#19 0xb7d07b25 in start_thread () from /lib/libpthread.so.0
#20 0xb688246e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5e2b710 (LWP 15523)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb68905b3 in __lll_lock_wait_private () from /lib/libc.so.6
#2  0xb682335f in _L_lock_10260 () from /lib/libc.so.6
#3  0xb6821ad6 in free () from /lib/libc.so.6
#4  0xb7d7d40b in qFree (ptr=0xb2400720) at global/qmalloc.cpp:60
#5  0xb7da11d5 in QHashData::freeNode (this=0xb2400560, node=0xb2400720) at tools/qhash.cpp:185
#6  0xb7da124a in QHashData::free_helper (this=0xb2400560, node_delete=0xb60ce4d0) at tools/qhash.cpp:272
#7  0xb60ce644 in ?? () from /usr/lib/libsoprano.so.4
#8  0xb67dd7cf in __run_exit_handlers () from /lib/libc.so.6
#9  0xb67dd82d in exit () from /lib/libc.so.6
#10 0xb6bc26e8 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:773
#11 0xb76d0e19 in KApplication::xioErrhandler (this=0xbfffefe8, dpy=0x8072690) at /usr/src/debug/kdelibs-4.5.90/kdeui/kernel/kapplication.cpp:417
#12 0xb76d0e54 in kde_xio_errhandler (dpy=0x8072690) at /usr/src/debug/kdelibs-4.5.90/kdeui/kernel/kapplication.cpp:126
#13 0xb6347504 in _XIOError () from /usr/lib/libX11.so.6
#14 0xb634e2b8 in ?? () from /usr/lib/libX11.so.6
#15 0xb634e70c in _XEventsQueued () from /usr/lib/libX11.so.6
#16 0xb63372e8 in XEventsQueued () from /usr/lib/libX11.so.6
#17 0xb6bff7e5 in x11EventSourceCheck (s=0x806b3a8) at kernel/qguieventdispatcher_glib.cpp:85
#18 0xb66dd7d0 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#19 0xb66de108 in ?? () from /usr/lib/libglib-2.0.so.0
#20 0xb66de60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#21 0xb7eafd5b in QEventDispatcherGlib::processEvents (this=0x8054470, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#22 0xb6bff9aa in QGuiEventDispatcherGlib::processEvents (this=0x8054470, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0xb7e8089d in QEventLoop::processEvents (this=0xbfffee44, flags=...) at kernel/qeventloop.cpp:149
#24 0xb7e80ac9 in QEventLoop::exec (this=0xbfffee44, flags=...) at kernel/qeventloop.cpp:201
#25 0xb7e85570 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#26 0xb6b47114 in QApplication::exec () at kernel/qapplication.cpp:3719
#27 0x0804b36e in main (argc=) at /usr/src/debug/kdebase-runtime-4.5.90/nepomuk/servicestub/main.cpp:165
Comment 6 Jorge Adriano 2010-12-23 21:30:12 UTC
By the way, gdb also returned no stack on this one. I got the backtrace with the kde crash widget. However the crash widget is not giving me a backtrace for krunner (BUG 261065), saying no useful info was found.
Comment 7 Dario Andres 2010-12-30 18:47:38 UTC
[Comment from a bug triager]
The crash could be related to Nepomuk/Soprano; but there are other errors I cannot identify.
Reopening.
Comment 8 Marco Martin 2011-01-03 17:31:04 UTC
uhm, possibly upstream?
Comment 9 Jorge Adriano 2011-01-07 11:30:58 UTC
Still present on RC2
Comment 10 Sebastian Trueg 2011-01-07 12:00:46 UTC
Does the nepomuk query service crash with the exact same backtrace as in comment 5?
Comment 11 Jorge Adriano 2011-01-07 13:26:42 UTC
(In reply to comment #10)
> Does the nepomuk query service crash with the exact same backtrace as in
> comment 5?

Application: Plasma Desktop Shell (plasma-desktop), signal: Floating point exception
[Current thread is 1 (Thread 0xb0e62720 (LWP 6502))]

Thread 2 (Thread 0xa87aeb70 (LWP 6509)):
#0  0xb32a022b in clock_gettime () from /lib/librt.so.1
#1  0xb64b5265 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6588d26 in updateCurrentTime (this=0x85c6794, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x85c6794, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb658755b in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xa87ae05c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb65875fd in timerSourcePrepare (source=0x85c6760, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb31f30c0 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#8  0xb31f3f22 in ?? () from /usr/lib/libglib-2.0.so.0
#9  0xb31f460e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#10 0xb6587da7 in QEventDispatcherGlib::processEvents (this=0x834f578, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb655889d in QEventLoop::processEvents (this=0xa87ae1f0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6558ac9 in QEventLoop::exec (this=0xa87ae1f0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb64577a9 in QThread::exec (this=0x834d220) at thread/qthread.cpp:490
#14 0xb65384ad in QInotifyFileSystemWatcherEngine::run (this=0x834d220) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb645a39a in QThreadPrivate::start (arg=0x834d220) at thread/qthread_unix.cpp:285
#16 0xb3858cd7 in ?? () from /usr/X11R6/lib/libGL.so.1
#17 0xb770946e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb0e62720 (LWP 6502)):
[KCrash Handler]
#7  0xb784610a in enter.8102 () from /lib/ld-linux.so.2
#8  0xb7846771 in do_lookup_x () from /lib/ld-linux.so.2
#9  0xb7846b49 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#10 0xb784845b in _dl_relocate_object () from /lib/ld-linux.so.2
#11 0xb784f823 in dl_open_worker () from /lib/ld-linux.so.2
#12 0xb784b50f in _dl_catch_error () from /lib/ld-linux.so.2
#13 0xb784f2e6 in _dl_open () from /lib/ld-linux.so.2
#14 0xb342fbdd in dlopen_doit () from /lib/libdl.so.2
#15 0xb784b50f in _dl_catch_error () from /lib/ld-linux.so.2
#16 0xb3430342 in _dlerror_run () from /lib/libdl.so.2
#17 0xb342fca7 in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#18 0xb65494b5 in QLibraryPrivate::load_sys (this=0x8be1a78) at plugin/qlibrary_unix.cpp:205
#19 0xb6543ff4 in QLibraryPrivate::load (this=0x8be1a78) at plugin/qlibrary.cpp:446
#20 0xb65440d8 in QLibraryPrivate::loadPlugin (this=0x8be1a78) at plugin/qlibrary.cpp:478
#21 0xb653ded3 in QPluginLoader::load (this=0xbfbb1128) at plugin/qpluginloader.cpp:227
#22 0xb68a2258 in KPluginLoader::load() () from /usr/lib/libkdecore.so.5
#23 0xb68a2675 in KPluginLoader::pluginVersion() const () from /usr/lib/libkdecore.so.5
#24 0xb74bcf67 in Plasma::RunnerManagerPrivate::loadInstalledRunner (this=0x8369f68, service=...) at /usr/src/debug/kdelibs-4.5.95/plasma/runnermanager.cpp:251
#25 0xb74bdde6 in Plasma::RunnerManagerPrivate::loadRunners (this=0x8369f68) at /usr/src/debug/kdelibs-4.5.95/plasma/runnermanager.cpp:218
#26 0xb74bb680 in Plasma::RunnerManager::launchQuery (this=0x826a930, untrimmedTerm=..., runnerName=...) at /usr/src/debug/kdelibs-4.5.95/plasma/runnermanager.cpp:702
#27 0xae22c18e in KRunnerModel::timerEvent (this=0x81f0d60, event=0xbfbb18dc) at /usr/src/debug/kdebase-workspace-4.5.95/plasma/netbook/containments/sal/models/krunnermodel.cpp:143
#28 0xb656e9c4 in QObject::event (this=0x81f0d60, e=0xbfbb18dc) at kernel/qobject.cpp:1175
#29 0xb5a56414 in QApplicationPrivate::notify_helper (this=0x80cb500, receiver=0x81f0d60, e=0xbfbb18dc) at kernel/qapplication.cpp:4445
#30 0xb5a5f137 in QApplication::notify (this=0x80c8820, receiver=0x81f0d60, e=0xbfbb18dc) at kernel/qapplication.cpp:3845
#31 0xb6b096c1 in KApplication::notify (this=0x80c8820, receiver=0x81f0d60, event=0xbfbb18dc) at /usr/src/debug/kdelibs-4.5.95/kdeui/kernel/kapplication.cpp:311
#32 0xb65595be in QCoreApplication::notifyInternal (this=0x80c8820, receiver=0x81f0d60, event=0xbfbb18dc) at kernel/qcoreapplication.cpp:732
#33 0xb658a9a8 in sendEvent (this=0x80cc6cc) at kernel/qcoreapplication.h:215
#34 QTimerInfoList::activateTimers (this=0x80cc6cc) at kernel/qeventdispatcher_unix.cpp:618
#35 0xb6587665 in timerSourceDispatch (source=0x80cb620) at kernel/qeventdispatcher_glib.cpp:184
#36 idleTimerSourceDispatch (source=0x80cb620) at kernel/qeventdispatcher_glib.cpp:231
#37 0xb31f3b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#38 0xb31f4350 in ?? () from /usr/lib/libglib-2.0.so.0
#39 0xb31f460e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#40 0xb6587d5b in QEventDispatcherGlib::processEvents (this=0x8053e88, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0xb5b0c9aa in QGuiEventDispatcherGlib::processEvents (this=0x8053e88, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb655889d in QEventLoop::processEvents (this=0xbfbb1b84, flags=...) at kernel/qeventloop.cpp:149
#43 0xb6558ac9 in QEventLoop::exec (this=0xbfbb1b84, flags=...) at kernel/qeventloop.cpp:201
#44 0xb655d570 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#45 0xb5a54114 in QApplication::exec () at kernel/qapplication.cpp:3719
#46 0xb77d685a in kdemain (argc=1, argv=0xbfbb1d94) at /usr/src/debug/kdebase-workspace-4.5.95/plasma/desktop/shell/main.cpp:118
#47 0x0804861b in main (argc=1, argv=0xbfbb1d94) at /usr/src/debug/kdebase-workspace-4.5.95/build/plasma/desktop/shell/plasma-desktop_dummy.cpp:3
Comment 12 Jorge Adriano 2011-01-07 13:29:09 UTC
(In reply to comment #10)
> Does the nepomuk query service crash with the exact same backtrace as in
> comment 5?

No, seems quite different now. Looks like the usual nvidia related crash backtrace now.
Comment 13 Dario Andres 2011-01-08 12:49:31 UTC
[Comment from a bug triager]
Indeed, the last backtrace is more like the one in bug 251719.
We could consider the nepomuk related crash now "fixed", or wait a bit more to check if that backtrace appears again in the near future
Regards
Comment 14 Marco Martin 2011-01-31 14:04:58 UTC
Comment #11 doesn't have anything to do with nepomuk and is probably due to a problem in all nvidia drivers more recent than 190
Comment 15 Jorge Adriano 2011-01-31 14:10:20 UTC
Closing as duplicate (hope it's ok).

*** This bug has been marked as a duplicate of bug 251719 ***