Bug 255639 - Plasma desktop crash on boot
Summary: Plasma desktop crash on boot
Status: RESOLVED DUPLICATE of bug 251719
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-30 03:26 UTC by Vivek
Modified: 2010-11-06 17:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
New crash information added by DrKonqi (6.17 KB, text/plain)
2010-11-06 17:32 UTC, Virtual Sound
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vivek 2010-10-30 03:26:49 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.2 (KDE 4.5.2) "release 10"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.5-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:

Plasma crashes on boot and every time I try to get it running.  It only stays running when I run it under 'gdb plasma-desktop' or 'gdb plasma-netbook'.  

This bug seems similar to another one found in Dr. Konqi.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Floating point exception
[KCrash Handler]
#7  0xb774910a in enter.8102 () from /lib/ld-linux.so.2
#8  0xb7749771 in do_lookup_x () from /lib/ld-linux.so.2
#9  0xb7749b49 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#10 0xb774b45b in _dl_relocate_object () from /lib/ld-linux.so.2
#11 0xb7752823 in dl_open_worker () from /lib/ld-linux.so.2
#12 0xb774e50f in _dl_catch_error () from /lib/ld-linux.so.2
#13 0xb77522e6 in _dl_open () from /lib/ld-linux.so.2
#14 0xb5df6bdd in dlopen_doit () from /lib/libdl.so.2
#15 0xb774e50f in _dl_catch_error () from /lib/ld-linux.so.2
#16 0xb5df7342 in _dlerror_run () from /lib/libdl.so.2
#17 0xb5df6ca7 in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#18 0xb6e33469 in QLibraryPrivate::load_sys (this=0x825fc58) at plugin/qlibrary_unix.cpp:205
#19 0xb6e2d9c4 in QLibraryPrivate::load (this=0x825fc58) at plugin/qlibrary.cpp:484
#20 0xb6e2daa8 in QLibraryPrivate::loadPlugin (this=0x825fc58) at plugin/qlibrary.cpp:516
#21 0xb6e28223 in QPluginLoader::load (this=0xbfa27070) at plugin/qpluginloader.cpp:227
#22 0xb70da36f in KPluginLoader::load() () from /usr/lib/libkdecore.so.5
#23 0xb70da835 in KPluginLoader::KPluginLoader(KService const&, KComponentData const&, QObject*) () from /usr/lib/libkdecore.so.5
#24 0xb4e2a700 in Plasma::Applet::load (appletName=..., appletId=21, args=...) at /usr/src/debug/kdelibs-4.5.2/plasma/applet.cpp:2346
#25 0xb4e414e5 in Plasma::ContainmentPrivate::addApplet (this=0x825ce68, name=..., args=..., appletGeometry=..., id=21, delayInit=true) at /usr/src/debug/kdelibs-4.5.2/plasma/containment.cpp:2366
#26 0xb4e49ff9 in Plasma::Containment::restoreContents (this=0x8258070, group=...) at /usr/src/debug/kdelibs-4.5.2/plasma/containment.cpp:511
#27 0xb4e443df in Plasma::Containment::restore (this=0x8258070, group=...) at /usr/src/debug/kdelibs-4.5.2/plasma/containment.cpp:381
#28 0xaa197a8f in Panel::restore (this=0x8258070, group=...) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/containments/panel/panel.cpp:671
#29 0xb4e53273 in Plasma::CoronaPrivate::importLayout (this=0x8164ee0, conf=..., mergeConfig=false) at /usr/src/debug/kdelibs-4.5.2/plasma/corona.cpp:519
#30 0xb4e53c45 in Plasma::Corona::loadLayout (this=0x8149d58, configName=...) at /usr/src/debug/kdelibs-4.5.2/plasma/corona.cpp:460
#31 0xb4e53d24 in Plasma::Corona::initializeLayout (this=0x8149d58, configName=...) at /usr/src/debug/kdelibs-4.5.2/plasma/corona.cpp:363
#32 0xb1667f52 in PlasmaApp::corona (this=0x80d8ec0) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/plasmaapp.cpp:806
#33 0xb16688de in PlasmaApp::setupDesktop (this=0x80d8ec0) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/plasmaapp.cpp:286
#34 0xb16728c9 in PlasmaApp::qt_metacall (this=0x80d8ec0, _c=QMetaObject::InvokeMetaMethod, _id=15, _a=0xbfa27bcc)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/plasma/desktop/shell/plasmaapp.moc:149
#35 0xb6e48efd in QMetaObject::metacall (object=0x80d8ec0, cl=QMetaObject::InvokeMetaMethod, idx=42, argv=0xbfa27bcc) at kernel/qmetaobject.cpp:237
#36 0xb6e57fe8 in QMetaObject::activate (sender=0x8128fe8, m=0xb6f5e188, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#37 0xb6e5d9d5 in QSingleShotTimer::timeout (this=0x8128fe8) at .moc/release-shared/qtimer.moc:82
#38 0xb6e5da8c in QSingleShotTimer::timerEvent (this=0x8128fe8) at kernel/qtimer.cpp:308
#39 0xb6e55774 in QObject::event (this=0x8128fe8, e=0xbfa28100) at kernel/qobject.cpp:1212
#40 0xb637bc64 in QApplicationPrivate::notify_helper (this=0x80e0778, receiver=0x8128fe8, e=0xbfa28100) at kernel/qapplication.cpp:4302
#41 0xb6383bf7 in QApplication::notify (this=0x80d8ec0, receiver=0x8128fe8, e=0xbfa28100) at kernel/qapplication.cpp:3706
#42 0xb7461941 in KApplication::notify (this=0x80d8ec0, receiver=0x8128fe8, event=0xbfa28100) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#43 0xb6e42e0e in QCoreApplication::notifyInternal (this=0x80d8ec0, receiver=0x8128fe8, event=0xbfa28100) at kernel/qcoreapplication.cpp:726
#44 0xb6e7170e in sendEvent (this=0x80e3834) at kernel/qcoreapplication.h:215
#45 QTimerInfoList::activateTimers (this=0x80e3834) at kernel/qeventdispatcher_unix.cpp:618
#46 0xb6e6e642 in timerSourceDispatch (source=0x80e3800) at kernel/qeventdispatcher_glib.cpp:184
#47 0xb5bc9b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#48 0xb5bca350 in ?? () from /usr/lib/libglib-2.0.so.0
#49 0xb5bca60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#50 0xb6e6ed4b in QEventDispatcherGlib::processEvents (this=0x80e0348, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#51 0xb642c19a in QGuiEventDispatcherGlib::processEvents (this=0x80e0348, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#52 0xb6e4211d in QEventLoop::processEvents (this=0xbfa283c4, flags=...) at kernel/qeventloop.cpp:149
#53 0xb6e42319 in QEventLoop::exec (this=0xbfa283c4, flags=...) at kernel/qeventloop.cpp:201
#54 0xb6e46c70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#55 0xb6379164 in QApplication::exec () at kernel/qapplication.cpp:3581
#56 0xb165b5ed in kdemain (argc=1, argv=0x80d53e0) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/main.cpp:118
#57 0x0804e3f1 in _start ()

This bug may be a duplicate of or related to bug 255626.

Possible duplicates by query: bug 255626.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-10-30 14:13:45 UTC

*** This bug has been marked as a duplicate of bug 251719 ***
Comment 2 Virtual Sound 2010-11-06 17:32:14 UTC
Created attachment 53202 [details]
New crash information added by DrKonqi

plasma-desktop (0.3) on KDE Platform 4.5.3 (KDE 4.5.3) using Qt 4.7.0

- What I was doing when the application crashed: Starting openSUSE 11.3 with KDE 4.5.3, but also occurs in KDE 4.5.2

- Unusual behavior I noticed: Completely black screen, plasma will not start

- Custom settings of the application: No

-- Backtrace (Reduced):
#7  0xb77a810a in enter.8102 () from /lib/ld-linux.so.2
#8  0xb77a8771 in do_lookup_x () from /lib/ld-linux.so.2
#9  0xb77a8b49 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#10 0xb77aa45b in _dl_relocate_object () from /lib/ld-linux.so.2
#11 0xb77b1823 in dl_open_worker () from /lib/ld-linux.so.2