Bug 257409 - KDE crash on start
Summary: KDE crash on start
Status: RESOLVED DUPLICATE of bug 251719
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-20 14:23 UTC by mabrand
Modified: 2010-11-20 16:11 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mabrand 2010-11-20 14:23:38 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.3 (KDE 4.5.3)
Qt Version: 4.7.1
Operating System: Linux 2.6.34.7-0.5-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:

Started KDE after upgrading to Suse 11.3 with KDE Factory 4.5

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Floating point exception
[KCrash Handler]
#7  0xb78ba10a in enter.8102 () from /lib/ld-linux.so.2
#8  0xb78ba771 in do_lookup_x () from /lib/ld-linux.so.2
#9  0xb78bab49 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#10 0xb78bc45b in _dl_relocate_object () from /lib/ld-linux.so.2
#11 0xb78c3823 in dl_open_worker () from /lib/ld-linux.so.2
#12 0xb78bf50f in _dl_catch_error () from /lib/ld-linux.so.2
#13 0xb78c32e6 in _dl_open () from /lib/ld-linux.so.2
#14 0xb5ecabdd in dlopen_doit () from /lib/libdl.so.2
#15 0xb78bf50f in _dl_catch_error () from /lib/ld-linux.so.2
#16 0xb5ecb342 in _dlerror_run () from /lib/libdl.so.2
#17 0xb5ecaca7 in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#18 0xb6f58405 in QLibraryPrivate::load_sys (this=0x88bb908) at plugin/qlibrary_unix.cpp:205
#19 0xb6f52f44 in QLibraryPrivate::load (this=0x88bb908) at plugin/qlibrary.cpp:446
#20 0xb6f53028 in QLibraryPrivate::loadPlugin (this=0x88bb908) at plugin/qlibrary.cpp:478
#21 0xb6f4ce23 in QPluginLoader::load (this=0xbfe4882c) at plugin/qpluginloader.cpp:227
#22 0xb721a6af in KPluginLoader::load (this=0xbfe4882c) at /usr/src/debug/kdelibs-4.5.3/kdecore/util/kpluginloader.cpp:222
#23 0xb721ab75 in KPluginLoader::KPluginLoader (this=0xbfe4882c, service=..., componentdata=..., parent=0x0) at /usr/src/debug/kdelibs-4.5.3/kdecore/util/kpluginloader.cpp:180
#24 0xb4f1eb6a in Plasma::DataEngineManager::loadEngine (this=0x8391020, name=...) at /usr/src/debug/kdelibs-4.5.3/plasma/dataenginemanager.cpp:137
#25 0xb4f55d75 in Plasma::DataEngineConsumer::dataEngine (this=0x83e8378, name=...) at /usr/src/debug/kdelibs-4.5.3/plasma/private/dataengineconsumer.cpp:100
#26 0xb4edada7 in Plasma::Applet::dataEngine (this=0x8350a80, name=...) at /usr/src/debug/kdelibs-4.5.3/plasma/applet.cpp:663
#27 0xa9d85fa2 in ClockApplet::init (this=0x8350a80) at /usr/src/debug/kdebase-workspace-4.5.3/libs/plasmaclock/clockapplet.cpp:570
#28 0xa9ddda3e in Clock::init (this=0x8350a80) at /usr/src/debug/kdebase-workspace-4.5.3/plasma/generic/applets/digital-clock/clock.cpp:72
#29 0xb4f02a2f in Plasma::ContainmentPrivate::initApplets (this=0x82b4758) at /usr/src/debug/kdelibs-4.5.3/plasma/containment.cpp:474
#30 0xb4f14f46 in Plasma::CoronaPrivate::importLayout (this=0x8165370, conf=..., mergeConfig=false) at /usr/src/debug/kdelibs-4.5.3/plasma/corona.cpp:525
#31 0xb4f15c95 in Plasma::Corona::loadLayout (this=0x81633b0, configName=...) at /usr/src/debug/kdelibs-4.5.3/plasma/corona.cpp:460
#32 0xb4f15d74 in Plasma::Corona::initializeLayout (this=0x81633b0, configName=...) at /usr/src/debug/kdelibs-4.5.3/plasma/corona.cpp:363
#33 0xb18131ea in PlasmaApp::corona (this=0x80d4720) at /usr/src/debug/kdebase-workspace-4.5.3/plasma/desktop/shell/plasmaapp.cpp:806
#34 0xb18168ae in PlasmaApp::setupDesktop (this=0x80d4720) at /usr/src/debug/kdebase-workspace-4.5.3/plasma/desktop/shell/plasmaapp.cpp:286
#35 0xb181f3d9 in PlasmaApp::qt_metacall (this=0x80d4720, _c=QMetaObject::InvokeMetaMethod, _id=15, _a=0x81607b8)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/plasma/desktop/shell/plasmaapp.moc:149
#36 0xb6f6edad in QMetaObject::metacall (object=0x80d4720, cl=QMetaObject::InvokeMetaMethod, idx=42, argv=0x81607b8) at kernel/qmetaobject.cpp:237
#37 0xb6f79895 in QMetaCallEvent::placeMetaCall (this=0x8160720, object=0x80d4720) at kernel/qobject.cpp:534
#38 0xb6f7dacf in QObject::event (this=0x80d4720, e=0x8160720) at kernel/qobject.cpp:1211
#39 0xb6f68afa in QCoreApplication::event (this=0x80d4720, e=0x8160720) at kernel/qcoreapplication.cpp:1561
#40 0xb6466c2d in QApplication::event (this=0x80d4720, e=0x8160720) at kernel/qapplication.cpp:2486
#41 0xb6464414 in QApplicationPrivate::notify_helper (this=0x80ddad0, receiver=0x80d4720, e=0x8160720) at kernel/qapplication.cpp:4445
#42 0xb646d137 in QApplication::notify (this=0x80d4720, receiver=0x80d4720, e=0x8160720) at kernel/qapplication.cpp:3845
#43 0xb75ae9f1 in KApplication::notify (this=0x80d4720, receiver=0x80d4720, event=0x8160720) at /usr/src/debug/kdelibs-4.5.3/kdeui/kernel/kapplication.cpp:310
#44 0xb6f6850e in QCoreApplication::notifyInternal (this=0x80d4720, receiver=0x80d4720, event=0x8160720) at kernel/qcoreapplication.cpp:732
#45 0xb6f6c29c in sendEvent (receiver=0x0, event_type=0, data=0x80572a0) at kernel/qcoreapplication.h:215
#46 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80572a0) at kernel/qcoreapplication.cpp:1373
#47 0xb6f6c3ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#48 0xb6f96b24 in sendPostedEvents (s=0x80dfd10) at kernel/qcoreapplication.h:220
#49 postEventSourceDispatch (s=0x80dfd10) at kernel/qeventdispatcher_glib.cpp:277
#50 0xb5c9fb49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#51 0xb5ca0350 in ?? () from /usr/lib/libglib-2.0.so.0
#52 0xb5ca060e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#53 0xb6f96cab in QEventDispatcherGlib::processEvents (this=0x80daa58, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#54 0xb651a9aa in QGuiEventDispatcherGlib::processEvents (this=0x80daa58, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#55 0xb6f677ed in QEventLoop::processEvents (this=0xbfe497a4, flags=...) at kernel/qeventloop.cpp:149
#56 0xb6f67a19 in QEventLoop::exec (this=0xbfe497a4, flags=...) at kernel/qeventloop.cpp:201
#57 0xb6f6c4c0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#58 0xb6462114 in QApplication::exec () at kernel/qapplication.cpp:3719
#59 0xb180c0aa in kdemain (argc=1, argv=0x80d0e48) at /usr/src/debug/kdebase-workspace-4.5.3/plasma/desktop/shell/main.cpp:118
#60 0x0804e441 in launch (argc=1, _name=0x80d1164 "/usr/bin/plasma-desktop", args=<value optimized out>, cwd=0x0, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x80524c3 "0") at /usr/src/debug/kdelibs-4.5.3/kinit/kinit.cpp:723
#61 0x0804ef77 in handle_launcher_request (sock=8, who=<value optimized out>) at /usr/src/debug/kdelibs-4.5.3/kinit/kinit.cpp:1215
#62 0x0804f61c in handle_requests (waitForPid=<value optimized out>) at /usr/src/debug/kdelibs-4.5.3/kinit/kinit.cpp:1408
#63 0x08050499 in main (argc=143820080, argv=0x0, envp=0x0) at /usr/src/debug/kdelibs-4.5.3/kinit/kinit.cpp:1892

This bug may be a duplicate of or related to bug 251719.

Possible duplicates by query: bug 256446, bug 255639, bug 255626, bug 251719.

Reported using DrKonqi
Comment 1 Dario Andres 2010-11-20 14:43:45 UTC
[Comment from a bug triager]
- Do you use the NVIDIA drivers ? (as in bug 251719)
Thanks
Comment 2 mabrand 2010-11-20 14:54:28 UTC
Yes. I tried switching to nouveau out of curiousity, but wasn't able to get X to start that way.

x11-video-nvidiaG02-260.19.21-20.1.i586
nvidia-gfxG02-kmp-desktop-260.19.21_k2.6.34.0_12-19.1.i586
01:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8400M GS] (rev a1)
Comment 3 Dario Andres 2010-11-20 16:11:19 UTC
Thanks for the information. Merging with bug 251719.

*** This bug has been marked as a duplicate of bug 251719 ***