Bug 257617 - ktorrent crash
Summary: ktorrent crash
Status: RESOLVED DUPLICATE of bug 241598
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-22 16:46 UTC by Justin
Modified: 2010-11-22 19:05 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin 2010-11-22 16:46:24 UTC
Application: ktorrent (3.3.4)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-25-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
started crashing maybe once every few hours, now crashes on start up....everytime

The crash can be reproduced every time.

 -- Backtrace:
Application: KTorrent (ktorrent), signal: Bus error
[KCrash Handler]
#6  0x0826a040 in ?? () from /lib/tls/i686/cmov/libc.so.6
#7  0x06700016 in QCA::MemoryRegion::MemoryRegion(QByteArray const&) () from /usr/lib/libqca.so.2
#8  0x06717167 in QCA::Hash::update(QByteArray const&) () from /usr/lib/libqca.so.2
#9  0x00af518f in bt::SHA1HashGen::update (this=0x9aeb068, data=0xb54b8000 <Address 0xb54b8000 out of bounds>, len=16384) at ../../libbtcore/util/sha1hashgen.cpp:240
#10 0x00b2db7e in bt::ChunkDownload::updateHash (this=0x9aeaff8) at ../../libbtcore/download/chunkdownload.cpp:579
#11 0x00b2dfcb in bt::ChunkDownload::load (this=0x9aeaff8, file=..., hdr=..., update_hash=true) at ../../libbtcore/download/chunkdownload.cpp:488
#12 0x00b34f6c in bt::Downloader::loadDownloads (this=0x97b9c20, file=...) at ../../libbtcore/download/downloader.cpp:618
#13 0x00b5494e in bt::TorrentControl::continueStart (this=0x97a8988) at ../../libbtcore/torrent/torrentcontrol.cpp:363
#14 0x00b54d37 in bt::TorrentControl::start (this=0x97a8988) at ../../libbtcore/torrent/torrentcontrol.cpp:353
#15 0x00e86955 in kt::QueueManager::startSafely (this=0x94090a0, tc=0x97a8988) at ../../libktcore/torrent/queuemanager.cpp:715
#16 0x00e88daf in kt::QueueManager::startInternal (this=0x94090a0, tc=0x97a8988) at ../../libktcore/torrent/queuemanager.cpp:144
#17 0x00e89467 in kt::QueueManager::orderQueue (this=0x94090a0) at ../../libktcore/torrent/queuemanager.cpp:575
#18 0x080729eb in kt::Core::loadTorrents (this=0x951c170) at ../../ktorrent/core.cpp:620
#19 0x0807e46c in GUI (this=0x94c8f48, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at ../../ktorrent/gui.cpp:95
#20 0x0807ef82 in kt::App::newInstance (this=0xbf965a14) at ../../ktorrent/app.cpp:52
#21 0x00370950 in KUniqueApplicationAdaptor::newInstance (this=0x9519ca0, asn_id=..., args=...) at ../../kdeui/kernel/kuniqueapplication.cpp:454
#22 0x003710b2 in KUniqueApplicationAdaptor::qt_metacall (this=0x9519ca0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf964f7c) at ./kuniqueapplication_p.moc:81
#23 0x00c65b34 in QDBusConnectionPrivate::deliverCall (this=0x93d12a0, object=0x9519ca0, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#24 0x00c66ddf in QDBusConnectionPrivate::activateCall (this=0x93d12a0, object=0x9519ca0, flags=337, msg=...) at qdbusintegrator.cpp:809
#25 0x00c67880 in QDBusConnectionPrivate::activateObject (this=0x93d12a0, node=..., msg=..., pathStartPos=16) at qdbusintegrator.cpp:1364
#26 0x00c67b1a in QDBusActivateObjectEvent::placeMetaCall (this=0x951b238) at qdbusintegrator.cpp:1477
#27 0x01b283fe in QObject::event (this=0xbf965a14, e=0x951b238) at kernel/qobject.cpp:1248
#28 0x01b1750b in QCoreApplication::event (this=0xbf965a14, e=0x951b238) at kernel/qcoreapplication.cpp:1533
#29 0x01d66e46 in QApplication::event (this=0xbf965a14, e=0x951b238) at kernel/qapplication.cpp:2353
#30 0x01d624dc in QApplicationPrivate::notify_helper (this=0x93d9ef8, receiver=0xbf965a14, e=0x951b238) at kernel/qapplication.cpp:4300
#31 0x01d6905e in QApplication::notify (this=0xbf965a14, receiver=0xbf965a14, e=0x951b238) at kernel/qapplication.cpp:3704
#32 0x00368f2a in KApplication::notify (this=0xbf965a14, receiver=0xbf965a14, event=0x951b238) at ../../kdeui/kernel/kapplication.cpp:302
#33 0x01b17a3b in QCoreApplication::notifyInternal (this=0xbf965a14, receiver=0xbf965a14, event=0x951b238) at kernel/qcoreapplication.cpp:704
#34 0x01b1a473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x93b66a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x93b66a0) at kernel/qcoreapplication.cpp:1345
#36 0x01b1a5dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#37 0x01b43adf in QCoreApplication::sendPostedEvents (s=0x93deca8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#38 postEventSourceDispatch (s=0x93deca8) at kernel/qeventdispatcher_glib.cpp:276
#39 0x07bf45e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#40 0x07bf82d8 in ?? () from /lib/libglib-2.0.so.0
#41 0x07bf84b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#42 0x01b435d5 in QEventDispatcherGlib::processEvents (this=0x93b6380, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#43 0x01e22135 in QGuiEventDispatcherGlib::processEvents (this=0x93b6380, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#44 0x01b16059 in QEventLoop::processEvents (this=0xbf965984, flags=) at kernel/qeventloop.cpp:149
#45 0x01b164aa in QEventLoop::exec (this=0xbf965984, flags=...) at kernel/qeventloop.cpp:201
#46 0x01b1a69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#47 0x01d62577 in QApplication::exec () at kernel/qapplication.cpp:3579
#48 0x08067a51 in main (argc=5, argv=0xbf965de4) at ../../ktorrent/main.cpp:172

This bug may be a duplicate of or related to bug 247984.

Possible duplicates by query: bug 257314, bug 256822, bug 256345, bug 255263, bug 254562.

Reported using DrKonqi
Comment 1 Joris Guisson 2010-11-22 19:05:07 UTC
This will be fixed in 4.1.

As a workaround, you need to figure out which torrent is causing the problem, remove it and then reopen it again. If you select the same location the data will be found again and scanned. That should hopefully fix it.

*** This bug has been marked as a duplicate of bug 241598 ***