Bug 257105 - Kile crashes on exit or unexpectetly
Summary: Kile crashes on exit or unexpectetly
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: 2.0.85
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-17 00:17 UTC by gkalelis
Modified: 2010-11-17 02:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gkalelis 2010-11-17 00:17:45 UTC
Application: kile (2.0.85)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-25-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
When I am exiting kile it crashes. When I open it again the state it was is lost, i.e., I have to reoopen the last tex documents I opened again. The same happens some times unexpectetly, not on exit.

The crash can be reproduced some of the time.

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#5  KateSmartCursor::setPositionInternal (this=0x202d9f0, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#6  0x00007fef83bd3e9f in KateSmartCursor::translate (this=0x202d9f0, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#7  0x00007fef83bd9ecc in KateSmartGroup::translateChanged (this=0x1e9aa70, edit=...) at ../../kate/smart/katesmartmanager.cpp:467
#8  0x00007fef83bdd093 in KateSmartManager::slotTextChanged (this=0x2f4d9c0, edit=0x24461a0) at ../../kate/smart/katesmartmanager.cpp:371
#9  0x00007fef83bdd3ec in KateSmartManager::qt_metacall (this=0x2f4d9c0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff5d982680) at ./katesmartmanager.moc:80
#10 0x00007fef95e16e3f in QMetaObject::activate (sender=0x1e99510, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x202d9f0) at kernel/qobject.cpp:3293
#11 0x00007fef83b9a68f in KateEditHistory::editDone (this=0x7fff5d9823f0, _t1=0x24461a0) at ./kateedit.moc:84
#12 0x00007fef83b764ee in KateDocument::closeUrl (this=0x2f2eb90) at ../../kate/document/katedocument.cpp:2522
#13 0x00000000006dfae6 in _start ()

Possible duplicates by query: bug 248572, bug 245923, bug 244453, bug 235506, bug 222995.

Reported using DrKonqi
Comment 1 Dario Andres 2010-11-17 02:37:55 UTC
[Comment from a bug triager]
This bug was caused by an error in the text editor component of the KDE Platform. The issue was being tracked at bug 200450 and it is properly fixed on KDE SC 4.5.0 and later.
Thanks

*** This bug has been marked as a duplicate of bug 200450 ***