Bug 248572 - Kile crashs unexpectedly
Summary: Kile crashs unexpectedly
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: 2.0.85
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-21 07:32 UTC by Rodrigue C.
Modified: 2010-08-21 09:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rodrigue C. 2010-08-21 07:32:15 UTC
Application: kile (2.0.85)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
More often when typing text is in progress, kile crash and closed unexpectedly. I use gnome

The crash can be reproduced every time.

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#6  0x02cba6ba in KateSmartCursor::setPositionInternal (this=0x9c2f5a0, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#7  0x02cbaa92 in KateSmartCursor::translate (this=0x9c2f5a0, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#8  0x02cc0d2f in KateSmartGroup::translateChanged (this=0x91fb090, edit=...) at ../../kate/smart/katesmartmanager.cpp:467
#9  0x02cc3fef in KateSmartManager::slotTextChanged (this=0x91fb758, edit=0x95b8b48) at ../../kate/smart/katesmartmanager.cpp:371
#10 0x02cc437f in KateSmartManager::qt_metacall (this=0x91fb758, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbfae1438) at ./katesmartmanager.moc:80
#11 0x03d88c9a in QMetaObject::metacall (object=0x91fb758, cl=19, idx=5, argv=0xbfae1438) at kernel/qmetaobject.cpp:237
#12 0x03d973d5 in QMetaObject::activate (sender=0x91fb670, m=0x2dd6784, local_signal_index=0, argv=0xbfae1438) at kernel/qobject.cpp:3293
#13 0x02c7bb63 in KateEditHistory::editDone (this=0x91fb670, _t1=0x95b8b48) at ./kateedit.moc:84
#14 0x02c54eaa in KateDocument::closeUrl (this=0x92b1b38) at ../../kate/document/katedocument.cpp:2522
#15 0x082e52ad in _start ()

Possible duplicates by query: bug 245923, bug 244453, bug 235506, bug 222995, bug 217998.

Reported using DrKonqi
Comment 1 Michel Ludwig 2010-08-21 09:32:46 UTC

*** This bug has been marked as a duplicate of bug 200450 ***