Bug 244453 - Kile crashes when reloading with F5
Summary: Kile crashes when reloading with F5
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: 2.0.85
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-13 05:23 UTC by Ryan Reich
Modified: 2010-07-13 12:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Reich 2010-07-13 05:23:14 UTC
Application: kile (2.0.85)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
I am editing a largish file (~9000 lines) and I often have to save it and reload with F5 to prevent lag.  After a long enough editing session, Kile will unpredictably crash when I press F5.

The crash can be reproduced some of the time.

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#6  0x031786ba in KateSmartCursor::setPositionInternal (this=0xaf38a9c, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#7  0x03178a92 in KateSmartCursor::translate (this=0xaf38a9c, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#8  0x0317ed2f in KateSmartGroup::translateChanged (this=0xa6e1c10, edit=...) at ../../kate/smart/katesmartmanager.cpp:467
#9  0x03181fef in KateSmartManager::slotTextChanged (this=0xa6ca108, edit=0xdbb56e8) at ../../kate/smart/katesmartmanager.cpp:371
#10 0x0318237f in KateSmartManager::qt_metacall (this=0xa6ca108, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbf88e8d8) at ./katesmartmanager.moc:80
#11 0x0439cc9a in QMetaObject::metacall (object=0xa6ca108, cl=QMetaObject::ResetProperty, idx=5, argv=0xbf88e8d8) at kernel/qmetaobject.cpp:237
#12 0x043ab3d5 in QMetaObject::activate (sender=0xa7068e8, m=0x3294784, local_signal_index=0, argv=0xbf88e8d8) at kernel/qobject.cpp:3293
#13 0x03139b63 in KateEditHistory::editDone (this=0xa7068e8, _t1=0xdbb56e8) at ./kateedit.moc:84
#14 0x03112eaa in KateDocument::closeUrl (this=0xa6d5d18) at ../../kate/document/katedocument.cpp:2522
#15 0x0014ab86 in KParts::ReadOnlyPart::openUrl (this=0xa6d5d18, url=...) at ../../kparts/part.cpp:537
#16 0x03113b08 in KateDocument::documentReload (this=0xa6d5d18) at ../../kate/document/katedocument.cpp:4004
#17 0x031af49a in KateView::reloadFile (this=0xaf33988) at ../../kate/view/kateview.cpp:1025
#18 0x031ba232 in KateView::qt_metacall (this=0xaf33988, _c=QMetaObject::InvokeMetaMethod, _id=113, _a=0xbf88eda8) at ./kateview.moc:435
#19 0x0439cc9a in QMetaObject::metacall (object=0xaf33988, cl=QMetaObject::ResetProperty, idx=152, argv=0xbf88eda8) at kernel/qmetaobject.cpp:237
#20 0x043ab3d5 in QMetaObject::activate (sender=0xaf975f0, m=0x7977d58, local_signal_index=1, argv=0xbf88eda8) at kernel/qobject.cpp:3293
#21 0x07048bd9 in QAction::triggered (this=0xaf975f0, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#22 0x0704adcc in QAction::activate (this=0xaf975f0, event=QAction::Trigger) at kernel/qaction.cpp:1255
#23 0x0704c698 in QAction::event (this=0x0, e=0x0) at kernel/qaction.cpp:1181
#24 0x04e96d63 in KAction::event (this=0xaf975f0, event=0xbf88f2c8) at ../../kdeui/actions/kaction.cpp:129
#25 0x0704f4dc in QApplicationPrivate::notify_helper (this=0x88ea2f0, receiver=0xaf975f0, e=0xbf88f2c8) at kernel/qapplication.cpp:4300
#26 0x0705605e in QApplication::notify (this=0xbf8901bc, receiver=0xaf975f0, e=0xbf88f2c8) at kernel/qapplication.cpp:3704
#27 0x04f82f2a in KApplication::notify (this=0xbf8901bc, receiver=0xaf975f0, event=0xbf88f2c8) at ../../kdeui/kernel/kapplication.cpp:302
#28 0x04397a3b in QCoreApplication::notifyInternal (this=0xbf8901bc, receiver=0xaf975f0, event=0xbf88f2c8) at kernel/qcoreapplication.cpp:704
#29 0x0709134d in QCoreApplication::sendEvent (this=0x88ea39c, e=0xbf88f744) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#30 QShortcutMap::dispatchEvent (this=0x88ea39c, e=0xbf88f744) at kernel/qshortcutmap.cpp:879
#31 0x0709315e in QShortcutMap::tryShortcutEvent (this=0x88ea39c, o=0xaf389b8, e=0xbf88f744) at kernel/qshortcutmap.cpp:364
#32 0x07057e43 in QApplication::notify (this=0xbf8901bc, receiver=0xaf389b8, e=0xbf88f744) at kernel/qapplication.cpp:3746
#33 0x04f82f2a in KApplication::notify (this=0xbf8901bc, receiver=0xaf389b8, event=0xbf88f744) at ../../kdeui/kernel/kapplication.cpp:302
#34 0x04397a3b in QCoreApplication::notifyInternal (this=0xbf8901bc, receiver=0xaf389b8, event=0xbf88f744) at kernel/qcoreapplication.cpp:704
#35 0x070502be in QCoreApplication::sendSpontaneousEvent (receiver=0xaf389b8, event=0x0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#36 qt_sendSpontaneousEvent (receiver=0xaf389b8, event=0x0) at kernel/qapplication.cpp:5279
#37 0x07109d90 in QKeyMapper::sendKeyEvent (keyWidget=0xaf389b8, grab=false, type=QEvent::KeyPress, code=16777268, modifiers=..., text=..., autorepeat=<value optimized out>, 
    count=<value optimized out>, nativeScanCode=71, nativeVirtualKey=65474, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1861
#38 0x0710c2f5 in QKeyMapperPrivate::translateKeyEvent (this=0x8911218, keyWidget=0xaf389b8, event=0xbf88fe0c, grab=false) at kernel/qkeymapper_x11.cpp:1831
#39 0x070df757 in QApplication::x11ProcessEvent (this=0xbf8901bc, event=0xbf88fe0c) at kernel/qapplication_x11.cpp:3394
#40 0x0710f60a in x11EventSourceDispatch (s=0x88ed1a8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#41 0x014175e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#42 0x0141b2d8 in ?? () from /lib/libglib-2.0.so.0
#43 0x0141b4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#44 0x043c35d5 in QEventDispatcherGlib::processEvents (this=0x88cd178, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#45 0x0710f135 in QGuiEventDispatcherGlib::processEvents (this=0x88cd178, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#46 0x04396059 in QEventLoop::processEvents (this=0xbf890104, flags=) at kernel/qeventloop.cpp:149
#47 0x043964aa in QEventLoop::exec (this=0xbf890104, flags=...) at kernel/qeventloop.cpp:201
#48 0x0439a69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#49 0x0704f577 in QApplication::exec () at kernel/qapplication.cpp:3579
#50 0x081f7af3 in _start ()

This bug may be a duplicate of or related to bug 200450.

Possible duplicates by query: bug 235506, bug 222995, bug 217998, bug 217431, bug 217406.

Reported using DrKonqi
Comment 1 Nicolas L. 2010-07-13 12:32:14 UTC

*** This bug has been marked as a duplicate of bug 200450 ***