Bug 222995 - failure occurred when I closed kile
Summary: failure occurred when I closed kile
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-16 17:18 UTC by Mario
Modified: 2010-01-18 22:13 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mario 2010-01-16 17:18:29 UTC
Application that crashed: kile
Version of the application: 2.0.83
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
had an open project with multiple files open, when you close the bug report appeared. 

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#5  KateSmartCursor::setPositionInternal (this=0x2ffa5d8, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#6  0x00007f45410950cf in KateSmartCursor::translate (this=0x2ffa5d8, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#7  0x00007f454109a35c in KateSmartGroup::translateChanged (this=0x2472db0, edit=...) at ../../kate/smart/katesmartmanager.cpp:464
#8  0x00007f454109da9b in KateSmartManager::slotTextChanged (this=0x2184fc0, edit=0x345f0b0) at ../../kate/smart/katesmartmanager.cpp:368
#9  0x00007f454109de1c in KateSmartManager::qt_metacall (this=0x2184fc0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4d2838a0) at ./katesmartmanager.moc:74
#10 0x00007f454fdd8ddc in QMetaObject::activate (sender=0x2196c90, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x2ffa5d8) at kernel/qobject.cpp:3113
#11 0x00007f454106fb5f in KateEditHistory::editDone (this=0x7fff4d283600, _t1=0x345f0b0) at ./kateedit.moc:78
#12 0x00007f4541048b7b in KateDocument::closeUrl (this=0x2472b30) at ../../kate/document/katedocument.cpp:3606
#13 0x00000000006cd30d in _start ()

This bug may be a duplicate of or related to bug 208033

Reported using DrKonqi
Comment 1 Dario Andres 2010-01-18 22:13:10 UTC
This is a bug in the KatePart, fixed in KDE SC 4.4 Regards

*** This bug has been marked as a duplicate of bug 200450 ***