Bug 245923 - Kile crashes on quitting
Summary: Kile crashes on quitting
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: 2.0.85
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-27 17:59 UTC by luca.naso
Modified: 2010-07-27 18:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description luca.naso 2010-07-27 17:59:41 UTC
Application: kile (2.0.85)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-23-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
Kile crasehes everytime I quite, regardless of other processes.

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#5  KateSmartCursor::setPositionInternal (this=0x3d98ea8, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#6  0x00007fae5ab59e9f in KateSmartCursor::translate (this=0x3d98ea8, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#7  0x00007fae5ab5fecc in KateSmartGroup::translateChanged (this=0x3e18b30, edit=...) at ../../kate/smart/katesmartmanager.cpp:467
#8  0x00007fae5ab63093 in KateSmartManager::slotTextChanged (this=0x3e190a0, edit=0x3a2e6b0) at ../../kate/smart/katesmartmanager.cpp:371
#9  0x00007fae5ab633ec in KateSmartManager::qt_metacall (this=0x3e190a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffda7cbe00) at ./katesmartmanager.moc:80
#10 0x00007fae6ce7ee3f in QMetaObject::activate (sender=0x3dea080, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x3d98ea8) at kernel/qobject.cpp:3293
#11 0x00007fae5ab2068f in KateEditHistory::editDone (this=0x7fffda7cbb70, _t1=0x3a2e6b0) at ./kateedit.moc:84
#12 0x00007fae5aafc4ee in KateDocument::closeUrl (this=0x3dbfcb0) at ../../kate/document/katedocument.cpp:2522
#13 0x00000000006dfae6 in _start ()

Possible duplicates by query: bug 244453, bug 235506, bug 222995, bug 217998, bug 217431.

Reported using DrKonqi
Comment 1 Nicolas L. 2010-07-27 18:09:24 UTC

*** This bug has been marked as a duplicate of bug 200450 ***