Bug 235506 - Kile crashes while idle
Summary: Kile crashes while idle
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: 2.0.85
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-27 01:06 UTC by Tim Henderson
Modified: 2010-05-30 23:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Henderson 2010-04-27 01:06:08 UTC
Application: kile (2.0.85)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-21-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
This has happened several times to me now. While using kile I may be typing in the document, or it may simply be open while I am looking at another application, kile seg faults. 

The crash can be reproduced some of the time.

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f811bc42760 (LWP 1926))]

Thread 2 (Thread 0x7f81089cd710 (LWP 1927)):
#0  0x00007f8116955f53 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f81139e84a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f81139e88fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f81179d9566 in QEventDispatcherGlib::processEvents (this=0x1959b00, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f81179ae992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f81179aed6c in QEventLoop::exec (this=0x7f81089ccdb0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f81178b8d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f811798f178 in QInotifyFileSystemWatcherEngine::run (this=0x1946bf0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f81178bb775 in QThreadPrivate::start (arg=0x1946bf0) at thread/qthread_unix.cpp:248
#9  0x00007f811762b9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007f811696269d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f811bc42760 (LWP 1926)):
[KCrash Handler]
#5  KateSmartCursor::setPositionInternal (this=0x3de82f0, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#6  0x00007f810ee98e9f in KateSmartCursor::translate (this=0x3de82f0, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#7  0x00007f810ee9eecc in KateSmartGroup::translateChanged (this=0x1c38890, edit=...) at ../../kate/smart/katesmartmanager.cpp:467
#8  0x00007f810eea2093 in KateSmartManager::slotTextChanged (this=0x1c3add0, edit=0x356b470) at ../../kate/smart/katesmartmanager.cpp:371
#9  0x00007f810eea23ec in KateSmartManager::qt_metacall (this=0x1c3add0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffc2cc6af0) at ./katesmartmanager.moc:80
#10 0x00007f81179c2e3f in QMetaObject::activate (sender=0x1bfa390, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x3de82f0) at kernel/qobject.cpp:3293
#11 0x00007f810ee5f68f in KateEditHistory::editDone (this=0x7fffc2cc6860, _t1=0x356b470) at ./kateedit.moc:84
#12 0x00007f810ee3b4ee in KateDocument::closeUrl (this=0x1c394a0) at ../../kate/document/katedocument.cpp:2522
#13 0x00000000006dfae6 in _start ()

Possible duplicates by query: bug 222995, bug 217998, bug 217431, bug 217406, bug 215847.

Reported using DrKonqi
Comment 1 Michel Ludwig 2010-05-30 23:23:16 UTC

*** This bug has been marked as a duplicate of bug 200450 ***