Bug 252261 - Crash after finished moving files
Summary: Crash after finished moving files
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-24 16:33 UTC by Dante
Modified: 2010-09-24 17:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dante 2010-09-24 16:33:30 UTC
Application: dolphin (1.4)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.32.21-168.fc12.x86_64 x86_64
Distribution: "Fedora release 12 (Constantine)"

-- Information about the crash:
After moving some directories. when Dolphin finished move, crashed as soon as it finished.


 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fbe9ecc2840 (LWP 2108))]

Thread 2 (Thread 0x7fbe94c11710 (LWP 2861)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:211
#1  0x000000338cc13631 in metronom_sync_loop (this=0x2683280) at metronom.c:870
#2  0x0000003f4d206a3a in start_thread (arg=0x7fbe94c11710) at pthread_create.c:297
#3  0x0000003f4cade77d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fbe9ecc2840 (LWP 2108)):
[KCrash Handler]
#5  0x0000003ea4334423 in KFileItem::isDir (this=0x1d409b0) at /usr/src/debug/kdelibs-4.4.5/kio/kio/kfileitem.cpp:975
#6  0x0000003ea4324628 in KDirModelPrivate::removeFromNodeHash (this=0x1d60a80, node=0x1d409b0, url=<value optimized out>) at /usr/src/debug/kdelibs-4.4.5/kio/kio/kdirmodel.cpp:200
#7  0x0000003ea432553b in KDirModelPrivate::_k_slotDeleteItems (this=0x1d60a80, items=<value optimized out>) at /usr/src/debug/kdelibs-4.4.5/kio/kio/kdirmodel.cpp:490
#8  0x0000003ea4325b02 in KDirModel::qt_metacall (this=0x1d5cc70, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffdb98c730)
    at /usr/src/debug/kdelibs-4.4.5/x86_64-redhat-linux-gnu/kio/kdirmodel.moc:89
#9  0x0000003ea6237a90 in DolphinModel::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libdolphinprivate.so.4
#10 0x0000003c8e566606 in QMetaObject::activate (sender=0x1d5ba00, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffdb98c730) at kernel/qobject.cpp:3295
#11 0x0000003ea43089a5 in KDirLister::itemsDeleted (this=<value optimized out>, _t1=...) at /usr/src/debug/kdelibs-4.4.5/x86_64-redhat-linux-gnu/kio/kdirlister.moc:295
#12 0x0000003ea4309681 in KDirLister::Private::emitItemsDeleted (this=0x1d5cd40, _items=<value optimized out>) at /usr/src/debug/kdelibs-4.4.5/kio/kio/kdirlister.cpp:2407
#13 0x0000003ea4314b8e in KDirListerCache::itemsDeleted (this=0x1d0f540, listers=<value optimized out>, deletedItems=...) at /usr/src/debug/kdelibs-4.4.5/kio/kio/kdirlister.cpp:1755
#14 0x0000003ea431541a in KDirListerCache::slotFilesRemoved (this=<value optimized out>, fileList=<value optimized out>) at /usr/src/debug/kdelibs-4.4.5/kio/kio/kdirlister.cpp:833
#15 0x0000003ea43158b4 in KDirListerCache::slotFilesRemoved (this=0x1d0f540, fileList=<value optimized out>) at /usr/src/debug/kdelibs-4.4.5/kio/kio/kdirlister.cpp:788
#16 0x0000003ea431c8c0 in KDirListerCache::qt_metacall (this=0x1d0f540, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffdb98cbc0)
    at /usr/src/debug/kdelibs-4.4.5/x86_64-redhat-linux-gnu/kio/kdirlister_p.moc:98
#17 0x0000003c8e566606 in QMetaObject::activate (sender=0x1d0fe50, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffdb98cbc0) at kernel/qobject.cpp:3295
#18 0x0000003ea4326555 in OrgKdeKDirNotifyInterface::FilesRemoved (this=<value optimized out>, _t1=...) at /usr/src/debug/kdelibs-4.4.5/x86_64-redhat-linux-gnu/kio/kdirnotify.moc:131
#19 0x0000003ea43266c0 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x1d0fe50, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffdb98ce30)
    at /usr/src/debug/kdelibs-4.4.5/x86_64-redhat-linux-gnu/kio/kdirnotify.moc:89
#20 0x0000003c90021eb6 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#21 0x0000003c9002c07f in QDBusCallDeliveryEvent::placeMetaCall (this=0x0, object=<value optimized out>) at qdbusintegrator_p.h:101
#22 0x0000003c8e562c81 in QObject::event (this=0x1d0fe50, e=0x20669b0) at kernel/qobject.cpp:1248
#23 0x00000030d89ab36c in QApplicationPrivate::notify_helper (this=0x1af35e0, receiver=0x1d0fe50, e=0x20669b0) at kernel/qapplication.cpp:4306
#24 0x00000030d89b173b in QApplication::notify (this=<value optimized out>, receiver=0x1d0fe50, e=0x20669b0) at kernel/qapplication.cpp:4189
#25 0x0000003ea3c06ac6 in KApplication::notify (this=0x7fffdb98d920, receiver=0x1d0fe50, event=0x20669b0) at /usr/src/debug/kdelibs-4.4.5/kdeui/kernel/kapplication.cpp:302
#26 0x0000003c8e5539cc in QCoreApplication::notifyInternal (this=0x7fffdb98d920, receiver=0x1d0fe50, event=0x20669b0) at kernel/qcoreapplication.cpp:726
#27 0x0000003c8e555ac4 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1acb540) at kernel/qcoreapplication.h:215
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1acb540) at kernel/qcoreapplication.cpp:1367
#29 0x0000003c8e5798b3 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#30 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#31 0x0000003f4e23923e in g_main_dispatch (context=0x1af7920) at gmain.c:1960
#32 IA__g_main_context_dispatch (context=0x1af7920) at gmain.c:2513
#33 0x0000003f4e23cc28 in g_main_context_iterate (context=0x1af7920, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2591
#34 0x0000003f4e23cd4a in IA__g_main_context_iteration (context=0x1af7920, may_block=1) at gmain.c:2654
#35 0x0000003c8e5793f3 in QEventDispatcherGlib::processEvents (this=0x1acac60, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#36 0x00000030d8a4a86e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#37 0x0000003c8e552412 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#38 0x0000003c8e5526dc in QEventLoop::exec (this=0x7fffdb98d870, flags=...) at kernel/qeventloop.cpp:201
#39 0x0000003c8e555dab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#40 0x00000000004379d5 in _start ()

This bug may be a duplicate of or related to bug 196695.

Possible duplicates by query: bug 242155, bug 239929, bug 232710, bug 227848, bug 226338.

Reported using DrKonqi
Comment 1 Frank Reininghaus 2010-09-24 17:16:52 UTC
Thanks for the bug report! This issue has been reported already. Unfortunately,
we don't know yet what the cause of the bug is.

*** This bug has been marked as a duplicate of bug 196695 ***