Bug 239929 - Dolphin Crash when copying data
Summary: Dolphin Crash when copying data
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-28 23:28 UTC by Hawkeye
Modified: 2010-05-30 18:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hawkeye 2010-05-28 23:28:45 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.32-1-mepis-smp i686
Distribution: MEPIS 8.5 (upgradable from Debian lenny)

What I was doing when the application crashed:
I had 2 dophin sessions open, and was trying to copy and paste from 2 different drive locations. Dolphin suddenly crashed.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 0 (LWP 5630)]

Thread 2 (Thread 0xb25c4b90 (LWP 7847)):
#0  0xb57adc08 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0xb5ed0af4 in pthread_cond_timedwait () from /lib/libc.so.6
#2  0xb32db92f in ?? () from /usr/lib/libxine.so.1

Thread 1 (Thread 0xb552c6c0 (LWP 5630)):
[KCrash Handler]
#5  0xb76e4058 in KFileItem::isDir (this=0x899b058) at ../../kio/kio/kfileitem.cpp:969
#6  0xb76d0942 in KDirModelPrivate::removeFromNodeHash (this=0x8bf66a8, node=0x899b058, url=@0xbf999ad4) at ../../kio/kio/kdirmodel.cpp:200
#7  0xb76d1a00 in KDirModelPrivate::_k_slotDeleteItems (this=0x8bf66a8, items=@0xbf999c38) at ../../kio/kio/kdirmodel.cpp:487
#8  0xb76d33e5 in KDirModel::qt_metacall (this=0x8be7ca0, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xbf999bfc) at ./kdirmodel.moc:83
#9  0xb6192cf8 in QMetaObject::activate (sender=0x8bf5f68, from_signal_index=17, to_signal_index=17, argv=0xbf999bfc) at kernel/qobject.cpp:3112
#10 0xb6193982 in QMetaObject::activate (sender=0x8bf5f68, m=0x80b5590, local_signal_index=13, argv=0xbf999bfc) at kernel/qobject.cpp:3186
#11 0xb76b5dd3 in KDirLister::itemsDeleted (this=0x8bf5f68, _t1=@0xbf999c38) at ./kdirlister.moc:289
#12 0xb76b6ce1 in KDirLister::Private::emitItemsDeleted (this=0x8bf6588, _items=@0x8bd4eb4) at ../../kio/kio/kdirlister.cpp:2351
#13 0xb76c1470 in KDirListerCache::itemsDeleted (this=0x894ee68, listers=@0x94b9228, deletedItems=@0x8bd4eb4) at ../../kio/kio/kdirlister.cpp:1697
#14 0xb76c1c92 in KDirListerCache::slotFilesRemoved (this=0x894ee68, fileList=@0xbf999e2c) at ../../kio/kio/kdirlister.cpp:808
#15 0xb76c20b8 in KDirListerCache::slotFilesRemoved (this=0x894ee68, fileList=@0x9390090) at ../../kio/kio/kdirlister.cpp:763
#16 0xb76c955a in KDirListerCache::qt_metacall (this=0x894ee68, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf999f2c) at ./kdirlister_p.moc:92
#17 0xb6192cf8 in QMetaObject::activate (sender=0x895fd88, from_signal_index=9, to_signal_index=9, argv=0xbf999f2c) at kernel/qobject.cpp:3112
#18 0xb6193982 in QMetaObject::activate (sender=0x895fd88, m=0xb78421d4, local_signal_index=4, argv=0xbf999f2c) at kernel/qobject.cpp:3186
#19 0xb76d4f73 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0x895fd88, _t1=@0x9390090) at ./kdirnotify.moc:125
#20 0xb76d5172 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x895fd88, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbf99a018) at ./kdirnotify.moc:83
#21 0xb6c5d0b5 in QDBusConnectionPrivate::deliverCall (this=0x878f220, object=0x895fd88, msg=@0x94b85ec, metaTypes=@0x94b85f0, slotIdx=9) at qdbusintegrator.cpp:891
#22 0xb6c65087 in QDBusCallDeliveryEvent::placeMetaCall (this=0x94b85c0, object=0x895fd88) at qdbusintegrator_p.h:101
#23 0xb618def0 in QObject::event (this=0x895fd88, e=0x94b85c0) at kernel/qobject.cpp:1110
#24 0xb63b5c2c in QApplicationPrivate::notify_helper (this=0x87a3f70, receiver=0x895fd88, e=0x94b85c0) at kernel/qapplication.cpp:4065
#25 0xb63bdf2e in QApplication::notify (this=0xbf99a7c4, receiver=0x895fd88, e=0x94b85c0) at kernel/qapplication.cpp:3605
#26 0xb70c53fd in KApplication::notify (this=0xbf99a7c4, receiver=0x895fd88, event=0x94b85c0) at ../../kdeui/kernel/kapplication.cpp:302
#27 0xb617d8bb in QCoreApplication::notifyInternal (this=0xbf99a7c4, receiver=0x895fd88, event=0x94b85c0) at kernel/qcoreapplication.cpp:610
#28 0xb617e515 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8778af8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#29 0xb617e70d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#30 0xb61a92df in postEventSourceDispatch (s=0x8797d58) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#31 0xb57f73b8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#32 0xb57fab23 in ?? () from /usr/lib/libglib-2.0.so.0
#33 0x08797cd8 in ?? ()
#34 0x00000000 in ?? ()

Reported using DrKonqi
Comment 1 Frank Reininghaus 2010-05-30 18:29:48 UTC
Thanks for the bug report! This issue has been reported already. Unfortunately, we don't know yet what the cause of the bug is.

*** This bug has been marked as a duplicate of bug 196695 ***