Bug 232710 - i "move to trash" pendrive's data
Summary: i "move to trash" pendrive's data
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-30 16:00 UTC by Alfonso Gamboa
Modified: 2010-03-31 14:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alfonso Gamboa 2010-03-30 16:00:39 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-20-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
i "move to trash" pendrive's data

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  0x00007f08ff8e2d03 in KFileItem::isDir (this=0x20d0960) at ../../kio/kio/kfileitem.cpp:969
#6  0x00007f08ff8d2198 in KDirModelPrivate::removeFromNodeHash (this=0x20cdcd0, node=0x20d0960, url=...) at ../../kio/kio/kdirmodel.cpp:200
#7  0x00007f08ff8d30ab in KDirModelPrivate::_k_slotDeleteItems (this=0x20cdcd0, items=<value optimized out>) at ../../kio/kio/kdirmodel.cpp:487
#8  0x00007f08ff8d4b82 in KDirModel::qt_metacall (this=0x20d1f90, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff26b20240) at ./kdirmodel.moc:83
#9  0x00007f08fc849ddc in QMetaObject::activate (sender=0x20d1ee0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#10 0x00007f08ff8b8895 in KDirLister::itemsDeleted (this=0x20d0960, _t1=<value optimized out>) at ./kdirlister.moc:289
#11 0x00007f08ff8b95d1 in KDirLister::Private::emitItemsDeleted (this=0x20d1970, _items=<value optimized out>) at ../../kio/kio/kdirlister.cpp:2351
#12 0x00007f08ff8c857e in KDirListerCache::itemsDeleted (this=0x20686c0, listers=<value optimized out>, deletedItems=...) at ../../kio/kio/kdirlister.cpp:1697
#13 0x00007f08ff8c9fca in KDirListerCache::slotFilesRemoved (this=0x20686c0, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:808
#14 0x00007f08ff8ca454 in KDirListerCache::slotFilesRemoved (this=0x20686c0, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:763
#15 0x00007f08ff8cadb0 in KDirListerCache::qt_metacall (this=0x20686c0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff26b206c0) at ./kdirlister_p.moc:92
#16 0x00007f08fc849ddc in QMetaObject::activate (sender=0x2074720, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#17 0x00007f08ff8d6115 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0x20d0960, _t1=<value optimized out>) at ./kdirnotify.moc:125
#18 0x00007f08ff8d6290 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x2074720, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff26b20980) at ./kdirnotify.moc:83
#19 0x00007f08fd6ffad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#20 0x00007f08fd706def in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#21 0x00007f08fc8440f9 in QObject::event (this=0x2074720, e=0x31d7db0) at kernel/qobject.cpp:1111
#22 0x00007f08fccc7efc in QApplicationPrivate::notify_helper (this=0x1e62600, receiver=0x2074720, e=0x31d7db0) at kernel/qapplication.cpp:4056
#23 0x00007f08fcccf1ce in QApplication::notify (this=0x7fff26b21320, receiver=0x2074720, e=0x31d7db0) at kernel/qapplication.cpp:4021
#24 0x00007f08fdffcab6 in KApplication::notify (this=0x7fff26b21320, receiver=0x2074720, event=0x31d7db0) at ../../kdeui/kernel/kapplication.cpp:302
#25 0x00007f08fc834c2c in QCoreApplication::notifyInternal (this=0x7fff26b21320, receiver=0x2074720, event=0x31d7db0) at kernel/qcoreapplication.cpp:610
#26 0x00007f08fc83580a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1e364d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1e364d0) at kernel/qcoreapplication.cpp:1247
#28 0x00007f08fc85d533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#29 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#30 0x00007f08f8353bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#31 0x00007f08f8357598 in ?? () from /lib/libglib-2.0.so.0
#32 0x00007f08f83576c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#33 0x00007f08fc85d1a6 in QEventDispatcherGlib::processEvents (this=0x1e35d20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#34 0x00007f08fcd5c4be in QGuiEventDispatcherGlib::processEvents (this=0x20d0960, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#35 0x00007f08fc833532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#36 0x00007f08fc833904 in QEventLoop::exec (this=0x7fff26b21270, flags=) at kernel/qeventloop.cpp:201
#37 0x00007f08fc835ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#38 0x0000000000439555 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../../apps/dolphin/src/main.cpp:94

This bug may be a duplicate of or related to bug 224009

Reported using DrKonqi
Comment 1 Dario Andres 2010-03-31 14:54:24 UTC
This is being tracked at bug 196695. Seems to be fixed in KDE SC 4.4.
Regards

*** This bug has been marked as a duplicate of bug 196695 ***