Bug 227848 - crash when moving folder from dolphin to konqueror
Summary: crash when moving folder from dolphin to konqueror
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-20 21:11 UTC by racecar56
Modified: 2010-02-20 21:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description racecar56 2010-02-20 21:11:42 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-19-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I was moving a folder (with JPEG images) from a Dolphin window to a Konqueror window, and Dolphin crashed

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f508630cd03 in KFileItem::isDir (this=0xf63e00) at ../../kio/kio/kfileitem.cpp:969
#6  0x00007f50862fc198 in KDirModelPrivate::removeFromNodeHash (this=0xf72e50, node=0xf63e00, url=...) at ../../kio/kio/kdirmodel.cpp:200
#7  0x00007f50862fd0ab in KDirModelPrivate::_k_slotDeleteItems (this=0xf72e50, items=<value optimized out>) at ../../kio/kio/kdirmodel.cpp:487
#8  0x00007f50862feb82 in KDirModel::qt_metacall (this=0xf76600, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffdbf27c10) at ./kdirmodel.moc:83
#9  0x00007f5083273ddc in QMetaObject::activate (sender=0xf763e0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#10 0x00007f50862e2895 in KDirLister::itemsDeleted (this=0xf63e00, _t1=<value optimized out>) at ./kdirlister.moc:289
#11 0x00007f50862e35d1 in KDirLister::Private::emitItemsDeleted (this=0xf76490, _items=<value optimized out>) at ../../kio/kio/kdirlister.cpp:2351
#12 0x00007f50862f257e in KDirListerCache::itemsDeleted (this=0xf20d00, listers=<value optimized out>, deletedItems=...) at ../../kio/kio/kdirlister.cpp:1697
#13 0x00007f50862f3fca in KDirListerCache::slotFilesRemoved (this=0xf20d00, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:808
#14 0x00007f50862f4454 in KDirListerCache::slotFilesRemoved (this=0xf20d00, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:763
#15 0x00007f50862f4db0 in KDirListerCache::qt_metacall (this=0xf20d00, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffdbf28090) at ./kdirlister_p.moc:92
#16 0x00007f5083273ddc in QMetaObject::activate (sender=0xf211e0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#17 0x00007f5086300115 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0xf63e00, _t1=<value optimized out>) at ./kdirnotify.moc:125
#18 0x00007f5086300290 in OrgKdeKDirNotifyInterface::qt_metacall (this=0xf211e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffdbf28350) at ./kdirnotify.moc:83
#19 0x00007f5084129ad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#20 0x00007f5084130def in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#21 0x00007f508326e0f9 in QObject::event (this=0xf211e0, e=0x122b0c0) at kernel/qobject.cpp:1111
#22 0x00007f50836f1efc in QApplicationPrivate::notify_helper (this=0xce5f30, receiver=0xf211e0, e=0x122b0c0) at kernel/qapplication.cpp:4056
#23 0x00007f50836f91ce in QApplication::notify (this=0x7fffdbf28cf0, receiver=0xf211e0, e=0x122b0c0) at kernel/qapplication.cpp:4021
#24 0x00007f5084a26ab6 in KApplication::notify (this=0x7fffdbf28cf0, receiver=0xf211e0, event=0x122b0c0) at ../../kdeui/kernel/kapplication.cpp:302
#25 0x00007f508325ec2c in QCoreApplication::notifyInternal (this=0x7fffdbf28cf0, receiver=0xf211e0, event=0x122b0c0) at kernel/qcoreapplication.cpp:610
#26 0x00007f508325f80a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0xcb74d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0xcb74d0) at kernel/qcoreapplication.cpp:1247
#28 0x00007f5083287533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#29 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#30 0x00007f507ed7cbce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#31 0x00007f507ed80598 in ?? () from /lib/libglib-2.0.so.0
#32 0x00007f507ed806c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#33 0x00007f50832871a6 in QEventDispatcherGlib::processEvents (this=0xcb6d20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#34 0x00007f50837864be in QGuiEventDispatcherGlib::processEvents (this=0xf63e00, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#35 0x00007f508325d532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#36 0x00007f508325d904 in QEventLoop::exec (this=0x7fffdbf28c40, flags=) at kernel/qeventloop.cpp:201
#37 0x00007f508325fab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#38 0x0000000000439555 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2010-02-20 21:50:40 UTC
This is being tracked at bug 196695. Thanks

*** This bug has been marked as a duplicate of bug 196695 ***