Bug 242155 - Dolphin crashes when moving files from a webfolder
Summary: Dolphin crashes when moving files from a webfolder
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-19 12:19 UTC by Mathias D
Modified: 2010-06-19 13:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias D 2010-06-19 12:19:51 UTC
Application: dolphin (1.4)
KDE Platform Version: 4.4.4 (KDE 4.4.4)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-22-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
I tryed to move files from an webfolder on GMX Mailprovider to local folder. I had the same error when I did sth similar on another computer.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe560d68760 (LWP 3148))]

Thread 2 (Thread 0x7fe54dcd9710 (LWP 3150)):
#0  0x00007fe55c9eaf53 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe558e0e4a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fe558e0e8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fe55d13a406 in QEventDispatcherGlib::processEvents (this=0x20434f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007fe55d10f6c2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fe55d10fa9c in QEventLoop::exec (this=0x7fe54dcd8db0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fe55d01e8db in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007fe55d0efdd8 in QInotifyFileSystemWatcherEngine::run (this=0x21a99d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe55d020f95 in QThreadPrivate::start (arg=0x21a99d0) at thread/qthread_unix.cpp:248
#9  0x00007fe55a15b9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007fe55c9f76cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe560d68760 (LWP 3148)):
[KCrash Handler]
#5  0x00007fe55ef66cf3 in KFileItem::isDir (this=0x1e3cb90) at ../../kio/kio/kfileitem.cpp:975
#6  0x00007fe55ef572d8 in KDirModelPrivate::removeFromNodeHash (this=0x1e55d80, node=0x1e3cb90, url=...) at ../../kio/kio/kdirmodel.cpp:200
#7  0x00007fe55ef581fb in KDirModelPrivate::_k_slotDeleteItems (this=0x1e55d80, items=<value optimized out>) at ../../kio/kio/kdirmodel.cpp:490
#8  0x00007fe55ef587c2 in KDirModel::qt_metacall (this=0x1e55a10, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffe1a027a0) at ./kdirmodel.moc:89
#9  0x00007fe5601ea2b0 in DolphinModel::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdolphinprivate.so.4
#10 0x00007fe55d124036 in QMetaObject::activate (sender=0x1e594c0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3295
#11 0x00007fe55ef3a645 in KDirLister::itemsDeleted (this=0x1e3cb90, _t1=<value optimized out>) at ./kdirlister.moc:295
#12 0x00007fe55ef3b4d1 in KDirLister::Private::emitItemsDeleted (this=0x1e59990, _items=<value optimized out>) at ../../kio/kio/kdirlister.cpp:2407
#13 0x00007fe55ef46b7e in KDirListerCache::itemsDeleted (this=0x1e00a10, listers=<value optimized out>, deletedItems=...) at ../../kio/kio/kdirlister.cpp:1755
#14 0x00007fe55ef485fa in KDirListerCache::slotFilesRemoved (this=0x1e00a10, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:833
#15 0x00007fe55ef48a94 in KDirListerCache::slotFilesRemoved (this=0x1e00a10, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:788
#16 0x00007fe55ef4f440 in KDirListerCache::qt_metacall (this=0x1e00a10, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffe1a02c30) at ./kdirlister_p.moc:98
#17 0x00007fe55d124036 in QMetaObject::activate (sender=0x1cb06d0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3295
#18 0x00007fe55ef59215 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0x1e3cb90, _t1=<value optimized out>) at ./kdirnotify.moc:131
#19 0x00007fe55ef59390 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x1cb06d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffe1a02ea0) at ./kdirnotify.moc:89
#20 0x00007fe55d44b5a6 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#21 0x00007fe55d455fef in QDBusCallDeliveryEvent::placeMetaCall (this=0x0, object=0x1e3cb90) at qdbusintegrator_p.h:101
#22 0x00007fe55d120b79 in QObject::event (this=0x1cb06d0, e=0x27947e0) at kernel/qobject.cpp:1248
#23 0x00007fe55dcffc0c in QApplicationPrivate::notify_helper (this=0x1b6b2a0, receiver=0x1cb06d0, e=0x27947e0) at kernel/qapplication.cpp:4302
#24 0x00007fe55dd060eb in QApplication::notify (this=0x7fffe1a03990, receiver=0x1cb06d0, e=0x27947e0) at kernel/qapplication.cpp:4185
#25 0x00007fe55ea0e606 in KApplication::notify (this=0x7fffe1a03990, receiver=0x1cb06d0, event=0x27947e0) at ../../kdeui/kernel/kapplication.cpp:302
#26 0x00007fe55d110d9c in QCoreApplication::notifyInternal (this=0x7fffe1a03990, receiver=0x1cb06d0, event=0x27947e0) at kernel/qcoreapplication.cpp:726
#27 0x00007fe55d114454 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1b3ec30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1b3ec30) at kernel/qcoreapplication.cpp:1367
#29 0x00007fe55d13a873 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#30 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#31 0x00007fe558e0a8c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#32 0x00007fe558e0e748 in ?? () from /lib/libglib-2.0.so.0
#33 0x00007fe558e0e8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#34 0x00007fe55d13a3b3 in QEventDispatcherGlib::processEvents (this=0x1b3e770, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#35 0x00007fe55ddb018e in QGuiEventDispatcherGlib::processEvents (this=0x1e3cb90, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#36 0x00007fe55d10f6c2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#37 0x00007fe55d10fa9c in QEventLoop::exec (this=0x7fffe1a038e0, flags=) at kernel/qeventloop.cpp:201
#38 0x00007fe55d11473b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#39 0x000000000043b1c5 in _start ()

This bug may be a duplicate of or related to bug 196695.

Possible duplicates by query: bug 239929, bug 232710, bug 227848, bug 226338, bug 225100.

Reported using DrKonqi
Comment 1 Nicolas L. 2010-06-19 13:41:42 UTC

*** This bug has been marked as a duplicate of bug 196695 ***