Bug 217431 - the program was abruptly shut down
Summary: the program was abruptly shut down
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-05 13:20 UTC by Mario
Modified: 2009-12-18 21:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mario 2009-12-05 13:20:30 UTC
Application that crashed: kile
Version of the application: 2.0.83
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-15-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I had only open kile an  Adobe Reader and the program was closed when I tried to use QuikBuild

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#6  0x02985e6a in ?? () from /usr/lib/kde4/katepart.so
#7  0x02986595 in ?? () from /usr/lib/kde4/katepart.so
#8  0x029ddf20 in ?? () from /usr/lib/kde4/katepart.so
#9  0x029e003e in ?? () from /usr/lib/kde4/katepart.so
#10 0x029bb2bb in ?? () from /usr/lib/kde4/katepart.so
#11 0x029c6238 in ?? () from /usr/lib/kde4/katepart.so
#12 0x0440b263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#13 0x0440b6d8 in QMetaObject::activate(QObject*, QMetaObject const*, int, int, void**) () from /usr/lib/libQtCore.so.4
#14 0x012789b1 in QAction::triggered(bool) () from /usr/lib/libQtGui.so.4
#15 0x01279f32 in QAction::activate(QAction::ActionEvent) () from /usr/lib/libQtGui.so.4
#16 0x0127ca18 in QAction::event(QEvent*) () from /usr/lib/libQtGui.so.4
#17 0x0396deb3 in KAction::event(QEvent*) () from /usr/lib/libkdeui.so.5
#18 0x0127ef54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#19 0x0128667c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0x03a54bfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#21 0x043f56cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#22 0x012b7dfd in ?? () from /usr/lib/libQtGui.so.4
#23 0x012b9c7e in ?? () from /usr/lib/libQtGui.so.4
#24 0x01287a0d in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#25 0x03a54bfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#26 0x043f56cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#27 0x0127fe2e in ?? () from /usr/lib/libQtGui.so.4
#28 0x0131c440 in ?? () from /usr/lib/libQtGui.so.4
#29 0x0131e989 in ?? () from /usr/lib/libQtGui.so.4
#30 0x012f2ed7 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#31 0x01320502 in ?? () from /usr/lib/libQtGui.so.4
#32 0x035f0e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#33 0x035f4720 in ?? () from /lib/libglib-2.0.so.0
#34 0x035f4853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#35 0x0442002c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#36 0x0131fbe5 in ?? () from /usr/lib/libQtGui.so.4
#37 0x043f3c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#38 0x043f40ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#39 0x043f653f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#40 0x0127edd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#41 0x081ee3f3 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-05 15:33:12 UTC
- If you can reproduce the crash at will (or you experience this regularly), can you install the "kdelibs5-dbg" package and post a complete backtrace here?
Thanks
Comment 2 Mario 2009-12-05 23:30:22 UTC
I installed "kdelibs5-dbg" package but do not know what to do now.


Por tu he mail deduzco que hablas español.


He instalado el paquete que me dijiste, pero ahora no tengo ni idea de que
hacer para lo del backtrace.


Si me das intrucciones, con gusto lo haré.




2009/12/5 Dario Andres <andresbajotierra@gmail.com>

> https://bugs.kde.org/show_bug.cgi?id=217431
>
>
> Dario Andres <andresbajotierra@gmail.com> changed:
>
>           What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>             Status|UNCONFIRMED                 |NEEDSINFO
>                 CC|                            |andresbajotierra@gmail.com
>         Resolution|                            |WAITINGFORINFO
>
>
>
>
> --- Comment #1 from Dario Andres <andresbajotierra gmail com>  2009-12-05
> 15:33:12 ---
> - If you can reproduce the crash at will (or you experience this
> regularly),
> can you install the "kdelibs5-dbg" package and post a complete backtrace
> here?
> Thanks
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 3 Dario Andres 2009-12-05 23:32:50 UTC
Intenta repetir la situación antes del primer fallo. De esta forma tal vez puedas hacer que Kile se cierre de nuevo. Si eso sucede y el diálogo manejador de errores aparece, debes hacer click en la pestaña "Información para desarrolladores" para luego copiar y pegar esa información aquí.
Saludos
Comment 4 Mario 2009-12-18 21:43:57 UTC
Bueno, este es el informe que generó el manejador de fallos. kile se
cerró inesperadamente y guardé el reporte que adjunto.

Espero que este si sea útil.

Estaré atento.


Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#6  0x01cc0e6a in KateSmartCursor::setPositionInternal
(this=0xa81ba78, pos=..., internal=true) at
../../kate/smart/katesmartcursor.cpp:186
#7  0x01cc1242 in KateSmartCursor::translate (this=0xa81ba78,
edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#8  0x01cc66af in KateSmartGroup::translateChanged (this=0xa5715b0,
edit=...) at ../../kate/smart/katesmartmanager.cpp:464
#9  0x01cc9fcf in KateSmartManager::slotTextChanged (this=0xa9989d0,
edit=0xa3dd668) at ../../kate/smart/katesmartmanager.cpp:368
#10 0x01cca38f in KateSmartManager::qt_metacall (this=0xa9989d0,
_c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbf90bf08) at
./katesmartmanager.moc:74
#11 0x042da263 in QMetaObject::activate (sender=0xa5fc290,
from_signal_index=4, to_signal_index=4, argv=0xbf90bf08) at
kernel/qobject.cpp:3113
#12 0x042daec2 in QMetaObject::activate (sender=0xa5fc290,
m=0x1dd5b64, local_signal_index=0, argv=0xbf90bf08) at
kernel/qobject.cpp:3187
#13 0x01c98523 in KateEditHistory::editDone (this=0xa5fc290,
_t1=0xa3dd668) at ./kateedit.moc:78
#14 0x01c6e937 in KateDocument::closeUrl (this=0xa86e210) at
../../kate/document/katedocument.cpp:3606
#15 0x082d4ef0 in _start ()




El 5 de diciembre de 2009 17:32, Dario Andres
<andresbajotierra@gmail.com> escribió:
>
> https://bugs.kde.org/show_bug.cgi?id=217431
>
>
>
>
>
> --- Comment #3 from Dario Andres <andresbajotierra gmail com>  2009-12-05 23:32:50 ---
> Intenta repetir la situación antes del primer fallo. De esta forma tal vez
> puedas hacer que Kile se cierre de nuevo. Si eso sucede y el diálogo manejador
> de errores aparece, debes hacer click en la pestaña "Información para
> desarrolladores" para luego copiar y pegar esa información aquí.
> Saludos
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 5 Dario Andres 2009-12-18 21:50:05 UTC
Gracias.. este fallo ya está reportado en bug 200450.

--

Thanks, this crash was already reported at bug 200450

*** This bug has been marked as a duplicate of bug 200450 ***