Bug 225100 - Dolphin crashes after pasting
Summary: Dolphin crashes after pasting
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-01 09:06 UTC by Volker Fröhlich
Modified: 2010-02-02 18:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volker Fröhlich 2010-02-01 09:06:10 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.31.12-174.2.3.fc12.x86_64 x86_64
Distribution: "Fedora release 12 (Constantine)"

What I was doing when the application crashed:
Crashes immediately after finishing the pasting

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#5  0x000000343c337913 in KFileItem::isDir (this=0x2912ac0) at /usr/src/debug/kdelibs-4.3.4/kio/kio/kfileitem.cpp:969
#6  0x000000343c325478 in KDirModelPrivate::removeFromNodeHash (this=0x29239d0, node=0x2912ac0, url=<value optimized out>) at /usr/src/debug/kdelibs-4.3.4/kio/kio/kdirmodel.cpp:200
#7  0x000000343c32637b in KDirModelPrivate::_k_slotDeleteItems (this=<value optimized out>, items=<value optimized out>) at /usr/src/debug/kdelibs-4.3.4/kio/kio/kdirmodel.cpp:487
#8  0x000000343c327e42 in KDirModel::qt_metacall (this=0x292aa60, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb8cbc120)
    at /usr/src/debug/kdelibs-4.3.4/x86_64-redhat-linux-gnu/kio/kdirmodel.moc:83
#9  0x0000003a3a15408c in QMetaObject::activate (sender=0x2923d70, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x7fffb8cbc120) at kernel/qobject.cpp:3112
#10 0x000000343c30bc35 in KDirLister::itemsDeleted (this=<value optimized out>, _t1=<value optimized out>) at /usr/src/debug/kdelibs-4.3.4/x86_64-redhat-linux-gnu/kio/kdirlister.moc:289
#11 0x000000343c30c971 in KDirLister::Private::emitItemsDeleted (this=0x292a8f0, _items=<value optimized out>) at /usr/src/debug/kdelibs-4.3.4/kio/kio/kdirlister.cpp:2351
#12 0x000000343c31b8ce in KDirListerCache::itemsDeleted (this=0x28ae950, listers=<value optimized out>, deletedItems=...) at /usr/src/debug/kdelibs-4.3.4/kio/kio/kdirlister.cpp:1697
#13 0x000000343c31d32a in KDirListerCache::slotFilesRemoved (this=<value optimized out>, fileList=<value optimized out>) at /usr/src/debug/kdelibs-4.3.4/kio/kio/kdirlister.cpp:808
#14 0x000000343c31d7a4 in KDirListerCache::slotFilesRemoved (this=0x28ae950, fileList=<value optimized out>) at /usr/src/debug/kdelibs-4.3.4/kio/kio/kdirlister.cpp:763
#15 0x000000343c31e0f0 in KDirListerCache::qt_metacall (this=0x28ae950, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb8cbc5a0)
    at /usr/src/debug/kdelibs-4.3.4/x86_64-redhat-linux-gnu/kio/kdirlister_p.moc:92
#16 0x0000003a3a15408c in QMetaObject::activate (sender=0x28aeeb0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x7fffb8cbc5a0) at kernel/qobject.cpp:3112
#17 0x000000343c3293c5 in OrgKdeKDirNotifyInterface::FilesRemoved (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdelibs-4.3.4/x86_64-redhat-linux-gnu/kio/kdirnotify.moc:125
#18 0x000000343c329530 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x28aeeb0, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb8cbc860)
    at /usr/src/debug/kdelibs-4.3.4/x86_64-redhat-linux-gnu/kio/kdirnotify.moc:83
#19 0x0000003a3b222e84 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#20 0x0000003a3b22a61f in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib64/libQtDBus.so.4
#21 0x0000003a3a14e401 in QObject::event (this=0x28aeeb0, e=0x3810300) at kernel/qobject.cpp:1110
#22 0x0000003370d8f65c in QApplicationPrivate::notify_helper (this=0x269fb40, receiver=0x28aeeb0, e=0x3810300) at kernel/qapplication.cpp:4065
#23 0x0000003370d968ce in QApplication::notify (this=<value optimized out>, receiver=0x28aeeb0, e=0x3810300) at kernel/qapplication.cpp:4030
#24 0x000000343b811a66 in KApplication::notify (this=0x7fffb8cbd200, receiver=0x28aeeb0, event=0x3810300) at /usr/src/debug/kdelibs-4.3.4/kdeui/kernel/kapplication.cpp:302
#25 0x0000003a3a13ee6c in QCoreApplication::notifyInternal (this=0x7fffb8cbd200, receiver=0x28aeeb0, event=0x3810300) at kernel/qcoreapplication.cpp:610
#26 0x0000003a3a13fa42 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x2674fa0) at kernel/qcoreapplication.h:213
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x2674fa0) at kernel/qcoreapplication.cpp:1247
#28 0x0000003a3a167573 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:218
#29 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#30 0x0000003a3103922e in g_main_dispatch (context=0x269c520) at gmain.c:1960
#31 IA__g_main_context_dispatch (context=0x269c520) at gmain.c:2513
#32 0x0000003a3103cc18 in g_main_context_iterate (context=0x269c520, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2591
#33 0x0000003a3103cd3a in IA__g_main_context_iteration (context=0x269c520, may_block=1) at gmain.c:2654
#34 0x0000003a3a1671e6 in QEventDispatcherGlib::processEvents (this=0x26747b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#35 0x0000003370e21ffe in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#36 0x0000003a3a13d772 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#37 0x0000003a3a13db44 in QEventLoop::exec (this=0x7fffb8cbd150, flags=...) at kernel/qeventloop.cpp:201
#38 0x0000003a3a13fcd9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#39 0x0000000000437025 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2010-02-01 22:23:08 UTC
- Does this happen when copying and pasting *any kind* of file, withing *every* location ? or there is some pattern?
- Do you use any non-default option ? (view mode, previews, sorting )?
Merging with bug 196695. 
Regards

*** This bug has been marked as a duplicate of bug 196695 ***
Comment 2 Volker Fröhlich 2010-02-02 10:34:56 UTC
This only happened once yet. I could not reproduce it, but I don't use Dolphin regularly. I therefore assume, that all options are default.

Thank you!
Comment 3 Dario Andres 2010-02-02 18:07:17 UTC
Thanks