Bug 233286 - KDE session handler crashed on startup
Summary: KDE session handler crashed on startup
Status: RESOLVED DUPLICATE of bug 195034
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-04 21:22 UTC by Mikko Karjalainen
Modified: 2010-04-05 01:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikko Karjalainen 2010-04-04 21:22:34 UTC
Application that crashed: ksmserver
Version of the application: 0.4
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.32-13-generic i686
Distribution: Debian GNU/Linux 5.0.4 (lenny)

What I was doing when the application crashed:
After running some updates (I can provide a list if needed) and rebooting the KDE session handler crashed.

 -- Backtrace:
Application: KDE:n istunnonhallinta (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x00a92da7 in _IceTransGetConnectionNumber () from /usr/lib/libICE.so.6
#7  0x07ca5de5 in KSMServer::newConnection (this=0x914ff70) at ../../ksmserver/server.cpp:825
#8  0x07ca611f in KSMServer::qt_metacall (this=0x914ff70, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbff7b90c) at ./server.moc:107
#9  0x00c63303 in QMetaObject::activate (sender=0x9176f48, from_signal_index=4, to_signal_index=4, argv=0xbff7b90c) at kernel/qobject.cpp:3112
#10 0x00c63f42 in QMetaObject::activate (sender=0x9176f48, m=0xd3fd30, local_signal_index=0, argv=0xbff7b90c) at kernel/qobject.cpp:3186
#11 0x00c9e9c3 in QSocketNotifier::activated (this=0x9176f48, _t1=9) at .moc/release-shared/moc_qsocketnotifier.cpp:83
#12 0x00c68907 in QSocketNotifier::event (this=0x9176f48, e=0xbff7bce0) at kernel/qsocketnotifier.cpp:316
#13 0x0571fa94 in QApplicationPrivate::notify_helper (this=0x9082300, receiver=0x9176f48, e=0xbff7bce0) at kernel/qapplication.cpp:4065
#14 0x05727bee in QApplication::notify (this=0x9082280, receiver=0x9176f48, e=0xbff7bce0) at kernel/qapplication.cpp:3605
#15 0x0113de2a in KApplication::notify (this=0x9082280, receiver=0x9176f48, event=0xbff7bce0) at ../../kdeui/kernel/kapplication.cpp:302
#16 0x00c4e1eb in QCoreApplication::notifyInternal (this=0x9082280, receiver=0x9176f48, event=0xbff7bce0) at kernel/qcoreapplication.cpp:610
#17 0x00c793aa in QCoreApplication::sendEvent (source=0x90ed8c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#18 socketNotifierSourceDispatch (source=0x90ed8c0) at kernel/qeventdispatcher_glib.cpp:110
#19 0x003ccb38 in g_main_dispatch (context=0x90ed800) at /build/buildd-glib2.0_2.22.4-1-i386-jRfNZE/glib2.0-2.22.4/glib/gmain.c:1960
#20 IA__g_main_context_dispatch (context=0x90ed800) at /build/buildd-glib2.0_2.22.4-1-i386-jRfNZE/glib2.0-2.22.4/glib/gmain.c:2513
#21 0x003d03d0 in g_main_context_iterate (context=0x90ed800, block=<value optimized out>, dispatch=1, self=0x9028d10) at /build/buildd-glib2.0_2.22.4-1-i386-jRfNZE/glib2.0-2.22.4/glib/gmain.c:2591
#22 0x003d0503 in IA__g_main_context_iteration (context=0x90ed800, may_block=1) at /build/buildd-glib2.0_2.22.4-1-i386-jRfNZE/glib2.0-2.22.4/glib/gmain.c:2654
#23 0x00c79041 in QEventDispatcherGlib::processEvents (this=0x90823c0, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#24 0x057bf305 in QGuiEventDispatcherGlib::processEvents (this=0x90823c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#25 0x00c4c83a in QEventLoop::processEvents (this=0xbff7bf30, flags=...) at kernel/qeventloop.cpp:149
#26 0x00c4cc82 in QEventLoop::exec (this=0xbff7bf30, flags=...) at kernel/qeventloop.cpp:201
#27 0x00c4f0d9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#28 0x0571f917 in QApplication::exec () at kernel/qapplication.cpp:3525
#29 0x07ca0b3b in kdemain (argc=1, argv=0x90664c0) at ../../ksmserver/main.cpp:322
#30 0x0804de39 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x9067976 "/home/mikko", envc=24, envs=0x9067986 "KDE_FULL_SESSION=true", 
    reset_env=true, tty=0x9067c67 "", avoid_loops=false, startup_id_str=0x9067c6c "") at ../../kinit/kinit.cpp:677
#31 0x0804e9ad in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#32 0x0804ee03 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1353
#33 0x0804f657 in main (argc=2, argv=0xbff7c8d4, envp=0xbff7c8e0) at ../../kinit/kinit.cpp:1793

This bug may be a duplicate of or related to bug 195034

Reported using DrKonqi
Comment 1 Mikko Karjalainen 2010-04-04 22:08:12 UTC
Update: After reporting the bug I tried to restart session handler but couldn't log in since my keyboard wan't working. However, after sysytem restart everything has been working fine.
Comment 2 Dario Andres 2010-04-05 01:47:40 UTC
This is being tracked at bug 195034. Regards

*** This bug has been marked as a duplicate of bug 195034 ***