Bug 221568 - Crash report upon opening of my KDE sessions
Summary: Crash report upon opening of my KDE sessions
Status: RESOLVED DUPLICATE of bug 195034
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-06 20:39 UTC by Fadi R
Modified: 2010-01-06 21:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fadi R 2010-01-06 20:39:11 UTC
Application that crashed: ksmserver
Version of the application: 0.4
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-16-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I've barely logged into to KDE and I see nothing but a big crash screen. I have no idea what brought this about. Main changes since yesterday: I installed a few VOIP programs yesterday and started running Akonadi. I have taken screenshots of the list of packages installed in synaptic. I can upload the pngs if you need it. 

 -- Backtrace:
Application: The KDE Session Manager (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  0x00007f5141988d40 in _IceTransGetConnectionNumber () from /usr/lib/libICE.so.6
#6  0x00007f513b6f6f26 in KSMServer::newConnection (this=<value optimized out>) at ../../ksmserver/server.cpp:825
#7  0x00007f513b6f7210 in KSMServer::qt_metacall (this=0x160abd0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffc95ca450) at ./server.moc:107
#8  0x00007f5147360ddc in QMetaObject::activate (sender=0x16029a0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x1b2c0) at kernel/qobject.cpp:3113
#9  0x00007f5147396e9e in QSocketNotifier::activated (this=0x0, _t1=10) at .moc/release-shared/moc_qsocketnotifier.cpp:83
#10 0x00007f5147365773 in QSocketNotifier::event (this=0x16029a0, e=0x7fffc95ca990) at kernel/qsocketnotifier.cpp:316
#11 0x00007f51452fbefc in QApplicationPrivate::notify_helper (this=0x1559670, receiver=0x16029a0, e=0x7fffc95ca990) at kernel/qapplication.cpp:4056
#12 0x00007f51453031ce in QApplication::notify (this=0x15595a0, receiver=0x16029a0, e=0x7fffc95ca990) at kernel/qapplication.cpp:4021
#13 0x00007f5145f32ab6 in KApplication::notify (this=0x15595a0, receiver=0x16029a0, event=0x7fffc95ca990) at ../../kdeui/kernel/kapplication.cpp:302
#14 0x00007f514734bc2c in QCoreApplication::notifyInternal (this=0x15595a0, receiver=0x16029a0, event=0x7fffc95ca990) at kernel/qcoreapplication.cpp:610
#15 0x00007f514737442a in QCoreApplication::sendEvent (source=0x155dc00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#16 socketNotifierSourceDispatch (source=0x155dc00) at kernel/qeventdispatcher_glib.cpp:110
#17 0x00007f514422cbce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#18 0x00007f5144230598 in ?? () from /lib/libglib-2.0.so.0
#19 0x00007f51442306c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#20 0x00007f51473741a6 in QEventDispatcherGlib::processEvents (this=0x14b5040, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#21 0x00007f51453904be in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#22 0x00007f514734a532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#23 0x00007f514734a904 in QEventLoop::exec (this=0x7fffc95cabf0, flags=) at kernel/qeventloop.cpp:201
#24 0x00007f514734cab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#25 0x00007f513b6f1485 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../ksmserver/main.cpp:322
#26 0x0000000000406da8 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=27, envs=<value optimized out>, reset_env=true, tty=0x1510b68 "", 
    avoid_loops=false, startup_id_str=0x1510b71 "") at ../../kinit/kinit.cpp:677
#27 0x0000000000407aa0 in handle_launcher_request (sock=4, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#28 0x0000000000407f08 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1353
#29 0x0000000000408bb2 in main (argc=2, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1793

Reported using DrKonqi
Comment 1 Dario Andres 2010-01-06 21:51:30 UTC
This is being tracked at bug 195034. Thanks

*** This bug has been marked as a duplicate of bug 195034 ***