Bug 219006 - kdeinit crash at startup
Summary: kdeinit crash at startup
Status: RESOLVED DUPLICATE of bug 195034
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-17 01:39 UTC by Kévin FERRARE
Modified: 2010-01-06 21:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kévin FERRARE 2009-12-17 01:39:25 UTC
Application that crashed: ksmserver
Version of the application: 0.4
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.5.3
Operating System: Linux 2.6.32-gentoo x86_64

What I was doing when the application crashed:
I just opened my session and bam !
This is the first time this problem occurs

 -- Backtrace:
Application: Le gestionnaire de session de KDE (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f4e8c04ac10 in _IceTransGetConnectionNumber () from /usr/lib64/libICE.so.6
#6  0x00007f4e7f9f5439 in KSMServer::newConnection () from /usr/lib64/libkdeinit4_ksmserver.so
#7  0x00007f4e7f9f588b in KSMServer::qt_metacall () from /usr/lib64/libkdeinit4_ksmserver.so
#8  0x00007f4e9190af3d in QMetaObject::activate () from /usr/lib64/qt4/libQtCore.so.4
#9  0x00007f4e9193debe in QSocketNotifier::activated () from /usr/lib64/qt4/libQtCore.so.4
#10 0x00007f4e91910f53 in QSocketNotifier::event () from /usr/lib64/qt4/libQtCore.so.4
#11 0x00007f4e8ed9dbbd in QApplicationPrivate::notify_helper () from /usr/lib64/qt4/libQtGui.so.4
#12 0x00007f4e8eda569a in QApplication::notify () from /usr/lib64/qt4/libQtGui.so.4
#13 0x00007f4e8fda0f1b in KApplication::notify () from /usr/lib64/libkdeui.so.5
#14 0x00007f4e918f8cdc in QCoreApplication::notifyInternal () from /usr/lib64/qt4/libQtCore.so.4
#15 0x00007f4e9191e479 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#16 0x00007f4e8d82c7ea in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#17 0x00007f4e8d830088 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#18 0x00007f4e8d83024c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#19 0x00007f4e9191e1ff in QEventDispatcherGlib::processEvents () from /usr/lib64/qt4/libQtCore.so.4
#20 0x00007f4e8ee2482f in ?? () from /usr/lib64/qt4/libQtGui.so.4
#21 0x00007f4e918f7672 in QEventLoop::processEvents () from /usr/lib64/qt4/libQtCore.so.4
#22 0x00007f4e918f780c in QEventLoop::exec () from /usr/lib64/qt4/libQtCore.so.4
#23 0x00007f4e918f98dc in QCoreApplication::exec () from /usr/lib64/qt4/libQtCore.so.4
#24 0x00007f4e7f9ee9f5 in kdemain () from /usr/lib64/libkdeinit4_ksmserver.so
#25 0x000000000040773f in launch ()
#26 0x0000000000407f18 in handle_launcher_request ()
#27 0x000000000040848e in handle_requests ()
#28 0x0000000000408b45 in main ()

This bug may be a duplicate of or related to bug 208533

Reported using DrKonqi
Comment 1 Dario Andres 2010-01-06 21:51:23 UTC
This is being tracked at bug 195034. Thanks

*** This bug has been marked as a duplicate of bug 195034 ***