Bug 208533 - ksmserver crash immediately after login
Summary: ksmserver crash immediately after login
Status: RESOLVED DUPLICATE of bug 195034
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-25 18:37 UTC by Matthias
Modified: 2009-11-23 20:01 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Logfile of another patch (3.48 KB, text/plain)
2009-10-20 18:52 UTC, tkoenig
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias 2009-09-25 18:37:51 UTC
Version:            (using KDE 4.3.1)
OS:                Linux
Installed from:    Debian testing/unstable Packages

I just tried to log into my computer and ksmserver crashed immediately without any obvious reason. I'll attach a backtrace right now...
Comment 1 Matthias 2009-09-25 18:39:35 UTC
How can I attach a file here?? Anyway, here's the backtrace: 

Application: Der KDE-Sitzungsmanager (kdeinit4), signal: Segmentation fault                                                                        
[KCrash Handler]                                                                                                                                   
#6  _IceTransGetConnectionNumber (ciptr=) at /usr/include/X11/Xtrans/Xtrans.c:1017                                                                 
#7  0xb45739ea in KSMServer::newConnection (this=0x87148d0) at ../../ksmserver/server.cpp:825                                                      
#8  0xb4573e82 in KSMServer::qt_metacall (this=0x87148d0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfb9c27c) at ./server.moc:107
#9  0xb7fbdb33 in QMetaObject::activate (sender=0x8716948, from_signal_index=4, to_signal_index=4, argv=0xbfb9c27c) at kernel/qobject.cpp:3112
#10 0xb7fbe782 in QMetaObject::activate (sender=0x8716948, m=0xb8099d90, local_signal_index=0, argv=0xbfb9c27c) at kernel/qobject.cpp:3186
#11 0xb7ff9003 in QSocketNotifier::activated (this=0x8716948, _t1=9) at .moc/release-shared/moc_qsocketnotifier.cpp:83
#12 0xb7fc3147 in QSocketNotifier::event (this=0x8716948, e=0xbfb9c630) at kernel/qsocketnotifier.cpp:316
#13 0xb6d6c814 in QApplicationPrivate::notify_helper (this=0x866abd8, receiver=0x8716948, e=0xbfb9c630) at kernel/qapplication.cpp:4056
#14 0xb6d7497e in QApplication::notify (this=0x866ab50, receiver=0x8716948, e=0xbfb9c630) at kernel/qapplication.cpp:3603
#15 0xb77b54ad in KApplication::notify (this=0x866ab50, receiver=0x8716948, event=0xbfb9c630) at ../../kdeui/kernel/kapplication.cpp:302
#16 0xb7fa89cb in QCoreApplication::notifyInternal (this=0x866ab50, receiver=0x8716948, event=0xbfb9c630) at kernel/qcoreapplication.cpp:610
#17 0xb7fd3aea in QCoreApplication::sendEvent (source=0x866e000) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#18 socketNotifierSourceDispatch (source=0x866e000) at kernel/qeventdispatcher_glib.cpp:110
#19 0xb694de98 in g_main_dispatch (context=0x866d290) at /build/buildd-glib2.0_2.22.0-1-i386-YCLGRR/glib2.0-2.22.0/glib/gmain.c:1960
#20 IA__g_main_context_dispatch (context=0x866d290) at /build/buildd-glib2.0_2.22.0-1-i386-YCLGRR/glib2.0-2.22.0/glib/gmain.c:2513
#21 0xb6951623 in g_main_context_iterate (context=0x866d290, block=1, dispatch=1, self=0x85e7310) at /build/buildd-glib2.0_2.22.0-1-i386-YCLGRR/glib2.0-2.22.0/glib/gmain.c:2591
#22 0xb69517a8 in IA__g_main_context_iteration (context=0x866d290, may_block=1) at /build/buildd-glib2.0_2.22.0-1-i386-YCLGRR/glib2.0-2.22.0/glib/gmain.c:2654
#23 0xb7fd3858 in QEventDispatcherGlib::processEvents (this=0x85e7220, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#24 0xb6e0bfd5 in QGuiEventDispatcherGlib::processEvents (this=0x85e7220, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#25 0xb7fa701a in QEventLoop::processEvents (this=0xbfb9c830, flags=...) at kernel/qeventloop.cpp:149
#26 0xb7fa7462 in QEventLoop::exec (this=0xbfb9c830, flags=...) at kernel/qeventloop.cpp:201
#27 0xb7fa98b9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#28 0xb6d6c697 in QApplication::exec () at kernel/qapplication.cpp:3525
#29 0xb456c75b in kdemain (argc=1, argv=0x85e7210) at ../../ksmserver/main.cpp:322
#30 0x0804e291 in launch (argc=1, _name=0x861f0f4 "ksmserver", args=0x861f0fe "/home/matthias", cwd=0x861f0fe "/home/matthias", envc=27, envs=0x861f111 "KDE_FULL_SESSION=true", reset_env=true,
    tty=0x861f491 "", avoid_loops=false, startup_id_str=0x861f496 "") at ../../kinit/kinit.cpp:677
#31 0x0804ea15 in handle_launcher_request (sock=9, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#32 0x0804ef1c in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1353
#33 0x0804f6c9 in main (argc=2, argv=0xbfb9d1b4, envp=0xbfb9d1c0) at ../../kinit/kinit.cpp:1793
Comment 2 Matthias 2009-09-25 18:42:50 UTC
Oh, sorry for being a moron, obviously it was kdeinit4 that crashed. I was confused by the fact that the file is called ksmserver-<date>.kcrash by default...
Comment 3 Dario Andres 2009-09-26 03:35:55 UTC
Backtrace looks related to bug 195034. Thanks
Comment 4 tkoenig 2009-10-20 18:52:41 UTC
Created attachment 37688 [details]
Logfile of another patch

The same thing (probably) happened to me, here's a logfile.
Comment 5 Steve Kroon 2009-11-12 08:24:00 UTC
Hi.

The same thing happened to me: I did some package updates yesterday, including a kernel upgrade to 2.6.31-15-generic .  I was requested to restart, and on restarting, I got a screen saying the session manager had crashed.  Automatic crash reporting got stuck along the way (for some reason I couldn't type in the uname and password text boxes), but after cancelling the crash report, I was auto-logged-out.  Logging in again was fine.

Here's the backtrace, in case it helps:

Application that crashed: ksmserver
Version of the application: 0.4
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-15-generic i686
Distribution: Ubuntu 9.10

 -- Backtrace:
Application: The KDE Session Manager (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0xb5a31a47 in _IceTransGetConnectionNumber () from /usr/lib/libICE.so.6
#7  0xb4254ef5 in KSMServer::newConnection (this=0x88e1820) at ../../ksmserver/server.cpp:825
#8  0xb425522f in KSMServer::qt_metacall (this=0x88e1820, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfd0b8f8) at ./server.moc:107
#9  0xb75ed263 in QMetaObject::activate (sender=0x88e6bb0, from_signal_index=4, to_signal_index=4, argv=0xbfd0b8f8) at kernel/qobject.cpp:3113
#10 0xb75edec2 in QMetaObject::activate (sender=0x88e6bb0, m=0xb76c88b0, local_signal_index=0, argv=0xbfd0b8f8) at kernel/qobject.cpp:3187
#11 0xb7627503 in QSocketNotifier::activated (this=0x88e6bb0, _t1=9) at .moc/release-shared/moc_qsocketnotifier.cpp:83
#12 0xb75f1c87 in QSocketNotifier::event (this=0x88e6bb0, e=0xbfd0bcb4) at kernel/qsocketnotifier.cpp:316
#13 0xb6250f54 in QApplicationPrivate::notify_helper (this=0x8859fd8, receiver=0x88e6bb0, e=0xbfd0bcb4) at kernel/qapplication.cpp:4056
#14 0xb625867c in QApplication::notify (this=0x8825410, receiver=0x88e6bb0, e=0xbfd0bcb4) at kernel/qapplication.cpp:3603
#15 0xb6ca0bfa in KApplication::notify (this=0x8825410, receiver=0x88e6bb0, event=0xbfd0bcb4) at ../../kdeui/kernel/kapplication.cpp:302
#16 0xb75d76cb in QCoreApplication::notifyInternal (this=0x8825410, receiver=0x88e6bb0, event=0xbfd0bcb4) at kernel/qcoreapplication.cpp:610
#17 0xb76022ca in QCoreApplication::sendEvent (source=0x885c900) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#18 socketNotifierSourceDispatch (source=0x885c900) at kernel/qeventdispatcher_glib.cpp:110
#19 0xb5e56e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#20 0xb5e5a720 in ?? () from /lib/libglib-2.0.so.0
#21 0xb5e5a853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#22 0xb760202c in QEventDispatcherGlib::processEvents (this=0x87d6a58, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#23 0xb62f1be5 in QGuiEventDispatcherGlib::processEvents (this=0x87d6a58, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#24 0xb75d5c79 in QEventLoop::processEvents (this=0xbfd0bf54, flags=) at kernel/qeventloop.cpp:149
#25 0xb75d60ca in QEventLoop::exec (this=0xbfd0bf54, flags=...) at kernel/qeventloop.cpp:201
#26 0xb75d853f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#27 0xb6250dd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#28 0xb424eb7b in kdemain (argc=1, argv=0x880d5c0) at ../../ksmserver/main.cpp:322
#29 0x0804dde1 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x880f936 "/home/skroon", envc=34, envs=0x880f947 "KDE_FULL_SESSION=true",
    reset_env=true, tty=0x880fdac "", avoid_loops=false, startup_id_str=0x880fdb1 "") at ../../kinit/kinit.cpp:677
#30 0x0804ea35 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#31 0x0804ee69 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1353
#32 0x0804fbaf in main (argc=2, argv=0xbfd0c894, envp=0xbfd0c8a0) at ../../kinit/kinit.cpp:1793
Comment 6 Lubos Lunak 2009-11-23 20:01:12 UTC

*** This bug has been marked as a duplicate of bug 195034 ***