Bug 215847 - Kile crashes on exit
Summary: Kile crashes on exit
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: 2.0.83
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-23 17:33 UTC by Nikos Papas
Modified: 2009-11-23 22:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nikos Papas 2009-11-23 17:33:08 UTC
Version:           2.0.83 (using KDE 4.3.3)
OS:                Linux
Installed from:    Ubuntu Packages

Kile randomly (but quite often) crashes on exit. Before the crash, I usually work on a project which involves 5 or 6 tex documents. I also have the dvi open in another window using Okular. This is the backtrace:

Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#5  KateSmartCursor::setPositionInternal (this=0x25b9740, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#6  0x00007fe6482b30df in KateSmartCursor::translate (this=0x25b9740, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#7  0x00007fe6482b836c in KateSmartGroup::translateChanged (this=0x1db25c0, edit=...) at ../../kate/smart/katesmartmanager.cpp:464
#8  0x00007fe6482bbaab in KateSmartManager::slotTextChanged (this=0x1db3580, edit=0x1ca7900) at ../../kate/smart/katesmartmanager.cpp:368
#9  0x00007fe6482bbe2c in KateSmartManager::qt_metacall (this=0x1db3580, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffee79fa60) at ./katesmartmanager.moc:74
#10 0x00007fe6546fcddc in QMetaObject::activate (sender=0x1db2be0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x25b9740) at kernel/qobject.cpp:3113
#11 0x00007fe64828db9f in KateEditHistory::editDone (this=0x7fffee79f7c0, _t1=0x1ca7900) at ./kateedit.moc:78
#12 0x00007fe648266b5b in KateDocument::closeUrl (this=0x1db1d90) at ../../kate/document/katedocument.cpp:3611
#13 0x00000000006cd30d in _start ()

Thanks.
Comment 1 Dario Andres 2009-11-23 22:38:20 UTC
Merging with bug 200450. Thanks

*** This bug has been marked as a duplicate of bug 200450 ***