Bug 231041 - Plasma crashes after Kopete crashes
Summary: Plasma crashes after Kopete crashes
Status: RESOLVED DUPLICATE of bug 226596
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-17 00:59 UTC by Alexis Kauffmann
Modified: 2010-03-17 01:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexis Kauffmann 2010-03-17 00:59:20 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.31-20-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
It happens more often when I leave the computer to sleep or hibernate.

 -- Backtrace:
Application: Espaço de trabalho do Plasma (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x005af266 in QString (this=0x15, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:714
#7  KIconEffect::fingerprint (this=0x15, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:158
#8  0x005bc724 in KIconLoader::loadIcon (this=0x9b8edb8, _name=..., group=KIconLoader::Desktop, size=21, state=0, overlays=..., path_store=0x0, canReturnNull=false)
    at ../../kdeui/icons/kiconloader.cpp:1085
#9  0x005b3bb8 in KIconEngine::actualSize (this=0x9da87f0, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:80
#10 0x0309dea6 in QIcon::actualSize (this=0x9ec22ac, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:700
#11 0x01519c43 in Plasma::IconWidgetPrivate::decoration (this=0x9ec2230, option=0x89b50b0, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:701
#12 0x0151b877 in Plasma::IconWidget::paint (this=0x9ed06a8, painter=0xbf87cbfc, option=0x89b50b0, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1013
#13 0x0367102c in _q_paintItem (item=<value optimized out>, painter=<value optimized out>, option=0x89b50b0, widget=0x0, useWindowOpacity=false, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4243
#14 0x03673c1a in _q_paintIntoCache (pix=<value optimized out>, item=<value optimized out>, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x89b50b0, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4281
#15 0x0368d6c0 in QGraphicsScenePrivate::drawItemHelper (this=0x89b4f50, item=0x9ed06b0, painter=0xbf87ea24, option=0x89b50b0, widget=0x96cb7e8, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4574
#16 0x0368e0e4 in QGraphicsScenePrivate::draw (this=0x89b4f50, item=0x9ed06b0, painter=0xbf87ea24, viewTransform=0xbf87e85c, transformPtr=0xbf87d5e0, exposedRegion=0x985cdbc, widget=0x96cb7e8, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4827
#17 0x0368ed6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x89b4f50, item=0x9ed06b0, painter=0xbf87ea24, viewTransform=0xbf87e85c, exposedRegion=0x985cdbc, widget=0x96cb7e8, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#18 0x0368e174 in QGraphicsScenePrivate::draw (this=0x89b4f50, item=0x8dfb398, painter=0xbf87ea24, viewTransform=0xbf87e85c, transformPtr=0xbf87dae0, exposedRegion=0x985cdbc, widget=0x96cb7e8, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#19 0x0368ed6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x89b4f50, item=0x8dfb398, painter=0xbf87ea24, viewTransform=0xbf87e85c, exposedRegion=0x985cdbc, widget=0x96cb7e8, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#20 0x0368e174 in QGraphicsScenePrivate::draw (this=0x89b4f50, item=0x8df2e10, painter=0xbf87ea24, viewTransform=0xbf87e85c, transformPtr=0xbf87dfe0, exposedRegion=0x985cdbc, widget=0x96cb7e8, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#21 0x0368ed6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x89b4f50, item=0x8df2e10, painter=0xbf87ea24, viewTransform=0xbf87e85c, exposedRegion=0x985cdbc, widget=0x96cb7e8, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#22 0x0368e174 in QGraphicsScenePrivate::draw (this=0x89b4f50, item=0x8d90e28, painter=0xbf87ea24, viewTransform=0xbf87e85c, transformPtr=0xbf87e4e0, exposedRegion=0x985cdbc, widget=0x96cb7e8, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#23 0x0368ed6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x89b4f50, item=0x8d90e28, painter=0xbf87ea24, viewTransform=0xbf87e85c, exposedRegion=0x985cdbc, widget=0x96cb7e8, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#24 0x0368f73e in QGraphicsScenePrivate::drawItems (this=0x89b4f50, painter=0xbf87ea24, viewTransform=0xbf87e85c, exposedRegion=0x985cdbc, widget=0x96cb7e8) at graphicsview/qgraphicsscene.cpp:4619
#25 0x036a9cab in QGraphicsView::paintEvent (this=0x978ec60, event=0xbf87f144) at graphicsview/qgraphicsview.cpp:3393
#26 0x0170dd99 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#27 0x0303a5d6 in QWidget::event (this=0x978ec60, event=0xbf87f144) at kernel/qwidget.cpp:8144
#28 0x03436733 in QFrame::event (this=0x978ec60, e=0xbf87f144) at widgets/qframe.cpp:557
#29 0x034d09b2 in QAbstractScrollArea::viewportEvent (this=0x0, e=0x15) at widgets/qabstractscrollarea.cpp:1036
#30 0x036a612b in QGraphicsView::viewportEvent (this=0x978ec60, event=0xbf87f144) at graphicsview/qgraphicsview.cpp:2787
#31 0x034d32a5 in QAbstractScrollAreaPrivate::viewportEvent (this=0x9324c70, o=0x96cb7e8, e=0xbf87f144) at widgets/qabstractscrollarea_p.h:100
#32 QAbstractScrollAreaFilter::eventFilter (this=0x9324c70, o=0x96cb7e8, e=0xbf87f144) at widgets/qabstractscrollarea_p.h:116
#33 0x00fd6e8a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x89249b8, receiver=0x96cb7e8, event=0xbf87f144) at kernel/qcoreapplication.cpp:819
#34 0x02fdc3a9 in QApplicationPrivate::notify_helper (this=0x89249b8, receiver=0x96cb7e8, e=0xbf87f144) at kernel/qapplication.cpp:4296
#35 0x02fe30b9 in QApplication::notify (this=0x8933b30, receiver=0x96cb7e8, e=0xbf87f144) at kernel/qapplication.cpp:4265
#36 0x005f942a in KApplication::notify (this=0x8933b30, receiver=0x96cb7e8, event=0xbf87f144) at ../../kdeui/kernel/kapplication.cpp:302
#37 0x00fd7beb in QCoreApplication::notifyInternal (this=0x8933b30, receiver=0x96cb7e8, event=0xbf87f144) at kernel/qcoreapplication.cpp:704
#38 0x030438e6 in QCoreApplication::sendSpontaneousEvent (this=0x9635d60, pdev=0x979b5a4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9781118)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#39 QWidgetPrivate::drawWidget (this=0x9635d60, pdev=0x979b5a4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9781118) at kernel/qwidget.cpp:5339
#40 0x03044725 in QWidgetPrivate::paintSiblingsRecursive (this=0x985ca58, pdev=0x979b5a4, siblings=..., index=11, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9781118)
    at kernel/qwidget.cpp:5452
#41 0x0304455e in QWidgetPrivate::paintSiblingsRecursive (this=0x985ca58, pdev=0x979b5a4, siblings=..., index=12, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9781118)
    at kernel/qwidget.cpp:5439
#42 0x03043635 in QWidgetPrivate::drawWidget (this=0x985ca58, pdev=0x979b5a4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9781118) at kernel/qwidget.cpp:5388
#43 0x03219f00 in QWidgetBackingStore::sync (this=0x9781118) at painting/qbackingstore.cpp:1291
#44 0x03033a93 in QWidgetPrivate::syncBackingStore (this=0x985ca58) at kernel/qwidget.cpp:1672
#45 0x0303ad96 in QWidget::event (this=0x978ec60, event=0x93ab110) at kernel/qwidget.cpp:8291
#46 0x03436733 in QFrame::event (this=0x978ec60, e=0x93ab110) at widgets/qframe.cpp:557
#47 0x034d13c7 in QAbstractScrollArea::event (this=0x978ec60, e=0x93ab110) at widgets/qabstractscrollarea.cpp:989
#48 0x036a82d6 in QGraphicsView::event (this=0x978ec60, event=0x93ab110) at graphicsview/qgraphicsview.cpp:2666
#49 0x0170e583 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#50 0x02fdc3cc in QApplicationPrivate::notify_helper (this=0x89249b8, receiver=0x93ab110, e=0x978ec60) at kernel/qapplication.cpp:4300
#51 0x02fe30b9 in QApplication::notify (this=0x8933b30, receiver=0x978ec60, e=0x93ab110) at kernel/qapplication.cpp:4265
#52 0x005f942a in KApplication::notify (this=0x8933b30, receiver=0x978ec60, event=0x93ab110) at ../../kdeui/kernel/kapplication.cpp:302
#53 0x00fd7beb in QCoreApplication::notifyInternal (this=0x8933b30, receiver=0x978ec60, event=0x93ab110) at kernel/qcoreapplication.cpp:704
#54 0x00fda623 in QCoreApplication::sendEvent (receiver=0x978ec60, event_type=77, data=0x88ee658) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#55 QCoreApplicationPrivate::sendPostedEvents (receiver=0x978ec60, event_type=77, data=0x88ee658) at kernel/qcoreapplication.cpp:1345
#56 0x00fda78d in QCoreApplication::sendPostedEvents (receiver=0x978ec60, event_type=77) at kernel/qcoreapplication.cpp:1238
#57 0x0368b3c6 in QGraphicsViewPrivate::dispatchPendingUpdateRequests (this=0x89b4f50) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:184
#58 QGraphicsScenePrivate::_q_processDirtyItems (this=0x89b4f50) at graphicsview/qgraphicsscene.cpp:509
#59 0x0368b916 in QGraphicsScene::qt_metacall (this=0x8a0be00, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xa3ea538) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#60 0x01458c6a in Plasma::Corona::qt_metacall (this=0x8a0be00, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xa3ea538) at ./corona.moc:107
#61 0x016fe1ad in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#62 0x00fdce5a in QMetaObject::metacall (object=0x8a0be00, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x0) at kernel/qmetaobject.cpp:237
#63 0x00fe7516 in QMetaCallEvent::placeMetaCall (this=0xa3f8548, object=0x8a0be00) at kernel/qobject.cpp:561
#64 0x00fe863e in QObject::event (this=0x8a0be00, e=0xa3f8548) at kernel/qobject.cpp:1248
#65 0x036875f4 in QGraphicsScene::event (this=0x8a0be00, event=0xa3f8548) at graphicsview/qgraphicsscene.cpp:3500
#66 0x02fdc3cc in QApplicationPrivate::notify_helper (this=0x89249b8, receiver=0x8a0be00, e=0xa3f8548) at kernel/qapplication.cpp:4300
#67 0x02fe301e in QApplication::notify (this=0x8933b30, receiver=0x8a0be00, e=0xa3f8548) at kernel/qapplication.cpp:3704
#68 0x005f942a in KApplication::notify (this=0x8933b30, receiver=0x8a0be00, event=0xa3f8548) at ../../kdeui/kernel/kapplication.cpp:302
#69 0x00fd7beb in QCoreApplication::notifyInternal (this=0x8933b30, receiver=0x8a0be00, event=0xa3f8548) at kernel/qcoreapplication.cpp:704
#70 0x00fda623 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x88ee658) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#71 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x88ee658) at kernel/qcoreapplication.cpp:1345
#72 0x00fda78d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#73 0x01003d0f in QCoreApplication::sendPostedEvents (s=0x8926210) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#74 postEventSourceDispatch (s=0x8926210) at kernel/qeventdispatcher_glib.cpp:276
#75 0x01c7ae88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#76 0x01c7e730 in ?? () from /lib/libglib-2.0.so.0
#77 0x01c7e863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#78 0x01003805 in QEventDispatcherGlib::processEvents (this=0x8924688, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#79 0x0309bb35 in QGuiEventDispatcherGlib::processEvents (this=0x8924688, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#80 0x00fd6209 in QEventLoop::processEvents (this=0xbf880b64, flags=) at kernel/qeventloop.cpp:149
#81 0x00fd665a in QEventLoop::exec (this=0xbf880b64, flags=...) at kernel/qeventloop.cpp:201
#82 0x00fda84f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#83 0x02fdc467 in QApplication::exec () at kernel/qapplication.cpp:3579
#84 0x0170617e in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#85 0x0804dff7 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x890ca60 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051405 "0") at ../../kinit/kinit.cpp:717
#86 0x0804ec15 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#87 0x0804f08c in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#88 0x0804fe2f in main (argc=4, argv=0xbf881614, envp=0xbf881628) at ../../kinit/kinit.cpp:1841

This bug may be a duplicate of or related to bug 226596.

Possible duplicates by query: bug 230313, bug 230222, bug 229461, bug 229429, bug 229302.

Reported using DrKonqi
Comment 1 Dario Andres 2010-03-17 01:56:52 UTC
Merging with bug 226596. Thanks

*** This bug has been marked as a duplicate of bug 226596 ***