Bug 229302 - Plasma desktop crash
Summary: Plasma desktop crash
Status: RESOLVED DUPLICATE of bug 226596
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-03 21:35 UTC by arthur.shagall
Modified: 2010-03-05 18:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description arthur.shagall 2010-03-03 21:35:07 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.31-20-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
Plasma desktop crashed while I was using Firefox, just after I got a notice that Kopete disconnected prior to crashing itself.  The Kopete crash did not produce an error report.

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x01114266 in QString (this=0x24, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:714
#7  KIconEffect::fingerprint (this=0x24, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:158
#8  0x01121724 in KIconLoader::loadIcon (this=0x9c710e8, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false)
    at ../../kdeui/icons/kiconloader.cpp:1085
#9  0x01118bb8 in KIconEngine::actualSize (this=0xa20a6d0, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:80
#10 0x0721fea6 in QIcon::actualSize (this=0xa15a884, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:700
#11 0x01a06c43 in Plasma::IconWidgetPrivate::decoration (this=0xa15a808, option=0x97dde48, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:701
#12 0x01a08877 in Plasma::IconWidget::paint (this=0xa296b50, painter=0xbf87022c, option=0x97dde48, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1013
#13 0x077f302c in _q_paintItem (item=<value optimized out>, painter=<value optimized out>, option=0x97dde48, widget=0x0, useWindowOpacity=false, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4243
#14 0x077f5c1a in _q_paintIntoCache (pix=<value optimized out>, item=<value optimized out>, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x97dde48, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4281
#15 0x0780f6c0 in QGraphicsScenePrivate::drawItemHelper (this=0x97ddce8, item=0xa296b58, painter=0xbf872054, option=0x97dde48, widget=0x9e56208, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4574
#16 0x078100e4 in QGraphicsScenePrivate::draw (this=0x97ddce8, item=0xa296b58, painter=0xbf872054, viewTransform=0xbf871e8c, transformPtr=0xbf870c10, exposedRegion=0x9d82224, widget=0x9e56208, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4827
#17 0x07810d6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x97ddce8, item=0xa296b58, painter=0xbf872054, viewTransform=0xbf871e8c, exposedRegion=0x9d82224, widget=0x9e56208, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#18 0x07810174 in QGraphicsScenePrivate::draw (this=0x97ddce8, item=0x99ec5f8, painter=0xbf872054, viewTransform=0xbf871e8c, transformPtr=0xbf871110, exposedRegion=0x9d82224, widget=0x9e56208, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#19 0x07810d6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x97ddce8, item=0x99ec5f8, painter=0xbf872054, viewTransform=0xbf871e8c, exposedRegion=0x9d82224, widget=0x9e56208, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#20 0x07810174 in QGraphicsScenePrivate::draw (this=0x97ddce8, item=0x99a1708, painter=0xbf872054, viewTransform=0xbf871e8c, transformPtr=0xbf871610, exposedRegion=0x9d82224, widget=0x9e56208, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#21 0x07810d6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x97ddce8, item=0x99a1708, painter=0xbf872054, viewTransform=0xbf871e8c, exposedRegion=0x9d82224, widget=0x9e56208, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#22 0x07810174 in QGraphicsScenePrivate::draw (this=0x97ddce8, item=0x9968d98, painter=0xbf872054, viewTransform=0xbf871e8c, transformPtr=0xbf871b10, exposedRegion=0x9d82224, widget=0x9e56208, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#23 0x07810d6b in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x97ddce8, item=0x9968d98, painter=0xbf872054, viewTransform=0xbf871e8c, exposedRegion=0x9d82224, widget=0x9e56208, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#24 0x0781173e in QGraphicsScenePrivate::drawItems (this=0x97ddce8, painter=0xbf872054, viewTransform=0xbf871e8c, exposedRegion=0x9d82224, widget=0x9e56208) at graphicsview/qgraphicsscene.cpp:4619
#25 0x0782bcab in QGraphicsView::paintEvent (this=0x9d69370, event=0xbf872774) at graphicsview/qgraphicsview.cpp:3393
#26 0x02c7ad99 in PanelView::paintEvent (this=0x9d69370, event=0xbf872774) at ../../../../plasma/desktop/shell/panelview.cpp:1310
#27 0x071bc5d6 in QWidget::event (this=0x9d69370, event=0xbf872774) at kernel/qwidget.cpp:8144
#28 0x075b8733 in QFrame::event (this=0x9d69370, e=0xbf872774) at widgets/qframe.cpp:557
#29 0x076529b2 in QAbstractScrollArea::viewportEvent (this=0x0, e=0x24) at widgets/qabstractscrollarea.cpp:1036
#30 0x0782812b in QGraphicsView::viewportEvent (this=0x9d69370, event=0xbf872774) at graphicsview/qgraphicsview.cpp:2787
#31 0x076552a5 in QAbstractScrollAreaPrivate::viewportEvent (this=0x9c6a7b8, o=0x9e56208, e=0xbf872774) at widgets/qabstractscrollarea_p.h:100
#32 QAbstractScrollAreaFilter::eventFilter (this=0x9c6a7b8, o=0x9e56208, e=0xbf872774) at widgets/qabstractscrollarea_p.h:116
#33 0x009f0e8a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x96ad790, receiver=0x9e56208, event=0xbf872774) at kernel/qcoreapplication.cpp:819
#34 0x0715e3a9 in QApplicationPrivate::notify_helper (this=0x96ad790, receiver=0x9e56208, e=0xbf872774) at kernel/qapplication.cpp:4296
#35 0x071650b9 in QApplication::notify (this=0x96a7a78, receiver=0x9e56208, e=0xbf872774) at kernel/qapplication.cpp:4265
#36 0x0115e42a in KApplication::notify (this=0x96a7a78, receiver=0x9e56208, event=0xbf872774) at ../../kdeui/kernel/kapplication.cpp:302
#37 0x009f1beb in QCoreApplication::notifyInternal (this=0x96a7a78, receiver=0x9e56208, event=0xbf872774) at kernel/qcoreapplication.cpp:704
#38 0x071c58e6 in QCoreApplication::sendSpontaneousEvent (this=0x9e56220, pdev=0x9e169d4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9e16830)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#39 QWidgetPrivate::drawWidget (this=0x9e56220, pdev=0x9e169d4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9e16830) at kernel/qwidget.cpp:5339
#40 0x071c6725 in QWidgetPrivate::paintSiblingsRecursive (this=0x9d81ec0, pdev=0x9e169d4, siblings=..., index=7, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9e16830)
    at kernel/qwidget.cpp:5452
#41 0x071c5635 in QWidgetPrivate::drawWidget (this=0x9d81ec0, pdev=0x9e169d4, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9e16830) at kernel/qwidget.cpp:5388
#42 0x0739bf00 in QWidgetBackingStore::sync (this=0x9e16830) at painting/qbackingstore.cpp:1291
#43 0x071b5a93 in QWidgetPrivate::syncBackingStore (this=0x9d81ec0) at kernel/qwidget.cpp:1672
#44 0x071bcd96 in QWidget::event (this=0x9d69370, event=0xa04c7b8) at kernel/qwidget.cpp:8291
#45 0x075b8733 in QFrame::event (this=0x9d69370, e=0xa04c7b8) at widgets/qframe.cpp:557
#46 0x076533c7 in QAbstractScrollArea::event (this=0x9d69370, e=0xa04c7b8) at widgets/qabstractscrollarea.cpp:989
#47 0x0782a2d6 in QGraphicsView::event (this=0x9d69370, event=0xa04c7b8) at graphicsview/qgraphicsview.cpp:2666
#48 0x02c7b583 in PanelView::event (this=0x9d69370, event=0xa04c7b8) at ../../../../plasma/desktop/shell/panelview.cpp:1324
#49 0x0715e3cc in QApplicationPrivate::notify_helper (this=0x96ad790, receiver=0x9d69370, e=0xa04c7b8) at kernel/qapplication.cpp:4300
#50 0x071650b9 in QApplication::notify (this=0x96a7a78, receiver=0x9d69370, e=0xa04c7b8) at kernel/qapplication.cpp:4265
#51 0x0115e42a in KApplication::notify (this=0x96a7a78, receiver=0x9d69370, event=0xa04c7b8) at ../../kdeui/kernel/kapplication.cpp:302
#52 0x009f1beb in QCoreApplication::notifyInternal (this=0x96a7a78, receiver=0x9d69370, event=0xa04c7b8) at kernel/qcoreapplication.cpp:704
#53 0x009f4623 in QCoreApplication::sendEvent (receiver=0x9d69370, event_type=77, data=0x9643658) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#54 QCoreApplicationPrivate::sendPostedEvents (receiver=0x9d69370, event_type=77, data=0x9643658) at kernel/qcoreapplication.cpp:1345
#55 0x009f478d in QCoreApplication::sendPostedEvents (receiver=0x9d69370, event_type=77) at kernel/qcoreapplication.cpp:1238
#56 0x0780d3c6 in QGraphicsViewPrivate::dispatchPendingUpdateRequests (this=0x97ddce8) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:184
#57 QGraphicsScenePrivate::_q_processDirtyItems (this=0x97ddce8) at graphicsview/qgraphicsscene.cpp:509
#58 0x0780d916 in QGraphicsScene::qt_metacall (this=0x97deb08, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x9fde478) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#59 0x01945c6a in Plasma::Corona::qt_metacall (this=0x97deb08, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x9fde478) at ./corona.moc:107
#60 0x02c6b1ad in DesktopCorona::qt_metacall (this=0x97deb08, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x9fde478) at ./desktopcorona.moc:86
#61 0x009f6e5a in QMetaObject::metacall (object=0x97deb08, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x9fde478) at kernel/qmetaobject.cpp:237
#62 0x00a01516 in QMetaCallEvent::placeMetaCall (this=0x9b48888, object=0x97deb08) at kernel/qobject.cpp:561
#63 0x00a0263e in QObject::event (this=0x97deb08, e=0x9b48888) at kernel/qobject.cpp:1248
#64 0x078095f4 in QGraphicsScene::event (this=0x97deb08, event=0x9b48888) at graphicsview/qgraphicsscene.cpp:3500
#65 0x0715e3cc in QApplicationPrivate::notify_helper (this=0x96ad790, receiver=0x97deb08, e=0x9b48888) at kernel/qapplication.cpp:4300
#66 0x0716501e in QApplication::notify (this=0x96a7a78, receiver=0x97deb08, e=0x9b48888) at kernel/qapplication.cpp:3704
#67 0x0115e42a in KApplication::notify (this=0x96a7a78, receiver=0x97deb08, event=0x9b48888) at ../../kdeui/kernel/kapplication.cpp:302
#68 0x009f1beb in QCoreApplication::notifyInternal (this=0x96a7a78, receiver=0x97deb08, event=0x9b48888) at kernel/qcoreapplication.cpp:704
#69 0x009f4623 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9643658) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#70 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9643658) at kernel/qcoreapplication.cpp:1345
#71 0x009f478d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#72 0x00a1dd0f in QCoreApplication::sendPostedEvents (s=0x96aef90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#73 postEventSourceDispatch (s=0x96aef90) at kernel/qeventdispatcher_glib.cpp:276
#74 0x08a36e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#75 0x08a3a730 in ?? () from /lib/libglib-2.0.so.0
#76 0x08a3a863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#77 0x00a1d805 in QEventDispatcherGlib::processEvents (this=0x96ad638, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#78 0x0721db35 in QGuiEventDispatcherGlib::processEvents (this=0x96ad638, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#79 0x009f0209 in QEventLoop::processEvents (this=0xbf874034, flags=) at kernel/qeventloop.cpp:149
#80 0x009f065a in QEventLoop::exec (this=0xbf874034, flags=...) at kernel/qeventloop.cpp:201
#81 0x009f484f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#82 0x0715e467 in QApplication::exec () at kernel/qapplication.cpp:3579
#83 0x02c7317e in kdemain (argc=1, argv=0x969c0b0) at ../../../../plasma/desktop/shell/main.cpp:112
#84 0x0804dff7 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x9644310 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051405 "0") at ../../kinit/kinit.cpp:717
#85 0x0804ec15 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#86 0x0804f08c in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#87 0x0804fe2f in main (argc=4, argv=0xbf874ae4, envp=0xbf874af8) at ../../kinit/kinit.cpp:1841

This bug may be a duplicate of or related to bug 228923.

Possible duplicates by query: bug 228923, bug 226596.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-03-05 18:12:22 UTC

*** This bug has been marked as a duplicate of bug 226596 ***